انجمن


ظاهر شدن ارور در بالای سایت  (۳ نوشته)

  • ~> Mr.vAhiD.DI <~

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۶۴۹
    تشکر شده: ۹۹۵ بار
    # نوشته شده: ۱۰ سال پیش
    ۷ بهمن ۱۳۸۹ - ۰۰:۴۲

    سلام...
    از چند ساعث پیش این ارورها در بالای سایتهای شبکه من نمایش داده می‌شه. می‌خوام ببینم دوستان دیگه هم با همچین اروری تابحال برخورد کردن؟؟ دلیلش چه چیزی می‌تونه باشه؟

    alchymyth 2010 */ global $wpdb; $querystr = "SELECT $wpdb->posts.* FROM $wpdb->posts WHERE $wpdb->posts.post_status = 'publish' AND $wpdb->posts.post_type = 'post' "; $pageposts = $wpdb->get_results($querystr, OBJECT); $counts = 0 ; if ($pageposts): foreach ($pageposts as $post): setup_postdata($post); $counts++; add_post_meta($post->ID, 'incr_number', $counts, true); update_post_meta($post->ID, 'incr_number', $counts); endforeach; endif; } add_action ( 'publish_post', 'updateNumbers' ); add_action ( 'deleted_post', 'updateNumbers' ); add_action ( 'edit_post', 'updateNumbers' ); function Get_Post_Number($postID){ $temp_query = $wp_query; $postNumberQuery = new WP_Query('orderby=date&order=DESC&posts_per_page=-1'); $counter = 1; $postCount = 0; if($postNumberQuery->have_posts()) : while ($postNumberQuery->have_posts()) : $postNumberQuery->the_post(); if ($postID == get_the_ID()){ $postCount = $counter; } else { $counter++; } endwhile; endif; wp_reset_query(); $wp_query = $temp_query; return $postCount; } ?>

    نمونش : http://vahid.yekweb.com/

    البته بگم من از مالتی‌یوزر استفاده میکنم ... جالبه که دستی هم به وردپرس نزدم !...

    دوستان آیا شما هم همین مشکل رو دارین یا خیر؟؟

  • Moeini

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۵۵۹
    تشکر شده: ۶۷۹ بار
    # نوشته شده: ۱۰ سال پیش
    ۷ بهمن ۱۳۸۹ - ۱۹:۴۰

    مثل اینکه مشکلتون حل شده !

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    ~> Mr.vAhiD.DI <~
  • ~> Mr.vAhiD.DI <~

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۶۴۹
    تشکر شده: ۹۹۵ بار
    # نوشته شده: ۱۰ سال پیش
    ۷ بهمن ۱۳۸۹ - ۲۱:۵۹

    بله معینی عزیز، مشکل از توابع function دات پی‌اچ‌پی یکی از پوسته‌ها بود که واقعاً برام جای سوال بود که چرا این ارور می‌داد در شرایطیکه اصلاً اون پوسته فعال نبوده !!! ولی به هر حال با چک اون کد در function ملکش برطرف شدو.

    با احترام

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Moeini

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.