انجمن


مشکل از بین رفتن آدرس فرم!  (۱۲ نوشته)

  • zilan

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۵
    تشکر شده: ۷ بار
    # نوشته شده: ۹ سال پیش
    ۷ اسفند ۱۳۸۹ - ۲۱:۱۰

    من یه فروم دارم توی ساب دامنه که بعد از فعال کردن قابلیت چندسایته دیگه وارد فروم نمی شه!
    لطفا راهنمایی کنید.

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۷ اسفند ۱۳۸۹ - ۲۲:۵۱

    مربوط به htaccess .می شه . از مقادیر پیش فرض استفاده کنید ببینید جواب می ده

  • zilan

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۵
    تشکر شده: ۷ بار
    # نوشته شده: ۹ سال پیش
    ۸ اسفند ۱۳۸۹ - ۱۳:۰۲

    با کدهای htaccess آشنایی ندارم.
    می شه بیشتر راهنمایی کنید

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۸ اسفند ۱۳۸۹ - ۲۳:۲۵

    از این مقادیر در اون فایل استفاده کنید ببینید مشکل حل می شه:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    یا:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  • zilan

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۵
    تشکر شده: ۷ بار
    # نوشته شده: ۹ سال پیش
    ۱۱ اسفند ۱۳۸۹ - ۲۳:۰۹

    الان این هست:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    لطفا راهنمایی کنید کدوم بخشش رو عوض کنم؟ چون اگه اون کدی رو که دادید بذارم فکر کنم دیگه امکان مولتی سایت از بین بره!

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۱۲ اسفند ۱۳۸۹ - ۱۸:۱۶

    جفتش رو بررسی کنید.
    مولتی سایت هم از بین نمی ره ;)

  • zilan

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۵
    تشکر شده: ۷ بار
    # نوشته شده: ۹ سال پیش
    ۱۲ اسفند ۱۳۸۹ - ۱۹:۰۸

    توی .htaccess روت یا فروم؟!
    جفتش رو توی .htaccess روت بررسی کردم و هیچ فرقس نکرد.
    با کد قبلی می رفت به صفحه ای که می گفت forum هنوز انتخاب نشده و شما می توینید از این آدرس استفاده کنید. این دوتا کد هم ریلود می کنه به صفحه اصلی : http://www.mysite.com

  • محمدمهدی میرزائی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵۰
    تشکر شده: ۳۱ بار
    # نوشته شده: ۹ سال پیش
    ۱۴ اسفند ۱۳۸۹ - ۲۰:۲۷

    فکر نمی کنم مشکل شما مربوط به htaccess . باشه .
    شما باید وارد قسمت تنظیمات در مدیر شبکه شوید و در فیلد نام های غیر مجاز نام ساب دامین تان را وارد کنید و با دکمه ذخیره تغییرات ، این تغییر را ثبت کنید.
    اگر نیاز بود از این تصویر نیز استفاده کنید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    zilan
  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۱۵ اسفند ۱۳۸۹ - ۱۴:۳۴

    ثابت زیر رو به wp-config.php قرار بدین
    مقدارش هم باید متناسب با سایتتون تغییر بدید
    define( 'NOBLOGREDIRECT', 'http://forum.mysite.com/' );

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    zilan
  • zilan

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۵
    تشکر شده: ۷ بار
    # نوشته شده: ۹ سال پیش
    ۱۷ اسفند ۱۳۸۹ - ۲۰:۳۲

    فکر نمی کنم مشکل شما مربوط به htaccess . باشه .
    شما باید وارد قسمت تنظیمات در مدیر شبکه شوید و در فیلد نام های غیر مجاز نام ساب دامین تان را وارد کنید و با دکمه ذخیره تغییرات ، این تغییر را ثبت کنید.
    اگر نیاز بود از این تصویر نیز استفاده کنید.

    این کار رو قبلا انجام دادم!

    ثابت زیر رو به wp-config.php قرار بدین
    مقدارش هم باید متناسب با سایتتون تغییر بدید

    الان دیگه لود نمی شه!

  • محمدمهدی میرزائی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵۰
    تشکر شده: ۳۱ بار
    # نوشته شده: ۹ سال پیش
    ۱۷ اسفند ۱۳۸۹ - ۲۳:۵۸

    قسمت مربوط به ساب دامین در کنترل پنل سی پنل را چک کنید ؛‌ احتمال دارد ساب دامنه مربوط به فروم حذف شده باشد که باید دوباره ایجاد شود.

  • HRST

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷
    # نوشته شده: ۹ سال پیش
    ۱۴ خرداد ۱۳۹۰ - ۱۵:۳۰

    سلام
    من هم دقیقاً همین مشکل رو دارم
    ظاهرا مشکل حل نشده !
    آدرس فوروم ردایرکت میشه به صفحه ایجاد وبلاگ
    چرا ؟
    البته وقتی وب سرور من کلوکسو بود فوروم راحت کارش رو انجام میداد ...
    اما وقتی دایرکت ادمین نصب کردم آدرس فوروم این شکلی شده ....

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.