انجمن


استفاده از moz-border در css  (۷ نوشته)

  • نوین ادمین

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۶
    تشکر شده: ۶۷ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۶ اردیبهشت ۱۳۹۰ - ۱۷:۳۸

    سلام . ببخشید این سوال رو نمیدونستم کجا مطرح کنم مجبور شدم اینجا بگم .
    من از دستور
    -moz-border-radius:5px;
    -webkit-border-radius:5px;
    برای گرد کردن گوشه های کادر های سایتم استفاده کردم . اما وقتی میرم سایت http://jigsaw.w3.org/css-validator/ کلی ارور میده و میگه این دستور وجود نداره .
    این دستور مال css3 هستش. من چطور میتونم css سایتم رو به ورژن ۳ ارتقا بدم ؟ باید کلاً کدهاش دوباره نوشته بشه یا میشه روی همین کار کرد درست شه ؟
    ممنون

    http://www.mohandesyar.com

  • rock

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۲
    تشکر شده: ۶۳ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۶ اردیبهشت ۱۳۹۰ - ۱۹:۱۰

    دوست عزیز css3 رومیخوایید برای چه؟ IE که پشتیبانی نمیکنه از خاصیت ها بعلاوه این دستورها فعلا وجود ندارند اگه هدفتون صفحات پویا هستند میتونید از فتوشاپ کمک بگیرید اینطوری validator ایراد نمیگیره!شما ازهمه جای وب یکمی دیدن کنید می بینید سایت ها بزرگ هم از css3 فعلا استفاده نمی کنند بعلاوه تا اونجایی که میدونم css3 برای چند مورد کوچیک استفاده میشه پس پیشنهاد من اینه که فعلا ها بیخیالش بشید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Mostafa - نوین ادمین
  • Morteza

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۳۴۰۲
    تشکر شده: ۳۱۲۸ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۷ اردیبهشت ۱۳۹۰ - ۱۷:۲۵

    کاملا با گفته های دوستمون در پست بالا مخالفم!
    css3نسل بعدی هست و الان هم بطور کامل پشتیبانی میشه. در همه مرورگرها! حتی ie
    خود مایکروسافت هم اذعان کرده که ie9 پشتیبانی کامل داره و بقیه مرورگرها هم حدود یکسالی هست از css3 و html5 پشتیبانی میکنن.
    دراکثر سایتهای بزرگ هم داره استفاده میشه. میتونم براتون مثالهای نامحدودی بزنم.

    نکته بعدی هم در مورد پویایی سایت هست که من نفهمیدم چه ربطی به فتوشاپ داره!
    برای پویایی بیشتر باید از js و فریمورکهای وابسته یا silverlight و امثالهم استفاده کنید.

    در نهایت شما از این دستورات استفاده کن و هیچ موردی هم نداره.
    نهایتا یک چکر بزارید که برای ورژنهای پایین ie پیامی به کاربر مبنی بر قدیمی بودن مرورگرش بده.

    موفق باشید

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    نوین ادمین
  • نوین ادمین

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۶
    تشکر شده: ۶۷ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۷ اردیبهشت ۱۳۹۰ - ۱۷:۴۱

    میتونید از فتوشاپ کمک بگیرید

    به نظر من این کار درست نیست . تعداد درخواست ها از سرور به دلیل بالا رفتن تعداد عکس ها زیاد میشه و این یعنی سرعت سایت رو فدای زیبایی کردن .

    در نهایت شما از این دستورات استفاده کن و هیچ موردی هم نداره.

    راستش سوال منم همینه . الان استفاده کردم و خوشبختانه سایت نسبت به قالب اصلی که خریداری کردم خیلی بهتر شده . اما مشکل همینه که ارور میده توی اون ولیدیتور .
    با جناب میثم ضابط مدیر وب سایت ضابط هم مشورت کردم ایشون گفتن که استفاده کنم اما با احتیاط (که البته زیاد متوجه لفظ با احتیاط نشدم)
    یکی از دوستان لینک زیر رو پیشنهاد دادن که مطالعه کنم .
    http://scgowda.com/blog/how-to-add-valid-css3-badge-to-your-website
    طبق این مقاله میتونم ولیدیتم رو بر اساس css3 انجام بدم . اما با این کار متوجه شدم باز هم همین ارور وجود داره و مثل اینکه این کد اصلاً به css3 هم ربط نداره و مثل اینکه در حال حاضر (طبق گفته جناب ضابط) این تکه کد مورد تایید w3 نیست .
    حالا ما استفاده می کنیم ببینیم کی این مشکل حل میشه . از دوستانی که در این فروم و خارج از این فروم کمک کردن تشکر میکنم .

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    saeid223 - Morteza
  • saeid223

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۸
    تشکر شده: ۱۶ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۷ اردیبهشت ۱۳۹۰ - ۱۷:۴۵

    ببخشید اگه پستم اسپم میشه
    اما کاملا با حرف های دوست و استاد عزیز من تو من موافقم
    من خودم در حال حاضر قالبی دارم که از css3 کارکرده و الان چندتا از قالب ها رو که فارسی کردم همشون css3 داشتن
    اینم بگم که قالب ها از سایت حرفه ای themeforest بودن و تا حالا با ie9 مشکل نداشتن
    اگه قرار بود css3 کار نکنیم، پس حرفه ها چرا به دنبالشن؟
    نیاز نیست شما چیزیو ارتقاء بدی! این مرورگرها هستن که باید خودشونو با css3 تطبیق و ارتقاء بدن!
    در حقیقت css3 یه پروتکل از پیش تعیین شده س که مرورگرها با اون انطباق می یابند

    موفق باشید

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    نوین ادمین - Morteza
  • نوین ادمین

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۶
    تشکر شده: ۶۷ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۷ اردیبهشت ۱۳۹۰ - ۱۷:۴۸

    نیاز نیست شما چیزیو ارتقاء بدی! این مرورگرها هستن که باید خودشونو با css3 تطبیق و ارتقاء بدن!
    در حقیقت css3 یه پروتکل از پیش تعیین شده س که مرورگرها با اون انطباق می یابند

    اینطور که متوجه شدم نیاز نیست من کاری انجام بدم . بعضی کد هایی که مربوط به css3 میشن و بدون هیچ تفاوتی با کدهای دیگه css2.1 در کنار هم قرار میدم و این مرورگره که باید بتونه اونها رو بخونه و اعمال کنه .
    مرسی

  • rock

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۲
    تشکر شده: ۶۳ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۷ اردیبهشت ۱۳۹۰ - ۱۹:۰۷

    اولا دوستان عزیز با اینکه موضوع حل شده است ولی فکر کنم بعدن ها این مطلبو بخونند....
    فعلا تو مملکت ماIE7 تازه اومده به کار...من اینو با اطمینان میگم!
    بعدش هر قالبی که به صورت زیبا باگرافیک ایجاد شده از نظر من پویا هست منظورمن رو فکر کنم دقیقا نفهمیدید. نیازی به اسکریپت سازی قالب نیست چکر هم برای همه ی ایران فعال میشه!!!!!!!!!!!!!!!!!
    من نظر شخصی دادم در ضمن با یکی دوکیلوبایت پهنای باند سایتی منفجر نشده!!!
    به هر حال پیشنهاد من میزان کاربرد مرورگر بود نه میزان ارزش!
    به هر حال ازهمتون ممنون.

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.