انجمن


مشکل ویلدکارد و دایرکت ادمین  (۷ نوشته)

  • HRST

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷
    # نوشته شده: ۸ سال پیش
    ۱۲ خرداد ۱۳۹۰ - ۱۵:۳۶

    سلام
    وردپرس من مولتی یوزر هست و به تازگی دایرکت ادمین نصب کردم .... وب سرور قبلی کلوکسو بود که واقعاً هم خوب بود و هیچ مشکل با وردپرس مولتی یوزر نداشت .
    اما حالا بعد از اینکه ویلدکارت رو در دایرکت ادمین فعال میکنم ، وبلاگ ها باز میشند و مشکلی نیست اما ساب دومین فوروم که مجازی نیست از کار میفته و سایت اصلی باز میشه ... خلاصه الان وضعیت اینطور هست که یا باید ساب دومین های مجازی کار کنن و یا ویلدکارد رو غیر فعال کنم تا فوروم کار کنه !! ... من اولین بار هست دارم با دایرکت ادمین کار میکنم و حسابی اعصاب من رو بهم ریخته .... خواهش مکنم راهنمایی کنید .

    آدرس فوروم به این شکل هست ===> http://www.forum.mysite.com
    که بعد از فعال سازی ویلدکارت از کار میفته .
    ویلدکارت رو به این صورت فعال کردم ...
    ابتدا : A myip * رو اضافه کردم و در قسمت Custom HTTPD Configurations هم عبارت|ServerAlias *.|DOMAIN

    چیکار کنم که به ساب دومین فوروم کاری نداشته باشه ؟

  • www.iransa.com

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۴
    تشکر شده: ۹ بار
    # نوشته شده: ۸ سال پیش
    ۱۲ خرداد ۱۳۹۰ - ۱۸:۴۲

    چون وبلاگ های شما بصورت ساب دومین ساخته می شود و سیستم هم از این نوع آدرس تبعیت میکند ، طبیعی است که چون وبلاگی بنام فرم ندارید به صفحه اول و یا صفحه ریجستر منتقل شوید / مطمئنا آدرس فرم شما بصورت ساب دایرکتوری باز میشود یعنی به این صورت :

    http://www.mysite.com/forum

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    HRST - Mostafa
  • HRST

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷
    # نوشته شده: ۸ سال پیش
    ۱۲ خرداد ۱۳۹۰ - ۱۹:۴۵

    http://www.iransa.com گفت:
    چون وبلاگ های شما بصورت ساب دومین ساخته می شود و سیستم هم از این نوع آدرس تبعیت میکند ، طبیعی است که چون وبلاگی بنام فرم ندارید به صفحه اول و یا صفحه ریجستر منتقل شوید / مطمئنا آدرس فرم شما بصورت ساب دایرکتوری باز میشود یعنی به این صورت :

    http://www.mysite.com/forum

    ممنونم از پاسخ شما ...
    بله درسته .... آدرس فوروم هم بهمین صورت که گفتید نیز وجود داره ... و من با ساختن ساب دامین خواستم آدرس به این صورت بشه .... http://www.forum.mysite.com .... همیشه آدرس فوروم به این شکل بوده ... و نمیشه ازش گذشت ... چون دیگه جا افتاده بود ....
    مسئله اینه من وقتی با وب سرور کلوکسو کار میکردم اصلاً همچین مشکلی نداشتم ! .... یعنی وقتی ساب دومینی موجود بود وردپس دیگه اون رو به صفحه رجیستر منتقل نمیکرد .... اما الان که با دایرکت ادمین هستم انگار نه انگار که ساب دامین فوروم وجود فیزیکی داره ! اصلاً انگار نمیبینتش .... و آدرس رو به صفحه رجیستر منتقل میکنه ....
    الان ویلدکار رو از کار انداختم تا فوروم با آدرس ساب دومین بیاد بالا و وبلاگها هم باز نمیشند ....
    حسابی گیج شدم و از این وضعیت خسته شدم .... کمکم کنید ...

  • www.iransa.com

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۴
    تشکر شده: ۹ بار
    # نوشته شده: ۸ سال پیش
    ۱۲ خرداد ۱۳۹۰ - ۲۲:۰۵

    دوست عزیز شما میتوانید نوع آدرس دادن وبلاگ هایتان را از ساب دومین به ساب دایرکتوری تغییر بدید تا فروم شما بصورت ساب دومین باز شود به این صورت :

    http://www.forum.mysite.com
    http://www.mysite.com/blogs

  • HRST

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷
    # نوشته شده: ۸ سال پیش
    ۱۴ خرداد ۱۳۹۰ - ۱۱:۳۶

    http://www.iransa.com گفت:
    دوست عزیز شما میتوانید نوع آدرس دادن وبلاگ هایتان را از ساب دومین به ساب دایرکتوری تغییر بدید تا فروم شما بصورت ساب دومین باز شود به این صورت :

    http://www.forum.mysite.com
    http://www.mysite.com/blogs

    ممنون از پیشنهادتون .... اما آدرس وبلاگها سالها بصورت ساب دامین بوده و نمیتونم تغییر بدم ....

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۸ سال پیش
    ۱۶ خرداد ۱۳۹۰ - ۱۷:۵۶

    ثابت زیر رو در wp-config.php به کار ببرید ببینید مورد حل می‌شه:
    define('NOBLOGREDIRECT', 'http://www.forum.mysite.com/');

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    aghili
  • امین

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴۷
    تشکر شده: ۶۴ بار
    # نوشته شده: ۶ سال پیش
    ۱۳ فروردین ۱۳۹۲ - ۰۰:۲۴

    HRST گفت:
    سلام
    وردپرس من مولتی یوزر هست و به تازگی دایرکت ادمین نصب کردم .... وب سرور قبلی کلوکسو بود که واقعاً هم خوب بود و هیچ مشکل با وردپرس مولتی یوزر نداشت .
    اما حالا بعد از اینکه ویلدکارت رو در دایرکت ادمین فعال میکنم ، وبلاگ ها باز میشند و مشکلی نیست اما ساب دومین فوروم که مجازی نیست از کار میفته و سایت اصلی باز میشه ... خلاصه الان وضعیت اینطور هست که یا باید ساب دومین های مجازی کار کنن و یا ویلدکارد رو غیر فعال کنم تا فوروم کار کنه !! ... من اولین بار هست دارم با دایرکت ادمین کار میکنم و حسابی اعصاب من رو بهم ریخته .... خواهش مکنم راهنمایی کنید .

    آدرس فوروم به این شکل هست ===> http://www.forum.mysite.com
    که بعد از فعال سازی ویلدکارت از کار میفته .
    ویلدکارت رو به این صورت فعال کردم ...
    ابتدا : A myip * رو اضافه کردم و در قسمت Custom HTTPD Configurations هم عبارت|ServerAlias *.|DOMAIN
    چیکار کنم که به ساب دومین فوروم کاری نداشته باشه ؟

    سلام
    چطوری "در قسمت Custom HTTPD Configurations هم عبارت|ServerAlias *.|DOMAIN" اضافه کردید؟
    چون فکر نکنم بشه توی این قسمت مستقیم چیز نوشت؟
    راستی اصلا لزومی داره اینو بنویسیم یا نه؟

درباره‌ی این موضوع