انجمن


مشکل با افزونه تی نی اسلایدر  (۹ نوشته)

  • internet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۳
    تشکر شده: ۱۲ بار
    # نوشته شده: ۹ سال پیش
    ۲۲ خرداد ۱۳۹۰ - ۱۳:۰۹

    سلام
    افزونه رو نصب کردم کد مربوطه رو در فایل اصلی قالب index.php گذاشتم همه تصاویر رو وسط صفحه زیر هم نشون می ده
    تصویر مشکل رو در زیر گذاشتم:
    http://www.novinupload.com/do.php?img=6515

    مسئله دیگه اینکه بعد از نصب رفت در کنترل پنل و در باکس اول سمت راست یا نوشته ها قرار گرفت در باکس پلاگین ها پایین نصب نشد که خوب زیاد هم مهم نیست
    با تشکر

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۲۳ خرداد ۱۳۹۰ - ۱۱:۴۱

    سلام، امکان داره در پوسته شما فایل های js دیگری لود می‌شه، که با js این افزونه تداخل داشته باشه!
    موقت افزونه هارو غیرفعال کنید ببینید درست می‌شه.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    internet
  • internet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۳
    تشکر شده: ۱۲ بار
    # نوشته شده: ۹ سال پیش
    ۲۳ خرداد ۱۳۹۰ - ۱۲:۳۳

    اقا می شه اینجا رو هم برام اوکی کنید ممنون می شم
    http://forum.wp-persian.com/topic/13297

  • internet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۳
    تشکر شده: ۱۲ بار
    # نوشته شده: ۹ سال پیش
    ۲۴ خرداد ۱۳۹۰ - ۱۸:۱۰

    مصطفی خان من تست کردم اسلایدرهای دیگه در فایل های دیگه قالب هم گذاشتم
    کلا وقتی می زارم اسلایدر رو نمی تونه ران کنه فقط به صورت تصویری می یاره زیر هم مثل تصویری که گذاشتم
    اسلایدرهای دیگه هم نصب کردم فایده ای نداشت
    چیکار باس بکنم
    لطفا کدی که باعث این مشکل می شه یا کمبود کد رو بفرمائید تا در قالب بزارم
    با تشکر

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۲۴ خرداد ۱۳۹۰ - ۲۱:۱۱

    همانطور که گفتم، احتمال داره از پوسته باشه که دستورات js اون با افزونه تداخل داره!

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    internet
  • internet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۳
    تشکر شده: ۱۲ بار
    # نوشته شده: ۹ سال پیش
    ۲۷ خرداد ۱۳۹۰ - ۰۷:۵۵

    همونطوری که در سایت مطرح کردم مشکل از کد:
    <?php wp_head(); ?>
    هست اش
    این کد رو اگه از قالب بردارم کلا از این قبیل پلاگین های متحرک محروم می شم
    اگه بگذارم یه فاصله اضافی از قسمت بالای قالب در مرورگر IE برام ایجاد می شه که قبلا اینجا مطرح کردم:
    http://forum.wp-persian.com/topic/13287
    و به کمک دوستان و استفاده از کد:

    <?php
    	global $is_IE;
    	if (!$is_IE) {
    	wp_head(); }
    ?>

    تونستم این فاصله اضافی که بالای قالب ایجاد می شد رو مرتفع کنم
    ولی ظاهرا در مرورگر IE کلا با این کد قالب رو معلول کردم و دیگه نمی تونه در این مرورگر این کد اجرا بشه
    و الان موندم مشکل رو چه طور باس حل کنم
    اگه این کد:
    <?php wp_head(); ?>
    بردارم از این قبیل پلاگین ها در سایت کار خواهد کردم ولی اگه بگذارم خیر
    با تشکر

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۲۷ خرداد ۱۳۹۰ - ۱۴:۲۸

    اگه بگذارم یه فاصله اضافی از قسمت بالای قالب در مرورگر IE برام ایجاد می شه که قبلا اینجا مطرح کردم:

    خب یک استایل جداگانه برای ie بنویسید و بگردید ببینید اون فاصله خالی در کدوم عنصر هست که در ie مشکل داره. اونو بهش مقدار دیگری بدین.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    internet
  • internet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۳
    تشکر شده: ۱۲ بار
    # نوشته شده: ۹ سال پیش
    ۲۷ خرداد ۱۳۹۰ - ۱۵:۵۶

    قالب رو که نمی تونم تغییر بدهم
    منظورتون از عنصر چیه و چه طور می شه فهمید؟
    <?php wp_head(); ?>
    گفتم که این کد رو که بردارم قالب درست می شه در IE
    این کد رو بزارم قالب یه فاصله اضافی بالاش می افته

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۳۱ خرداد ۱۳۹۰ - ۲۱:۳۷

    لینک سایتتون رو بدین.

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.