انجمن


زبان فارسی به مشکل خوردم کمک ؟!!  (۱۰ نوشته)

  • 021kids

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۹
    # نوشته شده: ۱۳ سال پیش
    ۸ خرداد ۱۳۸۷ - ۲۱:۰۳

    سلام دوستان
    سایت من
    http://021kids.com/MR.Copy/
    این است الان فارسی روش نصب کردم ولی حر چی فارسی می نویسم ؟؟؟؟؟؟؟؟ به این صورت در میاره نمی دونم چی کار کنم جریان واقعا نمی دونم چیه؟! ~X( 8-|
    لطفا کمکم کنید
    با تشکر
    Crash @},-

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۳ سال پیش
    ۸ خرداد ۱۳۸۷ - ۲۲:۰۸

    مطمئنن اگه قبل از نوشتن جستجو می‌کردین به نتایج جالبی می‌رسیدین:

    http://forum.wp-persian.com/topic/1009?replies=26

  • 021kids

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۹
    # نوشته شده: ۱۳ سال پیش
    ۸ خرداد ۱۳۸۷ - ۲۳:۳۴

    سلام دوست عزیز
    من جستجو کردم ولی به جوابی نرسیدم
    config ro utf-8 کردم ولی باز جواب نداد
    نمی دونم واقعا چی کار کنم
    باز هم معذرت می خوام که وقتتون رو گرفتم

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۳ سال پیش
    ۹ خرداد ۱۳۸۷ - ۰۱:۰۰

    DB_CHARSET و DB_COLLATE رو یونیکد کردین؟

  • بهرنگ

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۱۳۹۹
    تشکر شده: ۴۵۱ بار
    # نوشته شده: ۱۳ سال پیش
    ۹ خرداد ۱۳۸۷ - ۱۰:۲۵

    خب وقتی از اول utf-8 نکرده باشین جواب نمیده دیگه...
    از اول دیتا بیستون رو پاک کنید و از نو بسازید...

  • کاربر

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۸
    تشکر شده: ۱۲ بار
    # نوشته شده: ۱۳ سال پیش
    ۱۰ خرداد ۱۳۸۷ - ۰۲:۰۷

    لينك زير را هم ببينيد،
    http://forum.wp-persian.com/topic/1348

  • 021kids

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۹
    # نوشته شده: ۱۳ سال پیش
    ۱۰ خرداد ۱۳۸۷ - ۱۵:۱۸

    سلام دوست عزیز من همه ی کارها رو انجام دادم
    یه دفعه هر دوشون رو یونی کد کردم
    یه دفعه هم ‍اکش کردم ولی باز........

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', ''); // The name of the database
    define('DB_USER', ''); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_COLLATE', '');

    // Change SECRET_KEY to a unique phrase. You won't have to remember it later,
    // so make it long and complicated. You can visit https://www.grc.com/passwords.htm
    // to get a phrase generated for you, or just make something up.
    define('SECRET_KEY', 'put your unique phrase here'); // Change this to a unique phrase.

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'fa_IR');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    http://021kids.com/MR.Copy/

    با تشکر

  • behroooz

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۴
    تشکر شده: ۴۴ بار
    # نوشته شده: ۱۳ سال پیش
    ۱۱ خرداد ۱۳۸۷ - ۰۲:۰۹

    021kids گفت:
    سلام دوست عزیز من همه ی کارها رو انجام دادم
    یه دفعه هر دوشون رو یونی کد کردم
    یه دفعه هم ‍اکش کردم ولی باز........

    این پاسخ سوال شما نیست ، راهنمایست :D
    دوست عزیز با استفاده از گزینه دستور می تونید کدها رو درست جایگزین کنید . مثلا کدهای شما باید به این صورت
    توی صفحه ظاهر بشن :

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', ''); // The name of the database
    define('DB_USER', ''); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_COLLATE', '');
    
    // Change SECRET_KEY to a unique phrase. You won't have to remember it later,
    // so make it long and complicated. You can visit https://www.grc.com/passwords.htm
    // to get a phrase generated for you, or just make something up.
    define('SECRET_KEY', 'put your unique phrase here'); // Change this to a unique phrase.
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'fa_IR');
    
    /* That's all, stop editing! Happy blogging. */
    
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
  • کاربر

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۸
    تشکر شده: ۱۲ بار
    # نوشته شده: ۱۳ سال پیش
    ۱۱ خرداد ۱۳۸۷ - ۱۹:۱۰

    @ 021kids
    دوست عزيز، من كاربر تازه كاري هستم و به همچين مشكلي هم برخوردم، اما خيلي راحت با راهنمايي ديگر عضو ها مشكلم رو حل كردم و به نظر من اين مشكل راه حلش همينيه، كه ديگر دوستان به صفحاتي كه مشابه به مشكل شما بود لينكش رو قرار دادن تا مشكل شما حل بشه.

    متاسفانه من نتونستم سايت شما رو ببينم، سايت شما فيلتر شده، نميدونم چرا، فيلترينگ هوشمند ديگه! اگر در گوگل "ويندوز اكس پي" رو هم تايپ كني، مي بيني نتايج جستجو برات فيلتر شده! به هر حال در شهر كوچك ما همين يه آي اس پي هست كه بايد باهاش بسازيم :)

    احتمالا به همين دليل شما فعلا مطلبي پست نمي كنيد، اگر مي توانيد وردپرس را حذف كنيد و مجددا نصب كنيد، سپس بايد به طريق زير عمل كنيد (من اينطور عمل كردم و مشكل حل شد، من از پنل cPanel استفاده مي كنم و فرض مي كنم كه شما هم وردپرس را در مسير public_html نصب كرديد):
    - بسته فارسي ساز را از همين سايت برداشت كنيد. (برداشت فارسي ساز وردپرس 2.5)
    - بسته را از حالت فشرده خارج كنيد و سپس محتويات پوشه خارج شده را به در مسير "public_html" بفرستيد. (فايل هاي آپلود شده بايد روي فايل هاي جديد مجددا نوشته شوند، رونويسي، overwrite)
    - در پوشه "public_html" فايلي با نام "wp-config.php" را توسط يك ويرايشگر متن (code editor, editor) باز كنيد و عبارت زير را پيدا كنيد:
    define('WPLANG', ' ');

    سپس آن را به صورت زير تغيير دهيد:
    define('WPLANG', 'fa_IR');

    حالا بايد دستوري را كه باعث مي شود متون به شكل علامت سوال در آيند را در همين فايل "wp-config" حذف كنيد، خط زير را بيابيد و سپس آن را حذف كنيد (براي راهنمايي بيشتر، در فايل "wp-config" نام كاربري و كلمه رمز ورود شما به پنل وردپرس وجود دارد):
    define('DB_CHARSET', 'utf8');

    با اطلاعاتي ناچيزي كه خودم در اين زمينه داشتم، چگونگي كار رو براي شما توضيح دادم، اميدوارم كه موفق بشيد (حل ميشه :-) )
    پيشنهاد مي كنم اگر نتونستيد مشكل رو حل كنيد، نام كاربري و كلمه رمز ورود به فضايي كه خريداري كرديد رو به يكي از همين عضو هاي استاد و وارد به كار در wp-persian.com بديد و از آن ها در خواست كنيد كه اين كار رو براي شما انجام بدن، اگر براشون امكان باشه حتما اين كار را انجام خواهند داد.

  • 021kids

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۹
    # نوشته شده: ۱۳ سال پیش
    ۱۴ خرداد ۱۳۸۷ - ۰۰:۱۳

    دوستان محترم
    از تمام ‍پاسخهاتون ممنون بالاخره درست شد
    مشکل به قدری خنده دار که روم نمی شه بگم! :)) :P
    ?> آخر کد پریده بود همین! :O
    چجوری خودمم نمیدونم! خنده دار اینه که انقدر رفته بودم تو کف کد نویسی که یادم رفت بابا این آکولاد ها و پرانتز ها باید بسته شنا!
    بازم از پشتیبانی عالیتون ممنونم ;-)

درباره‌ی این موضوع



برچسب‌ها