انجمن


افزونه HExam برای ایجاد آزمون  (۹ نوشته)

  • برف سوخته

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۶
    تشکر شده: ۸۹ بار
    # نوشته شده: ۸ سال پیش
    ۵ شهریور ۱۳۹۰ - ۱۵:۴۶

    با سلام
    بنا به سوال یکی از دوستان در تاپیک زیر
    http://forum.wp-persian.com/topic/15306
    یه سرچ تو مخزن افزونه های وردپرس زدم و یک افزونه خوب دستگیرم شد که لینکشو برای دوست عزیزی که سوال کرده بود گذاشتم.
    خودم دانلودش کردم تا فارسیش کنم دیدم افزونه استاندارد نیست.(با poedit نمیشه فارسیش کرد).
    واسه همین دست بردم تو اصلش و از فایل php اصلی فارسیش کردم.
    این افزونه برای ایجاد انواع آزمون های گزینه ای طراحی شده که باهاش میشه اینکارا رو کرد:
    1- ایجاد آزمون چند گزینه که فرد پس از پاسخگویی به سوالات نتیجه عملکرد خود را ببیند1
    2- ایجاد آزمون مسابقه ای که نتایج تنها به کاربران عضو وارد شده اعلام میشود و مدیر سایت هر وقت خواست میتواند نتایج را با دو کلیک منتشر کند.
    3- و ....
    امکاناتش هم خوبه:
    و امکاناتش:
    1- قابلیت شمارش خودکار پاسخ های صحیح
    2- ارسال تمام اطلاعات شرکت کننده به مدیر توسط ایمیل
    3- و ....
    هم اکنون نسخه فارسی شده توسط این حقیر را از آدرس زیر دریافت دارید:
    http://parsaspace.com/files/8237214884/?c=896

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    hamed-sepehr
  • Omid Sh

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۷۸۲
    تشکر شده: ۹۱۷ بار
    # نوشته شده: ۸ سال پیش
    ۵ شهریور ۱۳۹۰ - ۱۶:۱۰

    سلام
    اینجوری فارسی کردن به درد نمی‌خوره دوست عزیز!
    شما با این کار افزونه رو غیر استاندارد کردین!
    بعد از آپدیت افزونه تمام ترجمه‌های شما از بین میره.
    سعی کنید با poedit ترجمه کنید.
    همه‌ی افزونه‌ها با poedit ترجمه میشن و استانداردش همینه، منظورتون رو از استاندارد نبودن افزونه نفهمیدم!

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    omid0098 - R
  • برف سوخته

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۶
    تشکر شده: ۸۹ بار
    # نوشته شده: ۸ سال پیش
    ۵ شهریور ۱۳۹۰ - ۲۱:۴۱

    OmidSh گفت:
    سلام
    اینجوری فارسی کردن به درد نمی‌خوره دوست عزیز!
    شما با این کار افزونه رو غیر استاندارد کردین!
    بعد از آپدیت افزونه تمام ترجمه‌های شما از بین میره.
    سعی کنید با poedit ترجمه کنید.
    همه‌ی افزونه‌ها با poedit ترجمه میشن و استانداردش همینه، منظورتون رو از استاندارد نبودن افزونه نفهمیدم!

    دوست عزیز این افزونه حتی با ایجاد فایل pot هم ترجمه نمیشه که من بخوام با poedit ترجمش کنم.

  • Omid Sh

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۷۸۲
    تشکر شده: ۹۱۷ بار
    # نوشته شده: ۸ سال پیش
    ۶ شهریور ۱۳۹۰ - ۱۱:۴۲

    bat_hex گفت:

    دوست عزیز این افزونه حتی با ایجاد فایل pot هم ترجمه نمیشه که من بخوام با poedit ترجمش کنم.

    من الآن افزونه رو بررسی کردم. افزونه کاملا استاندارد هست و میشه ترجمش کرد.
    چون رشته‌ها قابل ترجمه نیستند، شما نتونستید ترجمش کنید!
    اول باید رشته‌ها رو قابل ترجمه کنید که لازمش دونستن php هست.
    اگر نمی‌تونید بهتره اینجوری افزونه رو منتشر نکنید و لینکش رو بردارید.

  • hamed-sepehr

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۴
    تشکر شده: ۴۴ بار
    # نوشته شده: ۸ سال پیش
    ۶ شهریور ۱۳۹۰ - ۱۴:۳۵

    OmidSh گفت:

    من الآن افزونه رو بررسی کردم. افزونه کاملا استاندارد هست و میشه ترجمش کرد.
    چون رشته‌ها قابل ترجمه نیستند، شما نتونستید ترجمش کنید!
    اول باید رشته‌ها رو قابل ترجمه کنید که لازمش دونستن php هست.
    اگر نمی‌تونید بهتره اینجوری افزونه رو منتشر نکنید و لینکش رو بردارید.

    ببخشید ولی به نظر من بهتره افزونه باشه ولی در کنارش به کاربرا اخطار داده بشه که اگه آپدیتش کنن انگلیسی میشه.

  • برف سوخته

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۶
    تشکر شده: ۸۹ بار
    # نوشته شده: ۸ سال پیش
    ۶ شهریور ۱۳۹۰ - ۱۵:۱۸

    OmidSh گفت:

    من الآن افزونه رو بررسی کردم. افزونه کاملا استاندارد هست و میشه ترجمش کرد.
    چون رشته‌ها قابل ترجمه نیستند، شما نتونستید ترجمش کنید!
    اول باید رشته‌ها رو قابل ترجمه کنید که لازمش دونستن php هست.
    اگر نمی‌تونید بهتره اینجوری افزونه رو منتشر نکنید و لینکش رو بردارید.

    اگه منظورتون

    add_action('init', 'init_textdomain');
    function init_textdomain(){
    load_plugin_textdomain('potfilename',PLUGINDIR . '/' .
    dirname(plugin_basename (__FILE__)) . '/lang');
    }

    و
    <?php _e(‘text’, ‘potfielname’); ?>
    هست باید بگم دوست عزیز دارم روش کار میکنم ولی وقته زیادی ندارم که هر روز کلی وقت بزارم.
    بزودی انشالا درستشو ارائه میکنم

  • Omid Sh

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۷۸۲
    تشکر شده: ۹۱۷ بار
    # نوشته شده: ۸ سال پیش
    ۶ شهریور ۱۳۹۰ - ۱۷:۱۲

    hamed-sepehr گفت:

    ببخشید ولی به نظر من بهتره افزونه باشه ولی در کنارش به کاربرا اخطار داده بشه که اگه آپدیتش کنن انگلیسی میشه.

    خیر، این کار بسیار اشتباهی هست. شاید افزونه باگ داشته باشه.

    هست باید بگم دوست عزیز دارم روش کار میکنم ولی وقته زیادی ندارم که هر روز کلی وقت بزارم.
    بزودی انشالا درستشو ارائه میکنم

    بله، منظورم همین بود.
    استانداردش همینه.
    موفق باشید

  • برف سوخته

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۶
    تشکر شده: ۸۹ بار
    # نوشته شده: ۸ سال پیش
    ۶ شهریور ۱۳۹۰ - ۲۱:۳۰

    OmidSh گفت:

    شاید افزونه باگ داشته باشه.

    دوست عزیز سلامت باشی ولی تهمت خیلی بدی زدی من اونقدر php م خوب نیست که بخوام باگ ایجاد کنم و اصلا ایجاد باگ رو بلد نیستم.
    ثانیا بدلیل این فارسی شکل استاندارد رو به این زودی نمیتونم ارائه بدم چون اولا خودم درگیر مسائل قالب سایتمم ثانیا این روش با لوکال هاست من مشکل داره و باید روی هاست امتحانش کنم.
    سلامت باشید.

  • Omid Sh

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۷۸۲
    تشکر شده: ۹۱۷ بار
    # نوشته شده: ۸ سال پیش
    ۶ شهریور ۱۳۹۰ - ۲۱:۵۶

    bat_hex گفت:

    دوست عزیز سلامت باشی ولی تهمت خیلی بدی زدی من اونقدر php م خوب نیست که بخوام باگ ایجاد کنم و اصلا ایجاد باگ رو بلد نیستم.
    ثانیا بدلیل این فارسی شکل استاندارد رو به این زودی نمیتونم ارائه بدم چون اولا خودم درگیر مسائل قالب سایتمم ثانیا این روش با لوکال هاست من مشکل داره و باید روی هاست امتحانش کنم.
    سلامت باشید.

    پسر خوب نگفتم شما باگ ایجاد کردین.
    منظورم این بود که شاید افزونه مشکل داشته باشه و سازنده افزونه، آپدیت جدید ارائه بده. و اگر آپدیت نشه دچار مشکل میشه. پاک کردن صورت مسئله و آپدیت نکردن کار درستی نیست.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    R - omid0098

درباره‌ی این موضوع