انجمن


غير فعال شدن آپلود فايل در وردپرس  (۸ نوشته)

  • iranp

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۱
    تشکر شده: ۴۶ بار
    # نوشته شده: ۸ سال پیش
    ۵ آبان ۱۳۹۰ - ۱۵:۳۰

    با سلام خدمت دوستان عزيز
    چند روزي هست يك هاست گرفتم و سايتم رو بر روي آن راه اندازي كردم ، امروز مي خواستم مطلبي بنويسم ، براي آپلود عكس با ارور زير مواجه شدم ( هم از ارسال كننده فلش و هم از معمولي استفاده كردم ).

    ارور:
    "
    پرونده خالی است. لطفاً پرونده‌ای قابل قبول بارگذاری کنید. این خطا ممکن است به‌خاطر غیرفعال کردن بارگذاری پرونده‌ها در php.iniه شما باشد٬ یا به‌خاطر تنظیم کردن post_max_size کوچک‌تر از upload_max_filesize در php.ini.
    "
    با ميزبان هاست تماس گرفتم و بهشون گفتم كه فايل php.ini مربوط به شماست و به احتمال زياد مشكل از طرف شماست . تنظيمات سرور رو برام بهينه سازي كردند ولي مشكل برطرف نشد . دوباره بهشون خبر دادم و گفتند:

    "
    ایرادی در سرور وجود ندارد، شما باید ضمن بررسی permission های مجاز در صورت عدم حل مشکل با پشتیبانی اسکریپت مورد استفاده خود ارتباط برقرار کنید.
    "
    به خاطر همين مجبور شديم مزاحمتون بشيم. لطفا كمك كنيد

  • R

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶۵
    تشکر شده: ۸۱ بار
    # نوشته شده: ۸ سال پیش
    ۵ آبان ۱۳۹۰ - ۱۸:۵۷

    یک بار دیگه به روز رسانی کن کل فایل هارا از پیشخوانت
    اگر نشد دسترسی های پوشه هات چک کن

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    iranp
  • NESTED

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۲۳۵۴
    تشکر شده: ۲۳۷۰ بار
    # نوشته شده: ۸ سال پیش
    ۵ آبان ۱۳۹۰ - ۲۱:۵۰

    خب شما هم سطح دسترسی پوشه آپلود رو به 777 تغییر بده

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    iranp
  • iranp

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۱
    تشکر شده: ۴۶ بار
    # نوشته شده: ۸ سال پیش
    ۶ آبان ۱۳۹۰ - ۱۷:۱۰

    با سلام مجدد خدمت دوستان

    دسترسي ها رو به 777 تغيير دادم ولي بازم نشد.
    دوباره با مدير هاست تماس گرفتم و حتي شماره ورود به مديريت وردپرس رو هم بهشون دادم ، بعد از بررسي گفتند كه نتونستيم مشكل رو حل كنيم.

    به نظر من ربطي به وردپرس نداره. به خاطر همين آزمايشاتي رو انجام دادم .

    من هم از سيستم وردپرس روي هاست هاي ديگه كار كردم و روي لوكال.

    بر روي سيستم من نرم افزار wampserver جهت ايجاد لوكال هاست نصب هست ، به بخش مديريتي وردپرس خود در سيستم خانگي ام رفتم و وارد وردپرس شدم ، ابتدا وارد بخش افزودن پرونده شدم و يك فايلي رو خواستم آپلود كنم و همينطور شد يعني به راحتي آپلود كردم.

    بعد بر روي آيكون wampserver كه در سمت راست ، پايين وجود دارد كليك كرده و يك منو باز شد. بعد به منوي php و زير منوي php settings رفتم و ديدم كه گزينه ي upload files فعال هست ، آن را غير فعال كردم (البته مشخصه كه غير فعال كنيم هيچ فايلي آپلود نميشه ولي براي اطمينان و آزمايشات اينكار رو كردم) و دوباره به وردپرس رفتم و خواستم فايلي رو آپلود كنم كه دقيقا با ارور بالا مواجه شدم.(ارور در پست اول هست)

    براي اطمينان بيشتر دوباره به wampserver رفته و گزينه ي upload files رو دوباره فعال كردم و ديدم مشكل بر طرف شد. حال در wampserver به زير منوي php رفتم و فايل php.ini را باز كردم.

    گفتم شايد مشكل از مقادير upload_max_filesize يا post_max_size باشد،به خاطر همين مقادير رو عوض كردم حتي مقدار post_max_size رو كمتر از upload_max_filesize قرار دادم كه مشكلي در هنگام آپلود به وجود نيامد.

    البته بعد از هر بار تغيير wampserver رو ريستارت مي كردم تا تغييرات اعمال شود ولي مشكلي به وجود نيامد.

    آخرين تست: در همين فايل php.ini به گزينه ي زير برخوردم كه چند خط بالاتر ازupload_max_filesize بود:

    file_uploads = On
    بعد اين گزينه رو به Off تغيير دادم و wampserver رو ريستارت كردم و به وردپرس رفتم و دوباره خواستم فايل رو آپلود كنم كه دقيقا با ارور بالا مواجه شدم.

    به خاطر هيمن به احتما 90 درصد مشكل از فايل php.ini هاست هست.
    البته من به اين فايل دسترسي ندارم و در اين مورد هم تو اينترنت سرچ كردم و فايل رو ساختم ولي جواب نداد.

    با تشكر از همه ي دوستان

  • Morteza

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۳۴۰۲
    تشکر شده: ۳۱۲۸ بار
    # نوشته شده: ۸ سال پیش
    ۶ آبان ۱۳۹۰ - ۱۹:۳۵

    اگر مشکل از تنظیمات php.ini هست باید از طرف سرور رفع بشه.
    کار خاصی نمیتونید انجام بدید.

  • پیمان نعیمی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۲
    تشکر شده: ۳ بار
    # نوشته شده: ۸ سال پیش
    ۲۵ آبان ۱۳۹۰ - ۰۰:۵۵

    دوست من اگه مشکلت حل شد خبر بده؛ منم همچین مشکلی دارم

  • iranp

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۱
    تشکر شده: ۴۶ بار
    # نوشته شده: ۸ سال پیش
    ۲۵ آبان ۱۳۹۰ - ۱۴:۱۵

    بله دوست عزیز،مشکلم حل شد، مشکل مربوط می شد به هاستم یعنی باید از طرف مدیر هاستت مشکل برطرف شه ، شما کاری نمی تونید بکنید.

    موفق باشید

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    omid0098
  • omid0098

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳۵۳
    تشکر شده: ۱۱۹۴ بار
    # نوشته شده: ۸ سال پیش
    ۲۵ آبان ۱۳۹۰ - ۱۴:۲۱

    خدارو شکر
    اگه زحمتی نیست ؛ موضوع رو به حل شده تغییر بدید.
    با تشکر

درباره‌ی این موضوع