انجمن


مشکل خط تیره در عنوان مطلب  (۱۰ نوشته)

  • MrTarah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۸ بار
    # نوشته شده: ۶ سال پیش
    ۴ دی ۱۳۹۳ - ۱۳:۰۴

    سلام دوستان خسته نباشید

    توی عنوان مطالب از (-) استفاده می کنم.بعد از ارسال در ادامه مطلب خط تیره کوچک (-) تبدیل میشه به خط تیره بزرگ (–)

    مثلا عنوان باید اینجوری باشه :

    Saeed Arab - Eshghe Mardom

    اما به این شکل میشه

    Saeed Arab – Eshghe Mardom

    چطور میشه این رو درست کرد ؟

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    آموزش وردپرس
  • آموزش وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۸۳۹
    تشکر شده: ۱۷۶۷ بار
    # نوشته شده: ۶ سال پیش
    ۴ دی ۱۳۹۳ - ۱۴:۳۷

    MrTarah گفت:
    سلام دوستان خسته نباشید

    توی عنوان مطالب از (-) استفاده می کنم.بعد از ارسال در ادامه مطلب خط تیره کوچک (-) تبدیل میشه به خط تیره بزرگ (–)

    مثلا عنوان باید اینجوری باشه :

    Saeed Arab - Eshghe Mardom

    اما به این شکل میشه

    Saeed Arab – Eshghe Mardom

    چطور میشه این رو درست کرد ؟

    به نام خدا
    عرض سلامو خسته نباشید از چه افزونه سئو استفاده می کنید ؟ یا افزونه های فارسی سازی جلالی ساز ؟ با تشکر
    ارادتمند : مسلم فلاح نیت

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    MrTarah
  • MrTarah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۸ بار
    # نوشته شده: ۶ سال پیش
    ۴ دی ۱۳۹۳ - ۲۱:۴۱

    amoozesh98com گفت:

    به نام خدا
    عرض سلامو خسته نباشید از چه افزونه سئو استفاده می کنید ؟ یا افزونه های فارسی سازی جلالی ساز ؟ با تشکر
    ارادتمند : مسلم فلاح نیت

    سلام
    از worpress seo استفاده می کنم.افزونه جلالی هم نصبه.
    -----
    البته توی سایتای خارجی کد زیر رو پیدا کردم که گفته بود بذارید توی فایل function.php
    کد رو گذاشتم مشکل خط تیره رفع شد اما الان سایت مپ ارور میده.

    <?php
    add_filter('the_title','mh_double_dash',99);
    function mh_double_dash( $text ) {
    return str_replace('–','-',$text); }
    ?>

    مشکل کد چیه که سایت مپ رو از کار میندازه ؟
    ضمنا از افزونه Google Sitemap Generator استفاده میکنم.
    با تشکر

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    آموزش وردپرس
  • آموزش وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۸۳۹
    تشکر شده: ۱۷۶۷ بار
    # نوشته شده: ۶ سال پیش
    ۵ دی ۱۳۹۳ - ۲۲:۱۱

    MrTarah گفت:

    سلام
    از worpress seo استفاده می کنم.افزونه جلالی هم نصبه.
    -----
    البته توی سایتای خارجی کد زیر رو پیدا کردم که گفته بود بذارید توی فایل function.php
    کد رو گذاشتم مشکل خط تیره رفع شد اما الان سایت مپ ارور میده.

    <?php
    add_filter('the_title','mh_double_dash',99);
    function mh_double_dash( $text ) {
    return str_replace('–','-',$text); }
    ?>

    مشکل کد چیه که سایت مپ رو از کار میندازه ؟
    ضمنا از افزونه Google Sitemap Generator استفاده میکنم.
    با تشکر

    اصولا این کار اشتباهه که بخوایم با این روش کاراکتر فولان رو به فولان تغییر بدیم این تنظیمات مربوط میشه به افزونه سئو شما به احتمال قوی ! به همین علت افزونه سئو رو غیر فعال کنید اون کدی که گذاشتین رو هم بردارید و بعد تست کنید نتیجه رو اطلاع بدین با تشکر
    ارادتمند : مسلم فلاح نیت

  • MrTarah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۸ بار
    # نوشته شده: ۶ سال پیش
    ۶ دی ۱۳۹۳ - ۱۶:۵۳

    amoozesh98com گفت:

    اصولا این کار اشتباهه که بخوایم با این روش کاراکتر فولان رو به فولان تغییر بدیم این تنظیمات مربوط میشه به افزونه سئو شما به احتمال قوی ! به همین علت افزونه سئو رو غیر فعال کنید اون کدی که گذاشتین رو هم بردارید و بعد تست کنید نتیجه رو اطلاع بدین با تشکر
    ارادتمند : مسلم فلاح نیت

    سلام
    کد رو حذف کردم و افزونه سئو رو هم غیرفعال کردم اما اون کاراکتر تغییری نکرد.
    ببینید توی این دو تصویر اون تغییری که می خوام اینه :
    الان اون خط تیره این شکلیه
    http://upload7.ir/imgs/2014-12/39636142444864684838.jpg
    می خوام به این شکل بشه
    http://upload7.ir/imgs/2014-12/10987798450532793960.jpg

  • آموزش وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۸۳۹
    تشکر شده: ۱۷۶۷ بار
    # نوشته شده: ۶ سال پیش
    ۶ دی ۱۳۹۳ - ۱۷:۵۰

    تمام افزونه هاتو غیر فعال کن تست کن !

  • MrTarah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۸ بار
    # نوشته شده: ۶ سال پیش
    ۱۱ دی ۱۳۹۳ - ۱۳:۱۸

    amoozesh98com گفت:
    تمام افزونه هاتو غیر فعال کن تست کن !

    نه دوست من اصلا ربطی به افزونه ها نداره.روی وردپرس خط تیره کوتاه کلا تبدیل میشه به خط تیره بلند.
    من فایل های دانلودم رو که روی هاست دانلود قرار داره با عنوان مطالب وردپرس یکی میذارم الان با این وضعیت کارکتر خط تیره بلند روی هاست دانلودم جواب نمیده.
    مجبورم این رو تبدیل کنم نمیدونم چه گیری سایت مپ داده به این کارکتر.
    ضمنا روی rss هم همین مشکل هست.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    آموزش وردپرس
  • آموزش وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۸۳۹
    تشکر شده: ۱۷۶۷ بار
    # نوشته شده: ۶ سال پیش
    ۱۱ دی ۱۳۹۳ - ۱۳:۲۳

    MrTarah گفت:

    نه دوست من اصلا ربطی به افزونه ها نداره.روی وردپرس خط تیره کوتاه کلا تبدیل میشه به خط تیره بلند.
    من فایل های دانلودم رو که روی هاست دانلود قرار داره با عنوان مطالب وردپرس یکی میذارم الان با این وضعیت کارکتر خط تیره بلند روی هاست دانلودم جواب نمیده.
    مجبورم این رو تبدیل کنم نمیدونم چه گیری سایت مپ داده به این کارکتر.
    ضمنا روی rss هم همین مشکل هست.

    یه خواهشی دارم یه وردپرس دیگه نصب کن ببین روی اونم این مشکل هست ؟ بالاخره باید یه طوری علت به وقوع پیوستن مشکل رو بفهمیم بعضی از موارد هم با تست و خطا به نتیجه میرسه البته این تست و خطا اگر به ضرر سایت نباشه برای همین درخواست نصب یه وردپرس دیگه رو روی یه ساب دامین دیگه و یه دیتا بیس جدید دادم نتیجه رو هم اطلاع بدین بعد از تست با تشکر
    ارادتمند : مسلم فلاح نیت

  • MrTarah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۸ بار
    # نوشته شده: ۶ سال پیش
    ۱۱ دی ۱۳۹۳ - ۱۸:۵۲

    amoozesh98com گفت:

    یه خواهشی دارم یه وردپرس دیگه نصب کن ببین روی اونم این مشکل هست ؟ بالاخره باید یه طوری علت به وقوع پیوستن مشکل رو بفهمیم بعضی از موارد هم با تست و خطا به نتیجه میرسه البته این تست و خطا اگر به ضرر سایت نباشه برای همین درخواست نصب یه وردپرس دیگه رو روی یه ساب دامین دیگه و یه دیتا بیس جدید دادم نتیجه رو هم اطلاع بدین بعد از تست با تشکر
    ارادتمند : مسلم فلاح نیت

    آقا من نصب کردم اما همونطور که گفتم کلا سیستم وردپرس همینه.
    ---
    البته من مشکلم حل شد با دو تا تغییر.
    مشکل سایت مپ به خاطر وجود یک فضای خالی بعد این کد بود.
    مشکل rss هم با یه تغییر کوچیک توی کد حل شد. به جای - از &#45 استفاده کردم.
    ----
    ممنون بابت راهنمایی شما جناب فلاح

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    آموزش وردپرس
  • آموزش وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۸۳۹
    تشکر شده: ۱۷۶۷ بار
    # نوشته شده: ۶ سال پیش
    ۱۱ دی ۱۳۹۳ - ۲۰:۲۸

    از اطلاعاتون ممنون تاپیک رو به حالت حل شده تغییر دادم ممنون میشم بعد از حل مشکل مثل الان با ذکر علت حل اون تاپیک رو به حالت حل شده تغییر وضعیت بدین با تشکر
    ارادتمند : مسلم فلاح نیت

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    MrTarah

درباره‌ی این موضوع