انجمن


مشکل نمایش نوشته های فارسی  (۱۴ نوشته)

  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۷ خرداد ۱۳۹۴ - ۱۲:۴۱

    سلام
    وب سایت من به طور ناگهانی دچار این مشکل شده که نوشته های فارسی را با کاراکترهای نامفهوم نشان می دهد.
    تقریبا همه روشهایی که در انجمن دیدم را انجام دادم اما افاقه نکرد چه باید بکنم؟
    آدرس وب سایت: rent-istanbul.ir

  • Mr .Hamed .Org

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱۵
    تشکر شده: ۹۲ بار
    # نوشته شده: ۴ سال پیش
    ۱۷ خرداد ۱۳۹۴ - ۱۳:۱۱

    دوست عزیز دیتابیش شما با یو تی اف 8 ناسازگاری داره
    فایل کانفیگو پیدا باز کنید چک کنید این هست یا نه
    “define(‘DB_CHARSET’, ‘utf8′);”

  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۷ خرداد ۱۳۹۴ - ۱۳:۲۳

    فایل کانفیگو چک کردم بله هست

  • Mr .Hamed .Org

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱۵
    تشکر شده: ۹۲ بار
    # نوشته شده: ۴ سال پیش
    ۱۷ خرداد ۱۳۹۴ - ۱۴:۰۳

    اخیرا دیتابیسو آپدیت کردید ؟ ایمپورت رو میگم
    چند تا مطلب دارید رو سایت اگه زیاد نیست وردپرسو و دیتابیسشو کلا پاک کنید و یه دور دیگه بنصبید احتمالا دیتابیستون مطالب و سایتو با latin-1 ثبت میکنه در حالیکه زبان اسکریپت utf-8 هست

  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۷ خرداد ۱۳۹۴ - ۱۴:۳۹

    بله آپدیت کردم مطالب زیاد نیست اما چون با سایت کار می کنم تا سایت درست بشه مشتری ها مو از دست میدم نمی تونم پاک کنم راه دیگه ای نداره؟

  • Mr .Hamed .Org

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱۵
    تشکر شده: ۹۲ بار
    # نوشته شده: ۴ سال پیش
    ۱۷ خرداد ۱۳۹۴ - ۱۸:۵۷

    اون خط رو که بالا گفتم چک کنید تو کانفیگ،اونو حذف کنید ببینید درست میشه یا نه
    اگه نشد دوباره اضافه کنید تا راه های دیگه رو بررسی کنیم

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    iranestate
  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۸ خرداد ۱۳۹۴ - ۱۰:۵۵

    اون خط رو تو کانفیگ حذف کردم تغییری نکرد

  • پشتیبانی پارک وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۴
    تشکر شده: ۳۲ بار
    # نوشته شده: ۴ سال پیش
    ۱۸ خرداد ۱۳۹۴ - ۱۱:۳۶

    سلام دوست من ، وقت شما بخیر

    نام پوشته افزونه های خودتون رو از Plugins به یک چیز دیگر تغییر بدهید .

    با این روش همه افزونه های شما غیر فعال می شن ، به احتمال 95% مشکل از افزونه ها هست .

    بعد نام پوشه افزونه ها رو مجددا اصلاح کنید و یکی یکی افزونه ها رو فعال کنید تا ببینید مشکل از کجاست

  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۸ خرداد ۱۳۹۴ - ۱۱:۴۷

    سلام دوست عزیز
    همه افزونه ها را غیر فعال کردم اما مشکل حل نشد.

  • پشتیبانی پارک وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۴
    تشکر شده: ۳۲ بار
    # نوشته شده: ۴ سال پیش
    ۱۸ خرداد ۱۳۹۴ - ۱۱:۵۲

    به غیر از پوشه آپلود در wp-contetn و فایل wp-config در روت ، همه وب سایت را پاک کنید و مجددا وردپرس را در روت هاست کپی کنید و بعدش قالبتون رو اپلود کنید و افزونه ها رو نصب کنید .

    ابتدا قالب پیشفرض رو تست کنید . پرا که مشکل احتمالا از نوع کوئری هایی هست که قالب در دیتابیس ایجاد می کنه .

  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۸ خرداد ۱۳۹۴ - ۱۲:۳۷

    ParkWP.com گفت:
    به غیر از پوشه آپلود در wp-contetn و فایل wp-config در روت ، همه وب سایت را پاک کنید و مجددا وردپرس را در روت هاست کپی کنید و بعدش قالبتون رو اپلود کنید و افزونه ها رو نصب کنید .

    ابتدا قالب پیشفرض رو تست کنید . پرا که مشکل احتمالا از نوع کوئری هایی هست که قالب در دیتابیس ایجاد می کنه .

    این کار را انجام دادم اما با قالب پیش فرض هم مشکل همچنان باقی است ظاهرا اشکال در دیتابیس است.

  • پشتیبانی پارک وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۴
    تشکر شده: ۳۲ بار
    # نوشته شده: ۴ سال پیش
    ۱۸ خرداد ۱۳۹۴ - ۱۴:۲۶

    جدول های غیر ضروری دیتابیس رو با ورود به PhpMyAdmin پاک کنید ، البته قبلش 2 بار از دیتابیس بک آپ بگیرید .

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    iranestate
  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۹ خرداد ۱۳۹۴ - ۱۱:۱۱

    جدول های غیر ضروری را پاک کردم collation دیتا بیس را هم تغییر دادم افاقه نکرد

  • iranestate

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    # نوشته شده: ۴ سال پیش
    ۱۹ خرداد ۱۳۹۴ - ۱۱:۳۴

    سلام دوستان
    من با تماس با هاست متوجه شدم این اشکال در اثر بک آپ گیری از طریق وب سایت پنل ایجاد شده است و هیچ راهی برای بازگرداندن نوشته های فارسی وجود ندارد تنها باید مطالب را پاک کرد و مجددا به سایت اضافه کرد.
    طبق گفته هاست اگر بک آپ گیری از طریق phpmyadmin صورت بگیرد این مشکل پیش نمی آید.
    از کمک های دوستان ممنونم

درباره‌ی این موضوع