انجمن


ارور در بالا آمدن سایت مپ پس از معرفی به گوگل  (۱۶ نوشته)

  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۲ آذر ۱۳۹۴ - ۱۳:۵۰

    با درود
    دوستان من در وردپرس با افزونه ی سایمت مپ ایجاد کردم به این نشانی:

    همان گونه که می بینید به خوبی بالا میاد ولی زمانی که این نقشه سایت رو به گوگل معرفی می کنم. اونجا زمانی که روی سایت مپی که اونجا درج شده کلیک می کنم با این خطا روبرو می شه و سایت مپ بالا نمیاد

    این لینکی هست که توی گوگل وبمستر ثبت می شه و سایت مپ بالا نمیاد:
    http://www.behtarkala.ir/sitemap_index.xml
    و این ارور نوشته می شه:
    خطا در بارگذاری برگهٔ سبک: خطای نامعلومی رخ داده است (‪805303f4‬)

    ---
    و این هم لینکی هست که از توی افزونه ی می زنم و سایت مپ به خوبی بالا میاد:
    http://behtarkala.ir/sitemap_index.xml

    با وجودی که سعی کردم همگی مباحث سئو رو رعایت کنم و نوشته ها کاملا متفاوت باشه (پست ها) ولی هیچ ورودی پس از مدتها از موتورهای جستجو نداشتم

    به نظر یک مشکلی توی بخش سایت مپ یا... وجود داره

    نشانی تارنمای من: http://behtarkala.ir

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    forklift
  • naghmesara

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۱
    تشکر شده: ۲۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۲ آذر ۱۳۹۴ - ۱۶:۵۰

    می تونید در گوگل وب مستر سایت مپتون رو بدون www وارد کنید.
    که برای گوگل قایل رویت باشد.
    البته حتما یک اختلالی وجود دارد که سایت مپ با www در دسترس نیست.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۲ آذر ۱۳۹۴ - ۱۷:۰۵

    naghmesara گفت:
    می تونید در گوگل وب مستر سایت مپتون رو بدون www وارد کنید.
    که برای گوگل قایل رویت باشد.
    البته حتما یک اختلالی وجود دارد که سایت مپ با www در دسترس نیست.

    درست می فرمایید. این به ذهنم رسیده بود ولی خب می خواستم کار اصولی باشه.
    ولی دیدم این کار شدنی نیست. چرا که توی بخشی که سایت مپ رو وارد می کنیم گوگل خودش به صورت خودکار نشانی سایت با Www رو وارد می کنه و بعد ما می تونیم نشانی فایل رو بزاریم. پس نمی شه این کارو کرد بدبختانه

    گفتم با دوستان کارشناس یک مشورت کنم که شاید مشکل از چیز دیگری هست و باید اصلاح بشه

    در گوگل وبمستر هم کنار سایت مپ یک علامت تعجب زرد رنگ وجود داره:

    [URL=http://uupload.ir/][img]http://uupload.ir/files/zvc_capture.jpg[/img][/URL]

  • naghmesara

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۱
    تشکر شده: ۲۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۲ آذر ۱۳۹۴ - ۲۰:۱۸

    دامنه سایت در اصل بدون www است پس نباید در گوگل دامنه را با www وارد میکردید همین قضیه باعث اختلال می شود.
    سایت یا بدون www باید باز شود یا با www که الان برای شما بدون www باز می شود پس عملا تمام ثبت ها را در سایت های مختلف باید بدون www انجام میدادید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۲ آذر ۱۳۹۴ - ۲۲:۵۹

    naghmesara گفت:
    دامنه سایت در اصل بدون www است پس نباید در گوگل دامنه را با www وارد میکردید همین قضیه باعث اختلال می شود.
    سایت یا بدون www باید باز شود یا با www که الان برای شما بدون www باز می شود پس عملا تمام ثبت ها را در سایت های مختلف باید بدون www انجام میدادید.

    پس باید همه رو پاک کن و دوباره ثبت کنم ؟ (سایت های دیگری هم داشتم که با www توی گوگل وبمستر ثبت کرده بودم و بدون هیچ مشکلی بودن

    البته اکنون همه سایت هایی که با www ثبت کرده بودم رو از گوگل وبمستر خودم پاک کردم و بدون www ثبتشون کردم

  • naghmesara

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۱
    تشکر شده: ۲۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۰۰:۰۳

    پیشنهاد بنده این است که سایت رو با www کنید نه اینکه وب مستر رو تغییر دهید.
    البته میتونید از بخش تغییر دامین هم در وبمستر تولز هم اقدام کنید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۰۰:۲۲

    naghmesara گفت:
    پیشنهاد بنده این است که سایت رو با www کنید نه اینکه وب مستر رو تغییر دهید.
    البته میتونید از بخش تغییر دامین هم در وبمستر تولز هم اقدام کنید.

    ای داد بی داد. انگار بنده وارونه ی کاری که باید انجام می دادم رو انجام دادم! چدین سایت داشتم که مدت ها با www ثبت شده بودن همه رو پاک کردم و بدون www ثبت کردم!

    حالا دوباره سایت ها رو با www ثبت کنم و بدون www ها رو پاک کنم؟

    اگر این کارو بکنم تنها می مونه سایت http://www.behtarkala.ir که فایل سایت مپش با www کار نمی کنه. شما گفتین که این سایت رو با www بکنم. مشکل اینه که سایت مپ این سایت با www کار نمی کنه و تنها بدون www کار می کنه

    چجوری می تونم سایت رو اصلاح کنم؟ از توی وردپرس گزینه ای هست که باید از اونجا اقدام کنم تا سایت www دار بشه؟؟

    با سپاس

  • naghmesara

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۱
    تشکر شده: ۲۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۰۲:۳۳

    جهت اینکار باید ابتدا کدهای فایل .htacces موجود در روت هاست را برام بزارید تا بهتون بگم چه مراحلی را باید انجام دهید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۱۱:۳۸

    naghmesara گفت:
    جهت اینکار باید ابتدا کدهای فایل .htacces موجود در روت هاست را برام بزارید تا بهتون بگم چه مراحلی را باید انجام دهید.

    این محتوای فایل مورد نظر هست:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  • naghmesara

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۱
    تشکر شده: ۲۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۱۲:۳۳

    کدی را که ارائه دادید به شکل زیر تغییر دهید.

    # BEGIN WordPress
     <IfModule mod_rewrite.c>
     RewriteEngine On
     RewriteBase /
     RewriteCond %{HTTP_HOST} !^www\.
     RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
     RewriteRule ^index\.php$ - [L]
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteRule . /index.php [L]
     </IfModule>
    
    # END WordPress

    سپس در وردپرس بخش تنظیمات همگانی آدرس سایتتون رو به شکلی که در عکس آمده است وارد کنید.
    http://uupload.ir/files/tkug_www.jpg
    موفق باشید

  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۱۴:۰۹

    naghmesara گفت:
    کدی را که ارائه دادید به شکل زیر تغییر دهید.

    # BEGIN WordPress
     <IfModule mod_rewrite.c>
     RewriteEngine On
     RewriteBase /
     RewriteCond %{HTTP_HOST} !^www\.
     RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
     RewriteRule ^index\.php$ - [L]
     RewriteCond %{REQUEST_FILENAME} !-f
     RewriteCond %{REQUEST_FILENAME} !-d
     RewriteRule . /index.php [L]
     </IfModule>
    
    # END WordPress

    سپس در وردپرس بخش تنظیمات همگانی آدرس سایتتون رو به شکلی که در عکس آمده است وارد کنید.
    http://uupload.ir/files/tkug_www.jpg
    موفق باشید

    درود بر شما

    ببخشد این کارو که انجام دادم دیگه بخش مدیریت ورود به پیشخوان وردپرس بالا نمیاد. وقتی می خوام واردش بشم به این نشانی می ره:
    http://behtarkala.ir/403.shtml
    و اونجا هم نوشته: مطلبی یافت نشد

    دوباره متن فایل رو به حالت اول هم برگردوندم ولی باز با همین صفحه روبرو می شم

    درنتیجه این یکی متن رو وارد فایل کردم که تونستم به بخش پیشخوان دسترسی پیدا کنم دوباره:

    # BEGIN GZIP
    <ifmodule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript
    </ifmodule>
    # END GZIP
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/html "access plus 1 seconds"
    ExpiresByType image/gif "access plus 2 days"
    ExpiresByType image/jpeg "access plus 2 years"
    ExpiresByType image/png "access plus 3 years"
    ExpiresByType text/css "access plus 2 years"
    ExpiresByType text/woff "access plus 2 years"
    ExpiresByType text/ttf "access plus 2 years"
    ExpiresByType text/eot "access plus 2 years"
    ExpiresByType text/javascript "access plus 2 years"
    ExpiresByType application/x-javascript "access plus 2 years"
    ExpiresActive On
    ExpiresByType image/jpg "access plus 1 year"
    ExpiresByType image/jpeg "access plus 1 year"
    ExpiresByType image/gif "access plus 1 year"
    ExpiresByType image/png "access plus 1 year"
    ExpiresByType text/css "access plus 1 month"
    ExpiresByType application/pdf "access plus 1 month"
    ExpiresByType text/x-javascript "access plus 1 month"
    ExpiresByType application/x-shockwave-flash "access plus 1 month"
    ExpiresByType image/x-icon "access plus 1 year"
    ExpiresDefault "access plus 1 month"
    </IfModule>
    # Turn off ETags
    <ifmodule mod_headers.c="">
    Header unset ETag
    </ifmodule>
    FileETag None
    # compress text, HTML, JavaScript, CSS, and XML
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    # remove browser bugs
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4.0[678] no-gzip
    BrowserMatch bMSIE !no-gzip !gzip-only-text/html
    Header append Vary User-Agent

    -----

    پس از اینکه این متن رو جایگزین کردم و به پیشخوان دسترسی پیدا کردم، وقتی روی تنظیمات - همگانی کلیک می کنم که برم و نشانی رو درست کنم دوباره از صفحه پیشخوان بیرون میاد و به بخش ورود می ره!

    یعنی: با کدهایی که خودم داشتم وارد پیشخوان می شه ولی با گلیک روی بخش تنظیمات - همگانی بیرون می پره
    با کد شما وارد بخش ورود به پیشخوان (دریافت یوزر و گذرواژه) نمی شه و به صفحه ی
    http://behtarkala.ir/403.shtml
    هدایت می شه

    حالا نمی دونم مشکل از چی هست و چکارش باید کرد! شاید از هاست باشه.

  • naghmesara

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۱
    تشکر شده: ۲۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۳ آذر ۱۳۹۴ - ۱۵:۴۳

    کدهایی را که شما در .htaccess قرار دادید مربوط به کشینگ می شود.
    برای اینکه بهتر بتونم راهنماییتون کنم باید به هاست و وردپرستون دسترسی داشته باشم تا شاید بتونم مشکل رو حل کنم.
    اگر مایل بودید مشخصات رو برام میل کنید.
    upfa247@gmail.com
    موفق باشید

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • سرور مجازی ایران

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۶ بار
    # نوشته شده: ۱ سال پیش
    ۲۴ آذر ۱۳۹۴ - ۱۸:۲۸

    ولی دیدم این کار شدنی نیست. چرا که توی بخشی که سایت مپ رو وارد می کنیم گوگل خودش به صورت خودکار نشانی سایت با Www رو وارد می کنه و بعد ما می تونیم نشانی فایل رو بزاریم. پس نمی شه این کارو کرد بدبختانه

    اینجوری نیست. سایتی که بدون www در وبمستر تولز ثبت شده باشه سایت مپش هم بدون www ثبت و لینک میشه

    من فکر میکنم مشکل شما رو گیج کرده و انگار میخواید یه شی بزرگ رو که درست جلوی چشم شماست پیدا کنید.

    مشکل فتال ارور که فرمودید هم در 3 حالت پیش میاد.
    1. تداخل دو افزونه ی سایت مپ سئو یواست و گوگل ایکس ام ال سایت مپ
    2. استفاده ی بیش از حد افزونه ی گوگل سایت مپ از منابع ( این مورد با محدود کردن میزان استفاده در تنظیمات افزونه قابل حل هست )
    3. عدم توانایی جنریت کردن سایت مپ توسط سئو یواست ( متاسفانه الان نصب ندارم ولی یه جایی تعداد row در یک سایت مپ هست که به طور پیشفرض یا خالی هست یا روی 1000 هست که اون رو اگر تغییر بدید مشکل پیدا میکنه )
    اما حالا که سایت مپ شما به خوبی در نسخه ی بدون www سایت جنریت میشه شما دو راه دارید.
    *یا سایت رو ببرید بر روی www ( توی تنظیمات وردپرس )
    *یا سایت رو بدون www در wmt ثبت کرده و ادامه ی کار.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • nasimparsi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۴
    تشکر شده: ۳ بار
    # نوشته شده: ۱ سال پیش
    ۲۴ آذر ۱۳۹۴ - ۲۲:۵۸

    farsvideo گفت:

    اینجوری نیست. سایتی که بدون www در وبمستر تولز ثبت شده باشه سایت مپش هم بدون www ثبت و لینک میشه

    من فکر میکنم مشکل شما رو گیج کرده و انگار میخواید یه شی بزرگ رو که درست جلوی چشم شماست پیدا کنید.

    مشکل فتال ارور که فرمودید هم در 3 حالت پیش میاد.
    1. تداخل دو افزونه ی سایت مپ سئو یواست و گوگل ایکس ام ال سایت مپ
    2. استفاده ی بیش از حد افزونه ی گوگل سایت مپ از منابع ( این مورد با محدود کردن میزان استفاده در تنظیمات افزونه قابل حل هست )
    3. عدم توانایی جنریت کردن سایت مپ توسط سئو یواست ( متاسفانه الان نصب ندارم ولی یه جایی تعداد row در یک سایت مپ هست که به طور پیشفرض یا خالی هست یا روی 1000 هست که اون رو اگر تغییر بدید مشکل پیدا میکنه )
    اما حالا که سایت مپ شما به خوبی در نسخه ی بدون www سایت جنریت میشه شما دو راه دارید.
    *یا سایت رو ببرید بر روی www ( توی تنظیمات وردپرس )
    *یا سایت رو بدون www در wmt ثبت کرده و ادامه ی کار.

    سپاس از راهنماییتون به نظرم می رسه همون مورد 1 که گفتید مشکل اصلی هست و باعث این مشکل شده

    لطفا بفرمایید که اکنون که همگی سایت های خودم رو هم با WWWو هم بدون WWW در گوگل وبمستر ثبت کردم ای مشکلی نداره؟ به نظرتون باید یکشون حذف بشه یا اینکه هر دو مورد باقی بمونه؟ و اگر بهتره که یکیشون حذف بشه کدوم یکی حذف بشه بهتره از نظر سئو و ..

    با سپاس

  • سرور مجازی ایران

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۶ بار
    # نوشته شده: ۱ سال پیش
    ۲۷ آذر ۱۳۹۴ - ۰۸:۱۹

    nasimparsi گفت:

    لطفا بفرمایید که اکنون که همگی سایت های خودم رو هم با WWWو هم بدون WWW در گوگل وبمستر ثبت کردم ای مشکلی نداره؟ به نظرتون باید یکشون حذف بشه یا اینکه هر دو مورد باقی بمونه؟ و اگر بهتره که یکیشون حذف بشه کدوم یکی حذف بشه بهتره از نظر سئو و ..

    نه خیر مشکلی نداره. اتفاقا گوگل خود توصیه به صبت دوگانه ی سایت کرده و در قسمتی هم امکان انتخاب پرفرد ورژن آف سایت رو فراهم کرده که کاربر تعیین میکنه که کدام رو ترجیح میده.
    در نهایت در سایت شما باید یک آدرس کانونی به عنوان صفحه ی اصلی وجود داشته باشه که بهش میگن کانونیال یو آر ال ، در صورتی که سایت شما با و بدون www باز بشه و فورس بشه روی یکی از آدرس ها مشکلی نیست. اما اگر با و بدون www آدرس سایت رو وارد کرده پس از باز کردن هرکدام یک آدرس مجزا داشتید این مورد اشکال دارد.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    nasimparsi
  • طراحی بنر

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۳
    تشکر شده: ۱ بار
    # نوشته شده: ۲ هفته پیش
    ۱۴ شهریور ۱۳۹۶ - ۱۱:۱۰

    سلام دوست خوبم
    قایل های robots.txt وفایل های htaccess رو چک کنید ببینید مشکلی نداره

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.