انجمن


اشکال در افزونه جلالی  (۲ نوشته)

  • Moeini

    آفلاین
    عضو فعال
    تعداد نوشته‌ها: ۵۵۹
    تشکر شده: ۶۷۸ بار
    # نوشته شده: ۷ سال پیش
    ۸ اردیبهشت ۱۳۹۱ - ۱۰:۴۸

    درصورتی که حالت دیباگ در وردپرس فعال باشد با خطای
    Notice: has_cap از نگارش 2.0 از رده خارج شده! استفاده از سطوح دسترسی کاربران توسط افزونه‌ها و پوسته‌ها از رده خارج شده است. از نقش‌های کاربری و توانایی‌ها به‌جای آن‌ها استفاده کنید.
    مواجه میشویم.
    این خطا مربوط به سطح دستری وردپرس است که در نسخه‌های پیش از 2 به صورت 'عدد' بوده است.
    این حالت دیگر در دسترس نمیباشد و باید به جای آن از دسترسی های مانند 'create_users' و یا 'edit_pages' استفاده کرد.
    در جدول زیر دسترسی‌های پیش‌فرض وردپرس آمده است.
    http://72.233.56.142/Roles_and_Capabilities#Capability_vs._Role_Table

    درصورتی که در خط 67 فایل فایل wp-jalali.php عدد 10 را به یکی از دسترسی‌های اعلام شده مانند 'activate_plugins' تغییر دهید مشکل برطرف خواهد شد.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    گناهکار - saeli
  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۷ سال پیش
    ۸ اردیبهشت ۱۳۹۱ - ۱۱:۵۹

    ممنون، اصلاح شد و تغییرات توی نگارش‌های بعدی اعمال می‌شه.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Moeini

درباره‌ی این موضوع



برچسب‌ها