انجمن


مشکل با لینک ثابت فارسی  (۳۲ نوشته)

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۹ شهریور ۱۳۸۶ - ۱۷:۵۵

    سلام
    یه سوال
    وقتی من لینک ثابت رو روی موضوع و پست تنظیم می‌کنم، اگر موضوع و نام پست انگلیسی باشه به مشکلی برخورد نمی‌کنم. ولی اگر عنوان پست یا رده‌بندی‌ش فارسی باشه اکسپلورر صفحه‌ی اصلی رو نمایش می‌ده.
    ایضاً همین مشکل رو با تگ‌ها هم دارم.

    من WP رو روی IIS اجرا می‌کنم. دسترسی کامل هم به سرور دارم. کار خاصی باید انجام بدم یا نه؟

    ممنون

  • martianboy

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۳
    تشکر شده: ۱۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۹ شهریور ۱۳۸۶ - ۲۰:۲۶

    اا من خودم وردپرس رو روی آپاچی نصب کرده‌م. به شدت هم به بقیه توصیه می‌کنم همین‌کارو بکنن. ولی خوب برای حل مشکل شما ویکی سایت وردپرس مقاله داره:
    http://codex.wordpress.org/Using_Permalinks#Using_Permalinks_Without_mod_rewrite

    توی این چیزی که دادم دو تا پیوند هست:
    http://www.deanlee.cn/wordpress/url-rewriting-for-wordpress-under-iis/
    http://www.binaryfortress.com/wordpress-url-rewrite/

    این دوجا اطلاعات خوبی در مورد وردپرس روی IIS داده‌ن. پیشنهاد می‌کنم بخونیدشون.

  • مانی

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۶۹۶
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۹ شهریور ۱۳۸۶ - ۲۱:۴۱

    دوست من شما باید برای نوشته هاتون و همچنین دسته بندی هاتون از Slug استفاده کنید. مشکلتون حل می شه کاملا. توی صفحه ویرایش نوشته در سمت راست یه قسمت هست به نام Post Slug که اومجا یک نام انگلیسی برای مطلبتون وارد می کنید که توی آدرس نوشته تون به جای متن فارسی جایگزین می شه. برای دسته بندی ها هم، توی قسمت ویرایش نام دسته بندی ها Slug وجود دارد.

  • martianboy

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۳
    تشکر شده: ۱۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۹ شهریور ۱۳۸۶ - ۲۲:۲۰

    دوست من شما باید برای نوشته هاتون و همچنین دسته بندی هاتون از Slug استفاده کنید. مشکلتون حل می شه کاملا. توی صفحه ویرایش نوشته در سمت راست یه قسمت هست به نام Post Slug که اومجا یک نام انگلیسی برای مطلبتون وارد می کنید که توی آدرس نوشته تون به جای متن فارسی جایگزین می شه. برای دسته بندی ها هم، توی قسمت ویرایش نام دسته بندی ها Slug وجود دارد.

    خوب اگه فارسی باشن روی آپاچی که مشکلی ندارن بازم. روی IIS فارسیا مشکل پیدا می‌کنن؟

  • lukadium

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸۲
    تشکر شده: ۱۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۰ شهریور ۱۳۸۶ - ۰۴:۵۶

    در کل استفاده از slug برای هر چیزیتون که اسلاگ پذیر هست توصیه میشه ;-)

  • مانی

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۶۹۶
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۰ شهریور ۱۳۸۶ - ۱۱:۵۷

    martianboy گفت:

    دوست من شما باید برای نوشته هاتون و همچنین دسته بندی هاتون از Slug استفاده کنید. مشکلتون حل می شه کاملا. توی صفحه ویرایش نوشته در سمت راست یه قسمت هست به نام Post Slug که اومجا یک نام انگلیسی برای مطلبتون وارد می کنید که توی آدرس نوشته تون به جای متن فارسی جایگزین می شه. برای دسته بندی ها هم، توی قسمت ویرایش نام دسته بندی ها Slug وجود دارد.

    خوب اگه فارسی باشن روی آپاچی که مشکلی ندارن بازم. روی IIS فارسیا مشکل پیدا می‌کنن؟

    من رو IIS تست نکردم راستش. ولی من پیشنهاد می کنم همیشه از Slug استفاده کنید.

  • martianboy

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۳
    تشکر شده: ۱۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۰ شهریور ۱۳۸۶ - ۱۲:۰۸

    اون که بله. منم همیشه توصیه می‌کنم جایی که امکان داره از اسلاگ استفاده بشه. فقط در مورد IIS کنجکاو شدم.

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۰ شهریور ۱۳۸۶ - ۱۷:۵۴

    از نظراتتون ممنونم. ولی..

    جناب  martianboy
    من اون مقالاتی که لینکشون رو گذاشتید مطالعه کردم. اونا فقط به نحوه‌ی راه‌اندازی لینک پایدار روی IIS اشاره کردند. من با این قسمتش مشکل ندارم. مشکل من فقط در مطالب با عنوان فارسی یا اسلاگ فارسی است.

     mani عزیز: بنده با Slug انگلیسی که مشکل ندارم فقط بنا به دلایلی می‌خوام Slugهم فارسی باشه.

  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۰ شهریور ۱۳۸۶ - ۱۹:۲۰

    یک کاری کن یک بار روی آپاچی آزمایش کن ببین مشکل هنوز هست یا نه بعد خبر بده گام ب گام بریم جلو

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۰۰:۳۸

    mazdakam گفت:
    یک کاری کن یک بار روی آپاچی آزمایش کن ببین مشکل هنوز هست یا نه بعد خبر بده گام ب گام بریم جلو

    جناب mazdakam
    1- من اکانت روی سرور آپاچی ندارم. اما مطمئن هستم که روی بعضی از سایت‌ها درست کار می‌کنه.
    2- می‌تونید از این آدرس ببینید. وبلاگ تست
    3 توی پستی که با عنوان تست تگ‌نویسی زدم. دوتا تگ فارسی نوشتم. وردپرس و تگ و یه تگ انگلیسی Tag وقتی روی هرکدوم از تگ‌های فارسی کلیک کنید، صفحه‌ی Not Found نمایش داده میشه. درحالی که برای تگ انگلیسی این طور نیست.
    4- من از وردپرس 2.3 بتا 2 استفاده می‌کنم. و برای تگ نویسی از افزونه‌ی خاصی استفاده نکردم یعنی همون قابلیت جدید تگ در وردپرس. هرچند این مشکل رو با افزونه‌ها هم روی ورژن 2.2.2 داشتم.

  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۰۰:۴۶

    من رفتم که ببینم منتها خطا می‌ده

    Warning: main(C:\Domains\utopia.ir\httpdocs\Sufism/wp-includes/wp-db.php): failed to open stream: No such file or directory in C:\Domains\utopia.ir\httpdocs\Sufism\wp-settings.php on line 119
    
    Fatal error: main(): Failed opening required 'C:\Domains\utopia.ir\httpdocs\Sufism/wp-includes/wp-db.php' (include_path='.;./includes;./pear') in C:\Domains\utopia.ir\httpdocs\Sufism\wp-settings.php on line 119
  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۰۰:۵۰

    ببین دو تا مشکل داری تا اون‌جا که من فهمیدم یکی برچسب‌های فارسی هستش و دیگری نام‌های فارسی که در ساختار پیوند پایدار قرار می‌گیرند
    هر دوی این‌ها not found می‌شوند درسته؟

    اگر درسته وردپرس ۲.۲.۲ رو بریز و ما روی بخش دوم تمرکز کنیم فعلا تا بعد برویم روی بخش برچسب‌ها

    این خطایی رو هم که نوشتم بررسی کن ببین چیه داستانش

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۰۱:۰۸

    mazdakam گفت:
    ببین دو تا مشکل داری تا اون‌جا که من فهمیدم یکی برچسب‌های فارسی هستش و دیگری نام‌های فارسی که در ساختار پیوند پایدار قرار می‌گیرند
    هر دوی این‌ها not found می‌شوند درسته؟
    اگر درسته وردپرس ۲.۲.۲ رو بریز و ما روی بخش دوم تمرکز کنیم فعلا تا بعد برویم روی بخش برچسب‌ها
    این خطایی رو هم که نوشتم بررسی کن ببین چیه داستانش

    1- کاملاً درسته
    2- نمیشه با همین ورژن کار کنیم.! :-( تازه من آپگریدش کردم رو بتا 3. مطمئن هم هستم 2.2.2 هم همین جوره. ولی اگر امر بفرمائید اطاعت می‌کنم.
    3- داشتم آپگرید رو انجام می‌دادم که اون خطا رو داده

  • مانی

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۶۹۶
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۰:۵۹

    utopia گفت:

    mazdakam گفت:
    یک کاری کن یک بار روی آپاچی آزمایش کن ببین مشکل هنوز هست یا نه بعد خبر بده گام ب گام بریم جلو

    جناب mazdakam
    1- من اکانت روی سرور آپاچی ندارم. اما مطمئن هستم که روی بعضی از سایت‌ها درست کار می‌کنه.
    2- می‌تونید از این آدرس ببینید. وبلاگ تست
    3 توی پستی که با عنوان تست تگ‌نویسی زدم. دوتا تگ فارسی نوشتم. وردپرس و تگ و یه تگ انگلیسی Tag وقتی روی هرکدوم از تگ‌های فارسی کلیک کنید، صفحه‌ی Not Found نمایش داده میشه. درحالی که برای تگ انگلیسی این طور نیست.
    4- من از وردپرس 2.3 بتا 2 استفاده می‌کنم. و برای تگ نویسی از افزونه‌ی خاصی استفاده نکردم یعنی همون قابلیت جدید تگ در وردپرس. هرچند این مشکل رو با افزونه‌ها هم روی ورژن 2.2.2 داشتم.

    در مورد بخش آدرس ها ... راستش من مطمینم که قبلا درست کار می کرد، بگذارین یه کم دقیق تر بگم ... الان وردپرس دات کام خرابه همین موضوع توش ... یعنی قبلا خراب نبود ... الان اینجوری شده (حدود چند روزه). نتیجه منطقی اینه که تو وردپرس ۲.۳ بتا یه تغییری به وجود اومده ... (وردپرس دات کام همیشه از آخرین نسخه هسته وردپرس استفاده می کنه).

    اگه می شه همون کاری رو که مزدک می گه بکنید... یعنی رو ۲.۲.۳ آزمایش کنید. نتیجه آزمایش من. مشکلی نیست.

    مشکل تگ ها قبلا تو bbPress بهش برخورده بودیم... و اونجا حل شد... باید بررسی بشه ...

  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۱:۲۲

    مشکل تگ ها قبلا تو bbPress بهش برخورده بودیم... و اونجا حل شد... باید بررسی بشه ...

    دقیقا مانی همون سوتی رو دادند که ما گزارش داده بودیم

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۳:۰۷

    mani گفت:

    اگه می شه همون کاری رو که مزدک می گه بکنید... یعنی رو ۲.۲.۳ آزمایش کنید. نتیجه آزمایش من. مشکلی نیست.
    مشکل تگ ها قبلا تو bbPress بهش برخورده بودیم... و اونجا حل شد... باید بررسی بشه ...

    من wordpress 2.2.3 رو نصب کردم(روی این آدرس http://www.utopia.ir/WP) ضمن اینکه غیر از یک دونه تم هیچ چیز دیگه‌ای( اعم از افزونه‌ها و تم) اضافه نکردم. ولی باز هم همون مشکل دارم.

  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۴:۱۰

    http://www.utopia.ir/WP

    من به این‌جا رفتم ولی چیزی ندیدم خالی هستش برگه

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۴:۴۵

    mazdakam گفت:

    http://www.utopia.ir/WP

    من به این‌جا رفتم ولی چیزی ندیدم خالی هستش برگه

    به خاطر ISAPI بود که با نظر یکی از دوستان برای حل مشکل نصب کرده بودم. که کلاً سایت خوابید.
    الان سایت بالا میاد. می‌تونید چک کنید

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۵:۰۷

    یه چیزی که به نظرم رسید.
    ممکنه از ورژن php و یا mySQL باشه؟!! :?

  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۷:۰۶

    از mySql می‌تونه باشه نسخه‌ی چند هستش؟

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ شهریور ۱۳۸۶ - ۱۷:۲۸

    MySQL 4.1.18

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۲ شهریور ۱۳۸۶ - ۱۶:۴۶

    خبری نشد؟ :?

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۳ شهریور ۱۳۸۶ - ۱۲:۲۳

    شما لینک‌هاتون وابسته به نام دسته‌بندی هستن!

    این نوع ساختار اصلن پیشنهاد نمی‌شه٬ اگه می‌شه به حالت معمولی لینک‌هاتون رو دربیارین ببینیم باز هم مشکل دارین؟!

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۳ شهریور ۱۳۸۶ - ۱۳:۴۳

    اگر منظورتون از ساختار معمولی درست فهمیده باشم، باید به صورت(/index.php/%year%/%monthnum%/%day%/%postname%/) دربیارم.
    هرچند قبلاً هم این کار رو انجام دادم. ولی چشم.

    الان می‌تونید ببینید...
    http://www.utopia.ir/WP

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۳ شهریور ۱۳۸۶ - ۱۳:۴۷

    یه چیزی رو یادم رفت بگم. توی یه ساختاری مثل index.php/2007/09/14/sample-post/ اگر اسم پست اگلیسی باشه که بدون اشکال نمایش داده میشه. ولی اگر Slug پست فارسی باشه، اون‌وقت تمام پست‌های روز 14‌ام نمایش داده می‌شن... :-?

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۳ شهریور ۱۳۸۶ - ۱۷:۴۷

    یه چیزی رو یادم رفت بگم. توی یه ساختاری مثل index.php/2007/09/14/sample-post/ اگر اسم پست اگلیسی باشه که بدون اشکال نمایش داده میشه. ولی اگر Slug پست فارسی باشه، اون‌وقت تمام پست‌های روز 14‌ام نمایش داده می‌شن... :-?

    خب٬ این‌طور که از شواهد پیداست روی IIS شما نمی‌تونین بدون Slug انگلیسی از این ساختارها استفاده کنین٬ اگه نمی‌تونین برای نوشته‌هاتون Slug انگلیسی تعیین کنین پیشنهاد می‌کنم اصلن از %postname% توی ساختارتون استفاده نکنین و به‌جای اون از post_id% استفاده کنین.

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۴ شهریور ۱۳۸۶ - ۰۱:۲۱

    Gonahkar گفت:

    یه چیزی رو یادم رفت بگم. توی یه ساختاری مثل index.php/2007/09/14/sample-post/ اگر اسم پست اگلیسی باشه که بدون اشکال نمایش داده میشه. ولی اگر Slug پست فارسی باشه، اون‌وقت تمام پست‌های روز 14‌ام نمایش داده می‌شن... :-?

    خب٬ این‌طور که از شواهد پیداست روی IIS شما نمی‌تونین بدون Slug انگلیسی از این ساختارها استفاده کنین٬ اگه نمی‌تونین برای نوشته‌هاتون Slug انگلیسی تعیین کنین پیشنهاد می‌کنم اصلن از %postname% توی ساختارتون استفاده نکنین و به‌جای اون از post_id% استفاده کنین.

    این که شد پاک کردن صورت مساله.;)

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۴ شهریور ۱۳۸۶ - ۰۹:۰۶

    این که شد پاک کردن صورت مساله.;)

    خب تمامی راه‌ها رو شما امتحان کردی و به نتیجه نرسیدی٬ چیز دیگه‌ای به فکرم نمی‌رسید.

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۴ شهریور ۱۳۸۶ - ۱۵:۵۸

    من حتی زبون چینی رو هم امتحان کردم. باز همین طور بود. یعنی کلاْ با زبان‌های یونی‌کد مشکل داره...

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۴ شهریور ۱۳۸۶ - ۲۱:۴۱

    من حتی زبون چینی رو هم امتحان کردم. باز همین طور بود. یعنی کلاْ با زبان‌های یونی‌کد مشکل داره...

    مشکل IIS هست با slugهای غیرانگلیسی٬ به‌نظرم یا سرورت رو عوض کن٬ یا از slug استفاده نکن.

  • utopia

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۹
    تشکر شده: ۷ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۴ شهریور ۱۳۸۶ - ۲۳:۴۴

    مطمئن هستید مشکل مربوط به خود IIS هست؟
    یعنی هیچ کس روی سرور ویندوز از Slug غیر انگلیسی استفاده نمی‌کنه؟

    راستش من احتمال می‌دم مشکل از جای دیگه باشه.
    به همین خاطر هم بوده که این تاپیک را زدم.

  • mazdakam

    آفلاین

    تعداد نوشته‌ها: ۱۴۵۳
    تشکر شده: ۱۲۲ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۷ آذر ۱۳۸۶ - ۱۷:۲۰

    نگارش تازه‌ای که دراومده رو دریافت کن ببین هنوز همون مشکل رو داری یا نه

درباره‌ی این موضوع



برچسب‌ها