انجمن


اشکال در نمایش عنوان سایت  (۱۲ نوشته)

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۱ دی ۱۳۸۷ - ۰۱:۰۷

    چند وقتی هست با اینکه هیچ تغییری در پوسته نداده ام بعد از به روز رساتی وردپرس این اشکال ایجاد شده. در صفحه اول وبلاگ عنوان سایت در نوار ابزار بالای سایت نمایش داده نمیشود به عبارتی مرورگر اینترنت عنوانی شناسایی نمیکند. در صفحات دیگر وبلاگ این مشکل وجود ندارد و فقط در صفحه اول مشکل ایجاد شده.

    در هر دو سایت من هم همین مشکل وجود دارد.
    http://mastaneh.ir
    http://hafez.mastaneh.ir

  • دانلود تلگرام

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۶۲
    تشکر شده: ۱۰۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۱ دی ۱۳۸۷ - ۰۱:۵۳

    از افزونه ي ALL IN ONE SEO PACK استفاده كنيد همه چي حل ميشه !
    مثل من
    http://www.iranget.com

  • oshgool

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵۹۳
    تشکر شده: ۶۵ بار
    # نوشته شده: ۱۲ سال پیش
    ۱ دی ۱۳۸۷ - ۰۲:۵۸

    حالا شما اینکارو بکن تو مستانه.آی آر ببین شاید درست بشه.
    فایل header.php رو باز کن بعد بین کد زیر:
    <title></title>
    اینو کد زیر رو اضافه کن:
    <?php bloginfo('name'); ?> <?php if ( is_single() ) { ?>
    یعنی بشه مثل زیر:
    <title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?></title>

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۱ دی ۱۳۸۷ - ۲۰:۳۵

    من دقیقا همچین عبارتی را در همین قیمت که شما گفتید دارم به این صورت:
    <?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?>

    و همچنین از افزونه ALL IN ONE SEO PACK هم استفاده می کنم.

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۱ دی ۱۳۸۷ - ۲۰:۴۹

    این هم کد کامل فایل سربرگ مستانه.آی آر

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">

    <head profile="http://gmpg.org/xfn/11">

    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />

    <title>
    <?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?>
    </title>

    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats -->

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />

    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

    <?php wp_head(); ?>
    </head>

    <body>

    <div id="wrapper">

    <div id="header">

    <div id="header_left_top"><!-- Hack for IE --></div>

    <div id="header_left">

    <div id="navigation">

    <div id="menu">

      <li class="<?php if (((is_home()) && !(is_paged())) or (is_archive()) or (is_single()) or (is_paged()) or (is_search())) { ?>current_page_item<?php } else { ?>page_item<?php } ?>"><span>">صفحه اول<?php echo $langblog;?></span>

      <?php $params = wp_list_pages('sort_column=menu_order&depth=1&title_li='); ?>

    </div><!--end of menu -->
    </div><!--end of navigation -->
    </div><!--end of header_left -->

    <div id="header_right">

    <p align="center">"><img border="0" src="wp-content/themes/Mastaneh/images/header.jpg" ></p>

    </div><!--end of header_right -->

    <br clear="all" />

    </div><!--end of header -->

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۷ دی ۱۳۸۷ - ۱۲:۵۷

    هیچ کس نبود کمکی بکنه؟؟؟؟؟؟؟؟؟؟؟؟؟؟////

  • mostafa

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۸
    تشکر شده: ۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۸ دی ۱۳۸۷ - ۱۸:۳۵

    فکر کنم تم شما مشکل کد نویسی داشته باشد. توی header اینجوری (<title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> &raquo; ?> <?php } ?> <?php wp_title(); ?></title>)
    تغییر دهید

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۹ دی ۱۳۸۷ - ۲۲:۲۵

    فکر نکنم اشکال از پوسته باشه چون با تغییر پوسته باز هم همین مشکل وجود داره؟؟؟ :-(

  • مهدی

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۱۱۰۰
    تشکر شده: ۳۴۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۹ دی ۱۳۸۷ - ۲۲:۴۳

    فکر نکنم اشکال از پوسته باشه چون با تغییر پوسته باز هم همین مشکل وجود داره؟؟؟

    تمام افزونه‌های موجود را غیرفعال کنید، سپس امتحان کنید

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۹ دی ۱۳۸۷ - ۲۳:۰۰

    این طور که متوجه شدم مشکل به خاطر نصب افزونه wp-supercash و All in One SEO Pack به طور هم زمان هست؟
    به نظر شما اشکال همینه و چرا؟

  • مستانه

    آفلاین
    عضو
    تعداد نوشته‌ها: ۷۳
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۹ دی ۱۳۸۷ - ۲۳:۰۴

    به هر حال با غیر فعال کردن یکی مشکلم حل شد. ممنون از همه دوستان

  • gogolimagoli.ir

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۷ سال پیش
    ۵ تیر ۱۳۹۳ - ۰۲:۴۱

    قالب من هم همین مشکل رو داشت و هر کاری می کردم درست نمی شد
    این کد رو از header حذف کردم
    <title><?php wp_title('name'); ?></title>
    این کدی رو که گفتید جاش اضافه کردم درست شد
    <title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> &raquo; ?> <?php } ?> <?php wp_title(); ?></title>

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.