انجمن


مشکل در ارسال پاسخ به نظرات  (۴ نوشته)

  • eneah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۷
    تشکر شده: ۱۶ بار
    # نوشته شده: ۷ سال پیش
    ۲۴ اسفند ۱۳۹۱ - ۲۲:۰۰

    سلام
    وقتی کاربری نظری ارسال میکنه هم میتونم بپزیم هم جفنگ و همه قسمت ها کار میکنه
    اما وقتی رو دکمه پاسخ کلیک میکنم عمل نمیکنه و فقط آخر لینک # اضافه میشه
    قبلا درست بود از زمانی که انتقال دستی دادم اینطوری شده !
    البته قبلا هم چندین بار دستی انتقال داده بودم این مشکل نبود
    مشکلو چطوری حل کنم؟

  • ایران وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷۲۹
    تشکر شده: ۹۵۲ بار
    # نوشته شده: ۷ سال پیش
    ۲۴ اسفند ۱۳۹۱ - ۲۲:۲۲

    درود .

    جی کوئری سایتتون غیرفعال شده . کد زیر رو در فایل function.php قالبتون اضافه کنید و تست کنید :

    <?php
    if( !is_admin()){
    wp_deregister_script('jquery');
    wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"), false, '1.3.2');
    wp_enqueue_script('jquery');
    }
    ?>

    همچنین اگه کد بالا کار نکرد اینو تست کنید :

    if (!is_admin()) add_action("wp_enqueue_scripts", "my_jquery_enqueue", 11);
    function my_jquery_enqueue() {
       wp_deregister_script('jquery');
       wp_register_script('jquery', "http" . ($_SERVER['SERVER_PORT'] == 443 ? "s" : "") . "://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js", false, null);
       wp_enqueue_script('jquery');
    }

    ** دقت کنید که باید بین <?php و ?> قرار بدین تا کار کنه . مثل کد اولی **

    از دو لینک زیر هم میتونید استفاده کنید در صورتی که جواب نداد :
    http://www.kevinleary.net/wordpress-3-5-admin-jquery-is-not-defined/
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    eneah
  • eneah

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۷
    تشکر شده: ۱۶ بار
    # نوشته شده: ۷ سال پیش
    ۲۶ اسفند ۱۳۹۱ - ۱۵:۴۴

    دوست عزیز من کد اولی رو قرار دادم مشکل نطرات حل شد مشکل لود نشدن سایت بوجود اومد
    بعد دوباره برگردوندم به حالت اولی اما باز سایت لود نمیشه و صفحه کاملا سفید میاد
    البته پنل مدیریت بدون مشکل و کامل بالا میاد
    دقیقا از زمان انتقال اینطوری شد قبلا مکلی نداشت !
    چندین بار دستی انتقال داده بودم مشکلی پیش نیونده بود نمیدونم اینبار چرا اینطوری شد !

  • ایران وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷۲۹
    تشکر شده: ۹۵۲ بار
    # نوشته شده: ۷ سال پیش
    ۲۶ اسفند ۱۳۹۱ - ۱۶:۰۲

    درود بر شما .

    یک بار قالب رو روی پیش فرض ست کنید و نام پوشه ی plugins رو تغییر بدین .

    و مجددا تست کنید که سایت و قسمت نظرات درست هست یا خیر .

    یک بار هم کش مرورگر رو پاک کنید بد نیست ;)

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Araz

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.