انجمن


ارورهای عجیب بعد از فعال سازی افزونه جلالی  (۵ نوشته)

  • mostafanastary

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۰
    تشکر شده: ۱۳ بار
    # نوشته شده: ۸ سال پیش
    ۲۴ فروردین ۱۳۹۲ - ۰۴:۱۶

    با سلام و احترام.

    بعد از انتقال یه سری مشکلات تو سایتم بوجود آمده و بعضا رفع شدن، منتهی بعد از فعال سازی wp-jalali بعد از چند ساعت برای تمامی مطالب ارورهای نات فوند میاد.
    همچنین ارورهای زیر در سایت مشاهده میشه که بعد از غیر فعال کردن درست میشه.

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'widget_jarchive_init' not found or invalid function name in /home/site-man/public_html/wp-includes/plugin.php on line 406

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'widget_mps_calendar_init' not found or invalid function name in /home/site-man/public_html/wp-includes/plugin.php on line 406

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'mps_yk_solve_search' not found or invalid function name in /home/site-man/public_html/wp-includes/plugin.php on line 230

    همچنین اومدم توی فایل wp-jalali.php دو تا تابع ارورهای اول و دوم رو با استفاده از // کامنت کردم. ارورهای اول و دوم رفتند.
    منتهی مطلب ارور not found داشت بازم.
    و جالب تر از همه اینکه وقتی روی VPS میام آپاچی رو ریست میکنم.
    مشکلات برای چند ساعت آینده رفع میشن.

    لطفا نظرتون رو در این مورد بگید.

    با تشکر

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    aradrobot - نخ - تناسب اندام
  • mostafanastary

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۰
    تشکر شده: ۱۳ بار
    # نوشته شده: ۸ سال پیش
    ۲۴ فروردین ۱۳۹۲ - ۱۵:۰۶

    سلام.
    دوستان کسی نظری نداشت؟

    در ضمن مسئله ای دیگه هم هست و اونم این که، زمانی شش گزینه ی

    تبدیل اعداد به فارسی شامل:
    متن نوشته‌ها متن نظر‌ها تعداد نظر‌ها
    عنوان نوشته‌ها تاریخ‌ها فهرست دسته‌ها

    چک خورده اند، مطالب در عنوان،متن،تاریخ و ... اروری میده که مربوط به خط

    $mps_jd_optionsDB = get_option(MPS_JD_OPTIONS_NAME);
    $mps_jd_farsinum_date = $mps_jd_optionsDB['mps_jd_farsinum_date'];

    if ((!$forcelatinnums) && ($mps_jd_farsinum_date))
    $result = farsi_num($result);

    return $result;
    }

    در فایل plugin/wp-jalali/inc/jalali-core.php و شماره خط 419 میشه.

    تا میام و تیگ شش تا گزینه رو بر میدارم، سایت راه میافته دوباره/

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    نخ
  • ایران وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷۲۹
    تشکر شده: ۹۵۲ بار
    # نوشته شده: ۸ سال پیش
    ۲۴ فروردین ۱۳۹۲ - ۱۹:۳۰

    درود . وردپرس و افزونه رو بروز کنید .
    سپس تمامی افزونه هاتون رو به غیر از افزونه ی جلالی غیرفعال نید و تست کنید . شاید با افزونه ی دیگری مشکل داشته باشه

    قالب پیش فرض هم تست کنید بد نیست .

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    اسپادانا
  • mostafanastary

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۰
    تشکر شده: ۱۳ بار
    # نوشته شده: ۸ سال پیش
    ۲۴ فروردین ۱۳۹۲ - ۲۰:۰۴

    سلام.
    با تشکر از پاسخ شما.
    قبلا مسائلی که گفتید رو انجام دادمف منتهی این اتفاقات بعد از انتقال رخ داده و هیچ افزونه ای قبلا با هم تداخل نداشته است.
    همچنین چون افزونه های دیگری که در سایت نصب هستند مورد نیاز هستند نمیتونم بی خیال هیچ کدوم بشم.اما غیر فعال کردن رو امتحان کردم.
    افزونه و وردپرس و تمامی افزونه های دیگه هم بروز هستند.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    نخ
  • Araz

    آفلاین
    کاربر فعال
    تعداد نوشته‌ها: ۱۵۰۴
    تشکر شده: ۹۱۰ بار
    # نوشته شده: ۸ سال پیش
    ۴ اردیبهشت ۱۳۹۲ - ۰۳:۵۳

    پلاگین wp-jalali را حذف و آنرا مجددا دانلود و نصب کنید.

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.