انجمن


مشکل در شورت کد افزونه  (۴ نوشته)

  • rezanasiri

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲
    # نوشته شده: ۶ روز پیش
    ۲۲ آبان ۱۳۹۶ - ۱۲:۰۷

    سلام و خسته نباشید خدمت تمامی اساتید

    من به یه افزونه ی عضویت نیاز داشتم که برای سایتم عضو گیری کنم تا بتونم چک کنم اعضا رو دسترسی داشته باشم بهشون و بعد از یه گشتن در اینترنت به افزونه Clean Login برخوردم و به نظر خوب میومد. افزونه رو نصب کردم و طبق آموزشی که ازش دیدم گفته شده بود ک برای هر بخش باید یه برگه جدید ایجاد کرد و شورت کد مورد نظر رو اونجا قرار داد. من همین کارو کردم مثلا برای صفحه ورود از قسمت ایجاد برگه یک برگه جدید درست کردم و شورت کد [ clean-login ] که مربوط به این قسمت هست رو در جای نوشتن متن قرار دادم و انتشار رو زدم. ولی متاسفانه وقتی این صفحه رو باز میکنم صفحه ورود نمیاد و میگه این صفحه پیدا نشد. از یه افزونه ی دیگه هم که با شورتکد بود امتحان کردم همین مشکل رو داشتم

    از اساتید محترم کسی هست راهنمایی کنه تا من این مشکلم برطرف بشه! ممنون میشم

    و دوستان عزیز افزونه ی دیگه ای هست که بهتر از این باشه برای عضویت . نمیخوام اعضا کار خاصی بتونن انجام بدن . صرفا فقط جهت عضو گیری هست و نهایتن قابلیت اینو داشته باشه که برای نظر دادن برای هر پست باید عضو سایت بشن.

    پیشاپیش از کمک و همراهی دوستان سپاسگذارم

  • kamalireal

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۳
    تشکر شده: ۹ بار
    # نوشته شده: ۶ روز پیش
    ۲۲ آبان ۱۳۹۶ - ۱۶:۵۱

    rezanasiri گفت:
    سلام و خسته نباشید خدمت تمامی اساتید

    من به یه افزونه ی عضویت نیاز داشتم که برای سایتم عضو گیری کنم تا بتونم چک کنم اعضا رو دسترسی داشته باشم بهشون و بعد از یه گشتن در اینترنت به افزونه Clean Login برخوردم و به نظر خوب میومد. افزونه رو نصب کردم و طبق آموزشی که ازش دیدم گفته شده بود ک برای هر بخش باید یه برگه جدید ایجاد کرد و شورت کد مورد نظر رو اونجا قرار داد. من همین کارو کردم مثلا برای صفحه ورود از قسمت ایجاد برگه یک برگه جدید درست کردم و شورت کد [ clean-login ] که مربوط به این قسمت هست رو در جای نوشتن متن قرار دادم و انتشار رو زدم. ولی متاسفانه وقتی این صفحه رو باز میکنم صفحه ورود نمیاد و میگه این صفحه پیدا نشد. از یه افزونه ی دیگه هم که با شورتکد بود امتحان کردم همین مشکل رو داشتم

    از اساتید محترم کسی هست راهنمایی کنه تا من این مشکلم برطرف بشه! ممنون میشم

    و دوستان عزیز افزونه ی دیگه ای هست که بهتر از این باشه برای عضویت . نمیخوام اعضا کار خاصی بتونن انجام بدن . صرفا فقط جهت عضو گیری هست و نهایتن قابلیت اینو داشته باشه که برای نظر دادن برای هر پست باید عضو سایت بشن.

    پیشاپیش از کمک و همراهی دوستان سپاسگذارم

    درود .
    اگر از طریق مطلب جواب نمیده ، میتونید یک برگه سفارشی ایجاد کنید .
    و از کد زیر برای اجرای شورتکد درون فایل php قالب برگه سفارشی (Custom Page) استفاده کنید :
    echo do_shortcode( '[clean-login]' );
    سپس از بخش ایجاد برگه ، برگه با قالبی که ایجاد کرده بودید بسازید .

    موفق باشید .

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    rezanasiri
  • rezanasiri

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲
    # نوشته شده: ۶ روز پیش
    ۲۲ آبان ۱۳۹۶ - ۱۹:۳۲

    kamalireal گفت:

    درود .
    اگر از طریق مطلب جواب نمیده ، میتونید یک برگه سفارشی ایجاد کنید .
    و از کد زیر برای اجرای شورتکد درون فایل php قالب برگه سفارشی (Custom Page) استفاده کنید :
    echo do_shortcode( '[clean-login]' );
    سپس از بخش ایجاد برگه ، برگه با قالبی که ایجاد کرده بودید بسازید .

    موفق باشید .

    درود و تشکر بابت پاسخگوییتون
    الان ک دارم امتحان میکنم حتی پست جدید هم که ایجاد میکنم همین مشکل رو داره . یعنی وقتی افزودن نوشته میزنم و مطلب رو به اشتراک میزارم مطلب روی صفحه اصلی سایت میاد ولی وقتی ادامه مطلب رو میزنم تا صفحه ی اختصاصی مطلب باز بشه و کل مطلب رو ببینم باز نوشته شده که چیزی برای نشون دادن وجود نداره.
    میتونه مشکل از چی باشه؟ به نظر میاد پوسته موردی داره؟

  • kamalireal

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۳
    تشکر شده: ۹ بار
    # نوشته شده: ۵ روز پیش
    ۲۳ آبان ۱۳۹۶ - ۱۰:۲۷

    rezanasiri گفت:

    درود و تشکر بابت پاسخگوییتون
    الان ک دارم امتحان میکنم حتی پست جدید هم که ایجاد میکنم همین مشکل رو داره . یعنی وقتی افزودن نوشته میزنم و مطلب رو به اشتراک میزارم مطلب روی صفحه اصلی سایت میاد ولی وقتی ادامه مطلب رو میزنم تا صفحه ی اختصاصی مطلب باز بشه و کل مطلب رو ببینم باز نوشته شده که چیزی برای نشون دادن وجود نداره.
    میتونه مشکل از چی باشه؟ به نظر میاد پوسته موردی داره؟

    درود .
    فکر میکنم پیوندهای یکتا سایت شما مشکل دارند .
    از پنل مدیریت پیشخوان بخش تنظیمات » پیوندهای یکتا ، یکبار پیوندهای یکتا سایتتون رو بروزرسانی کنید .
    سپس از طریق هاست فایل .htaccess در مسیر public_html را هم بررسی کنید کد زیر درون آن وجود داشته باشد :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    باز هم اگر به نتیجه نرسیدید ، مشکل خودتون رو دقیق تر با عکس یا بصورت آنلاین مطرح کنید تا دقیق تر شما رو راهنمایی کنیم .

    موفق باشید .

درباره‌ی این موضوع