انجمن


مشکل با ایجاد پست  (۴ نوشته)

  • moosavimaleki

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹
    # نوشته شده: ۸ سال پیش
    ۱ بهمن ۱۳۹۲ - ۰۷:۵۳

    سلام

    من با این کد میخوام پستی راسال کنم...
    قراره تیتر متن یا همون عنوان پست قسمتی از خود متن باشه...

    $post_title=substr($post_content, 0, 30);
    $post_data = compact('post_content','post_title','post_date','post_date_gmt','post_author','post_category', 'post_status', 'tags_input','post_type','tax_input');
    $post_ID = wp_insert_post($post_data);

    همه چی خوب درست کار میکنه
    عنوان به خوبی عوض میشه و نمایش داده میشه اما تنها مشکل توی لینک هست
    مثلا برای عنوان:ای به قربان وجودت
    لینک مطلب به این صورت میشود:http:/mysite.ir/29357/ouoe-ou-uooou-uouoo/
    با حروف انگلیسی اشتباه پر میشود!!!

  • MD:::... Hosseini

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶۰
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۲ بهمن ۱۳۹۲ - ۰۲:۲۳

    سلام دوست عزیز
    شما پیوند های یکتا رو چک کردید ؟؟؟
    وقتی که رو این لینک کلیک می کنید به لینک مربوطه منتقل میشه ؟ یا صفحه ای پیدا نمیشه ؟

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    moosavimaleki
  • moosavimaleki

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹
    # نوشته شده: ۸ سال پیش
    ۵ بهمن ۱۳۹۲ - ۱۵:۴۶

    mohamaddapper گفت:
    سلام دوست عزیز
    شما پیوند های یکتا رو چک کردید ؟؟؟
    وقتی که رو این لینک کلیک می کنید به لینک مربوطه منتقل میشه ؟ یا صفحه ای پیدا نمیشه ؟

    نه درست کار میکنه و به صفحه به درستی منتقل میشه اما این جوری شده دیگه!!

  • MD:::... Hosseini

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶۰
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۶ بهمن ۱۳۹۲ - ۰۰:۵۷

    شما پیوند یکتاتون رو تیتر قرار دادی آره ؟
    چون تیتر شما فارسی هست با حروف یا اعداد دیگه پر می کنه اما وقتی که لینک رو میزنید حرفارو درست نشون میده

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.