انجمن


در ارتقا به 3.9.1 با مشکل پلاگ این مواجه شد  (۹ نوشته)

  • mf

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۶ سال پیش
    ۲۸ خرداد ۱۳۹۳ - ۱۱:۱۸

    سلام و عرض احترام
    متاسفانه بدون گرفتن بک آپ اقدام به ارتقا وردپرس به 3.9.1 کردم و با این پیغام مواجه شدم

    Warning: Invalid argument supplied for foreach() in /home3/******/public_html/wp-includes/plugin.php on line 622
    چگونه میتوان این مشکل را برطرف کرد؟

  • جعبه سازی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۴
    تشکر شده: ۳ بار
    # نوشته شده: ۶ سال پیش
    ۲۸ خرداد ۱۳۹۳ - ۱۳:۱۳

    دستی بروز رسانی کنید (نگران نباشید)

    در گوگل جستجو کنید:
    آموزش دستی آپدیت کردن وردپرس

  • فروشگاه 4شما

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۳۲
    تشکر شده: ۱۵ بار
    # نوشته شده: ۶ سال پیش
    ۲۸ خرداد ۱۳۹۳ - ۱۳:۱۸

    درود .

    در فایلی که داخل ارور آمده است دنبال کد زیر بگردید و آن را حذف کنید :

    foreach ( $wp_plugin_paths as $dir => $realdir ) {
    if ( strpos( $file, $realdir ) === 0 ) {
    $file = $dir . substr( $file, strlen( $realdir ) );
    }
    }

    البته راه دیگری نیز در انجمن پشتیبانی وردپرس انگلیسی توضیح داده شده که برای شما بازگو میکنم :

    1. اسکریپت جدید را دانلود کنید . از وردپرس فارسی میتوانید دانلودکنید .
    2. فولدر های wp-admin و wp-include را از اسکریپتی که دانلود کرده اید ، فشرده کنید با فرمت zip و در روت هاست خود ، جایگزین فایل های فعلی نمایید .
    3. افزونه ها را غیرفعال کنید و مجددا فعال کنید .

  • mf

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۶ سال پیش
    ۳۱ خرداد ۱۳۹۳ - ۱۸:۴۸

    من دسترسی به تنظیمات ورد پرس برای فعال و غیر فعال کردن افزونه ها را ندارم. یعنی اصلا نمیتوان وارد هیچ کدام از قسمتهای سایت بجز سی پنل شد.
    کدی که گفته بودید را حذف کردم ارور زیر نمایان شد
    فولدر های wp-admin و wp-include قبلی را تغییر نام داده و از ورد پرس 3.9.1 فولدر های wp-admin و wp-include را فشرده کرده و با فرمت zip و در روت هاست خود ، جایگزین فایل های فعلی نمودم

    Warning: require() [function.require]: Unable to access /home3/irantabl/public_html/wp-includes/load.php in /home3/irantabl/public_html/wp-settings.php on line 21

    Warning: require(/home3/irantabl/public_html/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home3/irantabl/public_html/wp-settings.php on line 21

    Warning: require() [function.require]: Unable to access /home3/irantabl/public_html/wp-includes/load.php in /home3/irantabl/public_html/wp-settings.php on line 21

    Warning: require(/home3/irantabl/public_html/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home3/irantabl/public_html/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required '/home3/irantabl/public_html/wp-includes/load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home3/irantabl/public_html/wp-settings.php on line 21

  • mf

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۶ سال پیش
    ۳۱ خرداد ۱۳۹۳ - ۱۸:۴۹

    من دسترسی به تنظیمات ورد پرس برای فعال و غیر فعال کردن افزونه ها را ندارم. یعنی اصلا نمیتوان وارد هیچ کدام از قسمتهای سایت بجز سی پنل شد.
    کدی که گفته بودید را حذف کردم ارور زیر نمایان شد
    فولدر های wp-admin و wp-include قبلی را تغییر نام داده و از ورد پرس 3.9.1 فولدر های wp-admin و wp-include را فشرده کرده و با فرمت zip و در روت هاست خود ، جایگزین فایل های فعلی نمودم

    Warning: require() [function.require]: Unable to access /home3/irantabl/public_html/wp-includes/load.php in /home3/irantabl/public_html/wp-settings.php on line 21

    Warning: require(/home3/irantabl/public_html/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home3/irantabl/public_html/wp-settings.php on line 21

    Warning: require() [function.require]: Unable to access /home3/irantabl/public_html/wp-includes/load.php in /home3/irantabl/public_html/wp-settings.php on line 21

    Warning: require(/home3/irantabl/public_html/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home3/irantabl/public_html/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required '/home3/irantabl/public_html/wp-includes/load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home3/irantabl/public_html/wp-settings.php on line 21

  • فروشگاه 4شما

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۳۲
    تشکر شده: ۱۵ بار
    # نوشته شده: ۶ سال پیش
    ۳۱ خرداد ۱۳۹۳ - ۲۱:۲۵

    درود مجدد .
    برای غیرفعال کردن افزونه و قالب هنگامی که پیشخوان دسترسی ندارید از طریق فایل منیجر هاست اقدام کنید .

    با تغییر نام پوشه ی themes و plugins به راحتی میتونید غیرفعال کنید .
    احتمالا بعضی از فایل ها صدمه دیدن و ناقص آپلود شدن . بهتره با گرفتن بک آپ از پوشه ی wp-content ( در صورتی که سایت رو تازه راه اندازی کرده اید و هیچ مطلبی ندارید میتونید کلا پاک کنید ) فایل های وردپرس را کلا حذف کنید و مجددا نسخه ی جدید رو آپلود کنید .

    در فایل wp-config.php هم مشخصات دیتابیس رو وارد کنید . فقط مراقب باشید دیتابیس رو حذف نکنید . کل این کار 5 دقیقه طول می کشه .
    با این کار فایل های ناقص هم ترمیم میشن و هم نسخه ی جدید کاملا پیاده سازی میشه .

    موفق باشید .

  • mf

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۶ سال پیش
    ۲ تیر ۱۳۹۳ - ۱۸:۲۵

    سلام مجدد

    تشکر و سپاسگذاری از شما دوست عزیز

    سایت ما بالاخره بروز شد

  • mf

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۶ سال پیش
    ۵ تیر ۱۳۹۳ - ۱۰:۱۳

    سلام و درود
    هر بار که وارد پیشخوان میشوم با ثبت نام کاربران ناخواسته ای که نامهای نامشخصی را عموما درج میکنند ،مواجه میشوم
    که بنظر می آید اینکار توسط رباطهای هکر انجام میگیرد
    1 - آیا این ثبت نام در کاربران ، برای سایت میتواند باعث بروز مشکل شود؟
    2- چگونه از ثبت نام و ورود هکر ها جلوگیری کنیم؟

  • فروشگاه 4شما

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۳۲
    تشکر شده: ۱۵ بار
    # نوشته شده: ۶ سال پیش
    ۵ تیر ۱۳۹۳ - ۱۴:۳۱

    درود .

    این ها هکر نیستند . رباتهایی هستند که اقدام به عضویت می کنند . برای غیرفعال کردن این مضووع میتوانید " تنظیمات > همگانی " امکان عضویت برای همه را غیر فعال کنید .

درباره‌ی این موضوع