انجمن


افزونه WP-PostViews 1.50  (۲۲ نوشته)

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۵ تیر ۱۳۸۸ - ۱۵:۰۷

    من از افزونه WP-PostViews 1.50 براي نمايش دادن دفعات بازديد هر پست داخل آن پست استفاده مي كنم. ولي وقتي صفحه را Refresh مي كنم به عدد بازديد 2 اضافه مي شود. بايد چه كار كنم؟
    در ضمن اين كد را داخل فايل single.php قرار مي دهم.
    <?php if(function_exists('the_views')) { the_views(); } ?>

    يا علي

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۷ تیر ۱۳۸۸ - ۰۱:۳۴

    ببخشيد به خاطر انتخاب بد انجمن. @},-
    من هنوز منتظر جواب هستم. :-(

    يا علي

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۷ تیر ۱۳۸۸ - ۱۵:۰۸

    میشه بیشتر توضیح دهید؟ یعنی با هر بار Refresh به جای اضافه شدن یک ، دو عدد به آن اضافه میشود؟ این افزونه را در لوکال نصب کردید یا هاست شخصی؟ کوکی های مرورگر خود را پاک کردید؟

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۷ تیر ۱۳۸۸ - ۲۳:۲۵

    m3ysam جان بله همان طور كه گفتيد: "با هر بار Refresh به جای اضافه شدن یک ، دو عدد به آن اضافه میشود".
    در هاست شخصي نصب كردم.
    كوكي ها را پاك كردم.

    يا علي

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۰۱:۳۵

    خوب به نظرم بهتره چند تا چیز را چک کنید. اول بهتره روی هاست شخصی امتحان کنید . این مشکلات عموما در لوکال بروز میکند و بر روی هاست شخصی به درستی کار میکند نگران نباشید.به هر حال کارهای زیر را پیشنهاد میکنم.
    آیا از آخرین نسخه وردپرس 2.8 استفاده میکنید؟ چون این نسخه فقط با وردپرس 2.8 کار میکنه.
    آیا این افزونه را ارتقا دادید؟ یعنی قبلا از نسخه پایینتر استفاده میکردید بعد به این نسخه ارتقا دادید؟ اگر آره به درستی انجام داده اید؟
    نسخه زبان پی اچ پی که افزونه را تست کردید چند است؟ آیا 5 است؟ ممکن است با نسخه کمتر از 5 سازگار نباشد.
    آیا تنظیمات پیش فرض افزونه را تغییر دادید؟ اگر آره، تنظیمات را به حالت اول برگردانید
    موفق باشید

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۱۵:۰۰

    خوب به نظرم بهتره چند تا چیز را چک کنید. اول بهتره روی هاست شخصی امتحان کنید . این مشکلات عموما در لوکال بروز میکند و بر روی هاست شخصی به درستی کار میکند نگران نباشید.

    همانطور كه قبلا گفتم بر روي هاست شخصي نصب كردم.

    آیا از آخرین نسخه وردپرس 2.8 استفاده میکنید؟ چون این نسخه فقط با وردپرس 2.8 کار میکنه.

    از نسخه 2.8 استفاده مي كنم (وردپرس).

    آیا این افزونه را ارتقا دادید؟ یعنی قبلا از نسخه پایینتر استفاده میکردید بعد به این نسخه ارتقا دادید؟ اگر آره به درستی انجام داده اید؟

    خير اين افزونه را ارتقا نداده ام.

    نسخه زبان پی اچ پی که افزونه را تست کردید چند است؟ آیا 5 است؟ ممکن است با نسخه کمتر از 5 سازگار نباشد.

    نسخه 5 است.

    آیا تنظیمات پیش فرض افزونه را تغییر دادید؟ اگر آره، تنظیمات را به حالت اول برگردانید

    تنظيمات آن را تغيير نداده ام.

    يا علي

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۱۶:۳۰

    با سلام
    راستش نکته دیگری به ذهنم نمیرسد! باید دوستان دیگر هم کمک کنند.
    ولی به این اطمینان دارم که در هاست شخصی این مشکلات بروز نمیکند پس نگران نباشید. ;-)

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۱۸:۲۰

    m3ysam گفت:
    با سلام
    راستش نکته دیگری به ذهنم نمیرسد! باید دوستان دیگر هم کمک کنند.
    ولی به این اطمینان دارم که در هاست شخصی این مشکلات بروز نمیکند پس نگران نباشید. ;-)

    من زبونم كم كم داره مو در مياره. به خدا روي هاست شخصي تست كردم. :D

    يا علي

  • Evil.l3oy

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۸
    تشکر شده: ۳۹ بار
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۱۹:۳۹

    سلام
    اوکی پس آدرس سایتتون رو بدید بچه ها ببینن !!!

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۱۹:۴۱

    atkrad گفت:

    m3ysam گفت:
    با سلام
    راستش نکته دیگری به ذهنم نمیرسد! باید دوستان دیگر هم کمک کنند.
    ولی به این اطمینان دارم که در هاست شخصی این مشکلات بروز نمیکند پس نگران نباشید. ;-)

    من زبونم كم كم داره مو در مياره. به خدا روي هاست شخصي تست كردم. :D
    يا علي

    با سلام
    دوست عزیز، مثل اینکه متوجه حرفهای من نشدید! ~X( بنده متوجه شدم که روی لوکال نصب کردید و عرض کردم که نگران نباشید هر زمان که روی هاست شخصی این افزونه را نصب کنید این مشکلات بروز نخواهد کرد! یعنی اینکه این مشکلات فقط روی لوکال هاست شما بروز کرده است . و شما اگر هاست شخصی بخرید/داشته باشید. وردپرس را روی آن بریزید و افزونه را روی آن نصب کنید، دیگر با این مشکلات برخورد نخواهید کرد.
    و برای حل مشکل روی لوکال هاست ، غیر از چک کردن اون چند مورد دیگه چیزی به ذهنم نمیرسه و دوستان دیگر باید کمکتون کننند!

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۲۰:۴۶

    به اين آدرس نگاه كنيد.
    m3ysam جان كارت با غلط كردن راه مي افته. به خدا غلط كردم ~X( ~X( :(( :((

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۲۱:۴۱

    با سلام
    دوست عزیز این حرفها چیه؟! :P

    من الان اون آدرسی که دادید را چک کردم . خوب اینکه درست کار میکنه! مشکل شما چیه؟ من یک بار فایرفاکس نگاه کردم بازدید ۱۸۷ بود صفحه refresh کردم همون 187 موند. بعد با opera نگاه کردم شد 188 .
    خب اینکه درست کار میکنه. مشکل شما الان چیه؟ من با گوگل کروم هم امتحان کردم درست کار میکند.(شد 189 :-) )

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۲۲:۴۴

    m3ysam گفت:
    با سلام
    دوست عزیز این حرفها چیه؟! :P
    من الان اون آدرسی که دادید را چک کردم . خوب اینکه درست کار میکنه! مشکل شما چیه؟ من یک بار فایرفاکس نگاه کردم بازدید ۱۸۷ بود صفحه refresh کردم همون 187 موند. بعد با opera نگاه کردم شد 188 .
    خب اینکه درست کار میکنه. مشکل شما الان چیه؟ من با گوگل کروم هم امتحان کردم درست کار میکند.(شد 189 :-) )

    ولي براي من 2 تا اضافه مي كنه.

    يا علي

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۸ تیر ۱۳۸۸ - ۲۲:۴۸

    دفعه اول Refresh مي كنم 1 عدد اضافه مي كند. ولي دفعه بعدي هر چند بار كه Refresh مي كنم 2 اضافه مي كند. :-?

    يا علي

  • Evil.l3oy

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۸
    تشکر شده: ۳۹ بار
    # نوشته شده: ۱۰ سال پیش
    ۹ تیر ۱۳۸۸ - ۰۰:۵۵

    سلام

    این افزونه هیچ مشکلی نداره . افزونه رو نصب کردم سالم است میتونید اینجا مشاهده کنید .

    یک بار افزونه را کاملا حذف کنید و دوباره نصب کنید .

  • quran

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷۶
    تشکر شده: ۱۹ بار
    # نوشته شده: ۱۰ سال پیش
    ۹ تیر ۱۳۸۸ - ۱۳:۰۲

    با سلام
    آقا منم چک کردم درست کار می کرد تازه چند بار هم refresh کردم.

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۹ تیر ۱۳۸۸ - ۱۴:۱۰

    atkrad جان شما از چه مرورگری استفاده میکنید؟ شاید مربوط به مرورگر شماست؟
    چون همانطور که میبینی بقیه دوستان هم به درستی تعداد بازدیدها را مشاهده میکنند.

  • Evil.l3oy

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۸
    تشکر شده: ۳۹ بار
    # نوشته شده: ۱۰ سال پیش
    ۹ تیر ۱۳۸۸ - ۱۸:۲۳

    سلام دوستان عزیز , atkrad درست میگه با هر بار کلیک 2 تا بالا میره
    من با فایرفاکس و اینترنت اکسپلورر تست کردم !! :-P
    اما دقیقا نمی دونم مشکلش کجاست ! احتمال میدم مال هاستش باشه !!
    با تشکر

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۹ تیر ۱۳۸۸ - ۲۰:۵۸

    m3ysam گفت:
    atkrad جان شما از چه مرورگری استفاده میکنید؟ شاید مربوط به مرورگر شماست؟
    چون همانطور که میبینی بقیه دوستان هم به درستی تعداد بازدیدها را مشاهده میکنند.

    m3ysam جان همانطور كه ديديد يكي ديگر از دوستان هم با مشكل مي بيند.
    من در مرورگر هاي FF 3.0.11 و IE 7.0 و Chrome 2.0.172.31 تست كردم.

    يا علي

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۱۰ تیر ۱۳۸۸ - ۰۰:۱۱

    چند بار مجدد صفحه را refresh کردم با opera 6.4 , firefox 3.0 , Internet explorer 8 . تقریبا نتایج مشابهی داشت! اما این بار فقط از هر 2 الی 3 بار refresh فقط یک عدد اضافه میشد!
    شایدم مربوط باشه به کش سرور. من بعضی سرورها را دیدم که کش خفنی دارند یعنی مثلا یک صفحه را که بازدید میکنی و اگر اون تغییر کنه و شما چند بار Refresh کنی باز هم همان صفحه قبلی را مشاهده میکنی .شما در واقع هیچ تغییری توی سایت مشاهده نمیکنی و اون کش همیشه مدت زمانی بیشتری میخواد که تغییر کنه! نمیدونم منظورم را متوجه میشید یا نه؟ مثلا این اتفاق بیشتر در هاستهای مجانی اتفاق می افتد. یا مثلا اگر افزونه wp-super-cache را نصب کنی چنین اتفاقی می افتد!
    راستی یک گزینه ای توی تنظیمات افزونه با نامCount Views From . اون را به Everyone تغییر بدهید شاید تغییری کرد.
    من هم احتمال میدم مشکل از هاست شما باشه. باید دوستان دیگری هم بیایند و ببینیم بلاخره میتونیم این مشکل عجیب را حل کنیم.

  • m3ysam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵۱
    تشکر شده: ۲۱ بار
    # نوشته شده: ۱۰ سال پیش
    ۱۰ تیر ۱۳۸۸ - ۰۰:۱۳

    چند بار مجدد صفحه را refresh کردم با opera 6.4 , firefox 3.0 , Internet explorer 8 . تقریبا نتایج مشابهی داشت! اما این بار فقط از هر 2 الی 3 بار refresh فقط یک عدد اضافه میشد!
    شایدم مربوط باشه به کش سرور. من بعضی سرورها را دیدم که کش خفنی دارند یعنی مثلا یک صفحه را که بازدید میکنی و اگر اون تغییر کنه و شما چند بار Refresh کنی باز هم همان صفحه قبلی را مشاهده میکنی .شما در واقع هیچ تغییری توی سایت مشاهده نمیکنی و اون کش همیشه مدت زمانی بیشتری میخواد که تغییر کنه! نمیدونم منظورم را متوجه میشید یا نه؟ مثلا این اتفاق بیشتر در هاستهای مجانی اتفاق می افتد. یا مثلا اگر افزونه wp-super-cache را نصب کنی چنین اتفاقی می افتد!
    راستی یک گزینه ای توی تنظیمات افزونه با نامCount Views From . اون را به Everyone تغییر بدهید شاید تغییری کرد.
    من هم احتمال میدم مشکل از هاست شما باشه. باید دوستان دیگری هم بیایند و ببینیم بلاخره میتونیم این مشکل عجیب را حل کنیم.

    در ضمن من پیشنهاد میکنم افزونه wp-postviews-plus را نصب کنی شاید این به درستی کار کند! این افزونه مشابه همون افزونه است!

    شرمنده اشتباهی 2 تا پست ارسال کردم!

  • atkrad

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۰
    # نوشته شده: ۱۰ سال پیش
    ۱۰ تیر ۱۳۸۸ - ۱۹:۵۳

    هاستم كه رايگان نيست. :-(
    فكر نمي كنم كه Cache خفني داشته باشد. :D
    تنظيماتش هم روي Everyone است 8-|
    و از افزونه wp-super-cache هم استفاده نمي كنم. 8-|

    يا علي

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.