انجمن


‍‍‍‍‍‍‍متن رو دیگه یونیکد نشون نمی ده.(فنتستیکو)  (۶ نوشته)

  • mmahdi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱
    # نوشته شده: ۱۲ سال پیش
    ۱۶ آبان ۱۳۸۶ - ۱۵:۳۱

    من فایل wp-config.php رو ‍‍‍اک کردم و بعدش فکر می کنم با فنتستیکو اونو درست کردم و این باعث شد که همه چی بهم بریزه و حالا که اومدم اینجا خوندم فهمیدم . حالا راهی هست که همه چیز به حالت قبل خودش برگرده . من بکا‍ هم نگرفته بودم.

    فنتستیکو

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۶ آبان ۱۳۸۶ - ۱۹:۳۶

    اگه فقط فایل wp-config.php پاک شده شما یه مشکل دارید : نمی دونید نام کاربری - رمز عبور و نام دیتابیستون چیه .
    برای حل این مشکل باید به قسمت دیتابیس هاستتون برید و دیتابیسی که وردپرس ازش استفاده می کرد رو پیدا کنید.
    حالا به قسمت mysql رفته و یک کاربر جدید بسازید و کاربر جدید رو به دیتابیس وردپرس متصل کنید و نام دیتابیس و نام و پسورد کاربر جدید رو وارد فایل wp-config.php کنید .

  • Babak

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۳
    تشکر شده: ۵ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۶ آبان ۱۳۸۶ - ۲۲:۲۸

    يه مشكلي كه منم بعد از Upgrade كردن به ورژن 2.3.1 داشتم اين بود كه تمام متن‌هاي فارسي به صورت علامت سئوال نشون داده ميشد. من هميشه فايل wp-config.php رو Move ميكردم اين دفعه دستي اطلاعات رو وارد كردم كه باعث به هم ريختگي شد و متوجه شدم مشكل از اين يك خط كد هست:

    define('DB_CHARSET', 'utf8');

    پاكش كردم درست شد.

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۶ آبان ۱۳۸۶ - ۲۳:۵۹

    موقع ارتقا به سری ۲.۳ بهتره اون دو خط مربوط به کاراکترهای دیتابیس رو خالی بذارین تا مشکلی پیش نیاد :)

  • mmahdi

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱
    # نوشته شده: ۱۲ سال پیش
    ۱۷ آبان ۱۳۸۶ - ۱۱:۴۸

    Babak گفت:
    يه مشكلي كه منم بعد از Upgrade كردن به ورژن 2.3.1 داشتم اين بود كه تمام متن‌هاي فارسي به صورت علامت سئوال نشون داده ميشد. من هميشه فايل wp-config.php رو Move ميكردم اين دفعه دستي اطلاعات رو وارد كردم كه باعث به هم ريختگي شد و متوجه شدم مشكل از اين يك خط كد هست:

    define('DB_CHARSET', 'utf8');

    پاكش كردم درست شد.

    حاجی درست شد. خیلی ممنون؟
    کارت حرف نداشت

  • مانی

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۶۹۶
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۸ آبان ۱۳۸۶ - ۰۲:۳۸

    Gonahkar گفت:
    موقع ارتقا به سری ۲.۳ بهتره اون دو خط مربوط به کاراکترهای دیتابیس رو خالی بذارین تا مشکلی پیش نیاد :)

    فکر کنم این هم جواب بده همیشه (در مورد این مشکل) :

    define('DB_CHARSET', 'latin1');
    define('DB_COLLATE', 'latin1_swedish_ci');

درباره‌ی این موضوع



برچسب‌ها