انجمن


مشکل در نصب افزونه feed wordpress  (۹ نوشته)

  • behrooz0o

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۴۰
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۰ سال پیش
    ۱۷ مهر ۱۳۸۸ - ۲۳:۱۰

    سلام امروز می خواتم افزونه فید وردپرس رو نصب کنم وقتی افزونه رو اکتیو کردم پیغام زیر رو داد البته افزونه فعال شد اما مشکل داره:
    FeedWordPress has detected that you are currently using a version of MagpieRSS other than the upgraded version that ships with this version of FeedWordPress.

    * Currently running: MagpieRSS 2.8.4-default
    * Version included with FeedWordPress 2009.0707: MagpieRSS 2009.0618

    It is strongly recommended that you install the upgraded version of MagpieRSS supplied with FeedWordPress. The version of MagpieRSS that ships with WordPress is very old and buggy, and encounters a number of errors when trying to parse modern Atom and RSS feeds.

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۰ سال پیش
    ۲۰ مهر ۱۳۸۸ - ۰۸:۴۳

    خب همون MagpieRSSی که همراه feedwordpress هست رو جایگزین کنین.

  • behrooz0o

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۴۰
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۰ سال پیش
    ۲۰ مهر ۱۳۸۸ - ۱۱:۴۰

    گناهکار جان من هرچی همراه feedwordpress بود رو اکتیو کردم اما چیزی راجع به MagpieRSS ندیدم...
    MagpieRSS افزونه هستش؟
    از کجا باید ببینم؟

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۰ سال پیش
    ۲۰ مهر ۱۳۸۸ - ۱۲:۳۵

    MagpieRSS در واقع یه کلاس php جداگونه هست برای خوندن محتویات RSS و تفسیر اون٬ که وردپرس هم ازش استفاده می‌کنه: http://magpierss.sourceforge.net

    وردپرس این کلاس رو توی wp-includes/rss.php ذخیره کرده٬ فکر کنم از اون‌جا بتونین بازنویسی‌ش کنین.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    behrooz0o - m-mehdipoor
  • behrooz0o

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۴۰
    تشکر شده: ۵۳ بار
    # نوشته شده: ۱۰ سال پیش
    ۲۰ مهر ۱۳۸۸ - ۲۳:۲۰

    گناهکارجان شرمندتم به خدا می دونم سرت شلوغه اما می تونید بیشتر توضیح بدید که باید چکار کنم؟

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۰ سال پیش
    ۲۱ مهر ۱۳۸۸ - ۱۴:۳۳

    توی پرونده‌ی feedWordpressی که از سایت وردپرس دریافت می‌کنین٬ یه پوشه وجود داره به‌نام MagpieRSS-upgrade که دو تا پرونده‌‌ی php توی اون هست٬ این دو تا پرونده رو به پوشه‌ی wp-includes کپی کنین. چون دو پرونده به همین نام‌ها در wp-includes وجود دارن٬ شما باید پرونده‌های جدید رو جایگزین‌ه قبلی‌ها کنین.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    بهرنگ - behrooz0o
  • bejlali

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۹ شهریور ۱۳۸۹ - ۲۱:۴۴

    سلام
    لطفا واسه نصب این افزونه کمکم کنید
    موقع فعال سازی افزونه این پیام رو میده

    (به‌دلیل داشتن مشکلی جدیافزونه فعال نشد.

    Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 4864 bytes) in /home/vol8/gigpa.com/gigpa_6125691/htdocs/wp-includes/class-simplepie.php on line 13816

  • bejlali

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۹ شهریور ۱۳۸۹ - ۲۱:۵۵

    خط 13816 هم ابتدای تایع هستش بترتیب زیر

    خط 13816 =====> function parse()
    {
    while ($this->state && $this->state !== 'emit' && $this->has_data())
    {
    $state = $this->state;
    $this->$state();
    }
    $this->data = '';
    if ($this->state === 'emit')
    {
    return true;
    }
    else
    {
    $this->version = '';
    $this->encoding = '';
    $this->standalone = '';
    return false;
    }
    }

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۹ سال پیش
    ۱۹ شهریور ۱۳۸۹ - ۲۳:۲۰

    سلام, خط رو کاری نداشته باشید
    این مشکل رو خیلی ها داشتن
    http://forum.wp-persian.com/search.php?q=Allowed+memory+size
    http://forum.wp-persian.com/search.php?search=Fatal+error&forum-id=0

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.