انجمن


ایراد در ترجمه پوسته با poedit  (۳ نوشته)

  • ramtin

    آفلاین
    عضو
    تعداد نوشته‌ها: ۸
    تشکر شده: ۳ بار
    # نوشته شده: ۱۲ سال پیش
    ۵ آبان ۱۳۸۸ - ۲۳:۱۲

    سلام بچه ها....وقت همتون بخیر......من تاپیکای مربوط به فارسی سازی پوسته رو خوندم ولی تنونستم مشکلی که برام افتاد رو جایی ببنیم......دو تا سوال داشتم....اولی در مورد poeditهستش که طبق مطلب متابلاگ در مورد فارسی سازی استاندارد پوسته.... در قسمتی که مسیر پوسته رو میذاشتم.....و در نهایت تاید رو میزدم همیشه erorمیداد تا اینکه طبق گفته متابلاگ عزیز نقطه گذاشتم و این مساله حل شد....میخواستم بدونم مشکل چیه که با یه نقطه حل میشه؟؟
    دومین سوالم مربوط به اینه که کد<?php load_theme_textdomain('default'); ?>
    رو کجا باید گذاشت؟؟توی تاپیکی که اینجا سنجاق شده گفته شده باید توی header.phpباید گذاشت .....ولی توی مطلب متابلاگ گفته شد که توی function.phpگذاشته شود......سوالم اینه که توی کدوم قسمت باید بذاریم hedearیا function؟؟اولین کد توی صفحه باشه؟زیز یه کد دیگه؟دقیقا کجا؟تقریبا لاین چند میشه؟
    چون من توی هر کدومشون گذاشتم و در نهایت وقتی در قسمت پوسته کنترل پنلم و روی پوسته مورد نظرم کلیک کردم....یه صفحه سفید با این نوشه اومد:
    msgid "" msgstr "" "Project-Id-Version: a\n" "POT-Creation-Date: \n" "PO-Revision-Date: \n" "Last-Translator: ramtin \n" "Language-Team: \n" "MIME-Version: 1.0\n" "Content-Type: text/plain; charset=utf-8\n" "Content-Transfer-Encoding: 8bit\n" "X-Poedit-Basepath: E:\\easy php\\EasyPHP1-8\\www\\wordpress\\wp-content\\themes\\seebsabz\n"

    خیلی ممنون و ببخشید که وقتتون رو گرفتم

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۶ آبان ۱۳۸۸ - ۱۶:۰۷

    در قسمتی که مسیر پوسته رو میذاشتم.....و در نهایت تاید رو میزدم همیشه erorمیداد

    چه ایرادی می‌گرفت؟

    دومین سوالم مربوط به اینه که کد<?php load_theme_textdomain('default'); ?>
    رو کجا باید گذاشت؟؟

    اول این‌که اون default رو باید به اسم پوسته‌تون تغییر بدین٬ توی هر کدوم از پرونده‌های header یا function هم بذارین احتمالن جواب بده.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    ramtin_b
  • ramtin_b

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱
    # نوشته شده: ۱۲ سال پیش
    ۶ آبان ۱۳۸۸ - ۲۰:۲۲

    اول از هر چیز.....یه عذر خواهی بزرگ...به خاطر ساختن userجدید.....توی این سه روز که عضو شدم و پسوردم رو عوض کردم....هر دفعه موقع loginارور داد.....و هر دفعه هم تقاضای درخواست پسورد جدید کردم....که امروز با اینکه چند بار روی بازیابی رمز کلیک کردم......چیزی به mail من ارسال نشد......بازم عذر میخوام به خاطر ساختن یوزر جدید

    خیلی ممنون که جواب دادید.....اروری که Poeditمیده اینه که پرونده ها و توابع رو پیدا نمیکنه و در نتیجه ارور میداد.....
    در مورد کد هم.....بله بنده اسم پوسته رو میذاشتم جایdefualt .......ولی امروز که دوباره ازمایش کردم.....همون متنی که گفتم میاد.....حتی وقتی که از دوتاشون هم برداشتم.....بازهم این ارور بود!!!
    احیانا مشکل از فایل زبان نیست؟؟؟
    شما خودتون در قسمت basepathو pathتوی برنامه چی وارد میکنید؟فقط مسیر؟یا نقطه؟

درباره‌ی این موضوع