انجمن


خطا در برقراری ایرتباط با پایگاه‌داده 2  (۲ نوشته)

  • Sarvha

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱
    # نوشته شده: ۱۰ سال پیش
    ۱۴ فروردین ۱۳۸۹ - ۱۷:۳۶

    سلام من کانفیگ را به صورت زیر تغیر دادم اما
    <?php

    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
    * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'putyourdbnamehere');

    /** MySQL database username */
    define('DB_USER', 'usernamehere');

    /** MySQL database password */
    define('DB_PASSWORD', 'yourpasswordhere');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', 'put your unique phrase here');
    define('SECURE_AUTH_KEY', 'put your unique phrase here');
    define('LOGGED_IN_KEY', 'put your unique phrase here');
    define('NONCE_KEY', 'put your unique phrase here');
    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * fa_IR.mo to wp-content/languages and set WPLANG to 'fa_IR' to enable Persian
    * language support.
    */
    define ('WPLANG', 'fa_IR');

    /* That's all, stop editing! Happy blogging. */

    /** WordPress absolute path to the Wordpress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    // ** MySQL settings ** //
    define('DB_NAME', 'sarvhac_wptehran');
    define('DB_USER', 'sarvhac_shining');
    define('DB_PASSWORD', '*********');
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    شما مطمئن هستید که نام‌کاربری و رمز (مربوط به پایگاه‌داده) را درست وارد کرده‌اید؟
    شما مطمئن هستید که نام سرویس‌دهنده (hostname) را درست وارد کرده‌اید؟
    شما مطمئن هستید که سرویس‌دهنده‌ی پایگاه‌داده در حال اجراست؟
    چک کردم همه چیز درست است !!!
    در ضمن یه مشکل دیگه هم برام بوجود خواهد آمد
    و آن نحوه تعیین دسترسی برای htaccess
    ایمیل من
    shining.aryan@live.com

  • Sarvha

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱
    # نوشته شده: ۱۰ سال پیش
    ۱۵ فروردین ۱۳۸۹ - ۰۰:۱۲

    یک فایل دیگر upload کردم درست شد
    htaccess هم درست کردم

درباره‌ی این موضوع



برچسب‌ها