انجمن


مشکل در فعال کردن افزونه  (۲۲ نوشته)

  • علی ایرانی

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۷۸۶
    تشکر شده: ۷۶ بار
    # نوشته شده: ۱۲ سال پیش
    ۲ اسفند ۱۳۸۶ - ۱۴:۵۴

    توی وردپرس اوبونتوم که می‌خوام افزونه ای رو فعال کنم یه اررو میده؟
    http://i27.tinypic.com/2ekoyex.jpg

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۲ اسفند ۱۳۸۶ - ۱۵:۰۷

    با htacess می تونی میزان حافظه رو ببری بالاتر. مزدک یه بار توضیح داده . به سرچ ... ;-)

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    ~> Mr.vAhiD.DI <~
  • علی ایرانی

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۷۸۶
    تشکر شده: ۷۶ بار
    # نوشته شده: ۱۲ سال پیش
    ۳ اسفند ۱۳۸۶ - ۰۰:۲۹

    چیزی پیدا نکردم :-(

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۳ اسفند ۱۳۸۶ - ۰۰:۴۶

    یه چیز جدید پیدا کردم . لطفا اینو تست کن :
    در فایل wp-config.php اینو اضافه کن بین تگ های پی اچ پی :
    @ini_set("memory_limit","16M");

    نتیجش رو بگو لطفا...

  • علی ایرانی

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۷۸۶
    تشکر شده: ۷۶ بار
    # نوشته شده: ۱۲ سال پیش
    ۳ اسفند ۱۳۸۶ - ۱۱:۵۲

    ممنون
    درست شد :-)

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۳۰ فروردین ۱۳۸۷ - ۱۰:۴۰

    سلام.
    من عین کد رو کپی پیست کردم توی یک خط خالی از فایل.
    اما مشکل به قوت خودش باقی مونده.

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۳۰ فروردین ۱۳۸۷ - ۱۱:۲۸

    این باید قبل از کد پی اچ پی باشه :
    ?>

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۳۱ فروردین ۱۳۸۷ - ۱۲:۳۹

    سلام. بازم کار نمیکنه. این جوری نوشتم:

    <?php
    
    @ini_set("memory_limit","16M");
    // ** MySQL settings ** //
    define('DB_NAME', 'xxxxx');    // The name of the database
    define('DB_USER', 'xxxxx');     // Your MySQL username
    define('DB_PASSWORD', 'xxxxx'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    
    // Change SECRET_KEY to a unique phrase.  You won't have to remember it later,
    // so make it long and complicated.  You can visit https://www.grc.com/passwords.htm
    // to get a phrase generated for you, or just make something up.
    define('SECRET_KEY', 'put your unique phrase here'); // Change this to a unique phrase.
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* That's all, stop editing! Happy blogging. */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۳۱ فروردین ۱۳۸۷ - ۱۳:۱۸

    اینو تست کنید :

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'xxxxx');    // The name of the database
    define('DB_USER', 'xxxxx');     // Your MySQL username
    define('DB_PASSWORD', 'xxxxx'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    
    // Change SECRET_KEY to a unique phrase.  You won't have to remember it later,
    // so make it long and complicated.  You can visit https://www.grc.com/passwords.htm
    // to get a phrase generated for you, or just make something up.
    define('SECRET_KEY', 'put your unique phrase here'); // Change this to a unique phrase.
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* That's all, stop editing! Happy blogging. */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    @ini_set("memory_limit","16M");
    ?>
  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۳۱ فروردین ۱۳۸۷ - ۱۳:۲۸

    این اررور رو میده:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 77824 bytes) in /home/public_html/wp-admin/includes/dashboard.php on line 134

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۳۱ فروردین ۱۳۸۷ - ۱۴:۵۸

    اون ۱۶ رو بکنید ۳۲ یا ۶۴

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۶ اردیبهشت ۱۳۸۷ - ۱۳:۰۲

    من این کارو هم کردم بازم نشد. حالا میگید چیکار کنم؟! این افزونه ای که الان هست جدیدتره از اینی که یک هفته پیش بود یا همونه؟

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۷ اردیبهشت ۱۳۸۷ - ۲۰:۱۴

    شاید هاستتون اجازه تغییر رو نمی ده. بهشون ایمیل بزنید و موضوع را مطرح کنید ...

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۱۲ اردیبهشت ۱۳۸۷ - ۱۱:۱۳

    navid گفت:
    شاید هاستتون اجازه تغییر رو نمی ده. بهشون ایمیل بزنید و موضوع را مطرح کنید ...

    سلام. بله علی الظاهر و الباطن هاست اجازه این کار رو نمیده. پشتیبانی سایت این پیغام رو برام فرستاده و میگه باید کدها عوض بشن:

    Ba salam
    Script shoma say dar gereftane meghdar ziadi az fazaye server ra dar har bar ejra roye har session darad.
    Az onja ke server ShareHosting mibashad va ghatan control ingone bahrebardariha mahdod shode ast, leza nesbat be eslah in moshkel va ya kam kardane meghdar arayeha va moteghayyerhaye por hajm dar hafeze eghdam farmaeid.

    به نظر منم این اشکال یه اشکال عمومیه و ممکنه برای همه پیش بیاد. به نظرتون وقتش نرسیده کدهای افزونه optimize بشن؟

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۲ اردیبهشت ۱۳۸۷ - ۲۰:۳۵

    من در تعجبم که چرا جلوی شما رو تا این حد گرفتن. افزونه ای که می خواهید نصب کنید اسمش چیه ؟!
    معمولا افزونه ها سنگین نیستن اگر سنگین باشن مورد استقبال قرار نمی گیرن. کلا اون مقدار مقدار بسیار پایینی هست که درخواست شده ...

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۱۳ اردیبهشت ۱۳۸۷ - ۱۶:۰۷

    navid گفت:
    من در تعجبم که چرا جلوی شما رو تا این حد گرفتن. افزونه ای که می خواهید نصب کنید اسمش چیه ؟!
    معمولا افزونه ها سنگین نیستن اگر سنگین باشن مورد استقبال قرار نمی گیرن. کلا اون مقدار مقدار بسیار پایینی هست که درخواست شده ...

    افزونه ای که میخوام نصب کنم همین افزونه جدید وردپرس فارسیه!
    به نظرم این افزونه مشکل داره چون با سایر افزونه های ورژن قبلی مشکلی پیش نمیاد.

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۳ اردیبهشت ۱۳۸۷ - ۱۶:۳۱

    کلا وردپرس فارسی نیاز به قدرت بیشتری از سرور داره چراکه باید کلمات فارسی جایگزین انگلیسی بشن. اما خود افزونه وردپرس فارسی نباید مشکلی داشته باشه ... احتمالا مربوط به فارسی سازی می شه ... ;-)

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۱۳ اردیبهشت ۱۳۸۷ - ۱۸:۴۰

    میدونید چیه من افزونه فارسی رو روی وردپرس 2.3.3 نصب کردم مشکل مموری پیش نیومد، اما روی 2.5 این مشکل وجود داره. الان هم تصمیم گرفتم روی سایتم 2.3.3 رو موقتا نصب کنم تا ورژن های بعدی آزمایش بشه و این مشکلات برطرف بشه.

  • reza1022

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    # نوشته شده: ۱۲ سال پیش
    ۱۴ اردیبهشت ۱۳۸۷ - ۲۳:۳۸

    آقا مجددا پشتیبانی این جواب رو داده:

    Ba salam
    Beharhal hamaknon scripthaye ziadi niz roye server ma ba hamin limitaion kar mikonand! (Bish az 1200 site!)
    Ghatan harchi hast be nahve estefade script shoma az meghdar ghabele estefade RAM bastegi dare..
    Lotfan darbare in moshkel dar forumha search konid..

    من تست کردم افزونه wp-jalali روی وردپرس 2.3.3 کار میکرد. با وردپرس 2.5 دچار این مشکل میشه.

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۹ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۵ اردیبهشت ۱۳۸۷ - ۰۷:۰۳

    ببینید 2 تا بحثه یکی محدودیت یکی فشار زیاد.
    معمولا هاست ها وقتی فشار به سرور زیاد باشه ایمیل می زنن و تذکر و ... می دن. ممکنه یه برنامه نیازش بیشتر باشه ولی خب دلیل نمی شه فشار زیادی به سرور بیاره. بطور مثال شما می تونید در هاست های دیگه مقدار حافظه رو 64 یا 128 مگ بکنید. ولی آیا اصلا این مقدار یک دهمش هم استفاده می شه ؟

  • komakhesabdar

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۰
    # نوشته شده: ۷ سال پیش
    ۲۷ خرداد ۱۳۹۲ - ۲۳:۵۳

    با سلام
    دوستان من افزونه edd را نصب كردم ولي هنگام فعال كردن افزونه يه صفحه خطا مياد كه مينويسه نشاني معتبر نميباشد همه نسخه هاي edd را امتحان كردم نشد كه نشد.
    لطفا راهنماييم نماييد
    با تشكر

  • komakhesabdar

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۰
    # نوشته شده: ۷ سال پیش
    ۲۸ خرداد ۱۳۹۲ - ۱۱:۱۴

    لطفا يكي كمك كنه ضروريه

درباره‌ی این موضوع