انجمن


مشکل با تغییر پیوند یکتا  (۱۷ نوشته)

  • python

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸۶
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۲۷ فروردین ۱۳۹۰ - ۱۹:۰۰

    با سلام
    پیوند یکتای من به این شکل هستش
    /%postname%/
    الان میخوام تبدیلش کنم به این
    /%postname%.html
    یعنی آدرسم به این شکل باشه:
    site.com/postname.html
    اما وقتی تغییرش میدم آدرس های قبلی 404 میشن
    من از افزونه Dean's Permalinks Migration 1.0 هم استفاده میکنم و بعد از تغییر توی افزونه قسمت Old Permalink Structure پیوند یکتای قبلی رو که به این /%postname%/ صورت بود رو وارد میکنم اما بازم خطای 404 رو میده چیکار کنم درست بشه؟
    ممنون

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    forklift
  • python

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸۶
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۲۷ فروردین ۱۳۹۰ - ۱۹:۱۹

    مشکلم حل شد

  • blacknet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۲ بار
    # نوشته شده: ۸ سال پیش
    ۶ اردیبهشت ۱۳۹۰ - ۱۴:۰۶

    سلام
    چه خوب میشد اگر یه توضیحی میدادید.شما که مشکلتون حل شد
    من همین چند روز پیش وردپرس رو نصب کردم.(واقعا برای من که کد بلد نیستم خیلی سخته،البته برای کار در سطح حرفه ای)
    پیوند یکتا سایتم رو تغییر دادم به /%postname%/ اما پست های قبلیم و حتی پست هایی که بعد از تغییر پیوند یکتا منتشر میکنم نمایش داده نمیشه!یا به قول خودمون 404 میشه.
    همینطور تمامی برگه های ایجاد شده 404 میشن.
    لطفا من رو راهنمایی کنید.ممنون

  • python

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸۶
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۶ اردیبهشت ۱۳۹۰ - ۱۹:۳۹

    سلام
    این افزونه رو نصب و فعال کن ببین مشکلت حل میشه؟

    http://downloads.wordpress.org/plugin/permalinks-moved-permanently.zip

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    بهروز ازند
  • blacknet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۲ بار
    # نوشته شده: ۸ سال پیش
    ۶ اردیبهشت ۱۳۹۰ - ۲۰:۲۵

    سلام
    افزونه رو نصب کردم،تنظیماتی چیزی نداره؟چون هیچی تغییر نکرد!

  • Saeed Fard

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۹۸۲
    تشکر شده: ۱۶۱۵ بار
    # نوشته شده: ۸ سال پیش
    ۶ اردیبهشت ۱۳۹۰ - ۲۰:۴۸

    دوست عزیز blacknet خان ، اول اینکه به وردپرس خوش اومدی ،، ایشاالله که سریع همه چیزش رو یاد میگیری ..

    یکی از قوانین انجمن اینه که قبل از پرسیدن مشکل ، تو انجمن جستجو کنی و نتایج جستجو رو مطالعه کنی ..

    این مشکلی که شما داری خیلی مطرح شده و بحث شده و به جواب هم رسیده ، اگه شما نتایج جستجو رو مطالعه میکردی حتما مشکلت رو حل میکردی ..
    پیشنهاد میکنم مطالعه کن ..

    نتایج جستجو :

    http://forum.wp-persian.com/search.php?q=%D9%BE%DB%8C%D9%88%D9%86%D8%AF+%DB%8C%DA%A9%D8%AA%D8%A7

    اگه موفق نشدی درستش کنی ،، مطرح کن ..

    موفق باشید ../.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    بهروز ازند
  • blacknet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۲ بار
    # نوشته شده: ۸ سال پیش
    ۸ اردیبهشت ۱۳۹۰ - ۱۹:۱۲

    Saeed Fard عزیز سلام،ممنون که پاسخ دادی
    عزیزم من انجمن رو گشتم که به اینجا رسیدم دیگه!گفتم این آقا مشکلش حل شده بلکه بتونه مشکل ما رو هم حل کنه!
    من مطالب دیگه رو خوندم و انجام دادم اما هنوز مشکلم حل نشده و سایت خوابیده!
    در یه تاپیک دیگه هم مطرح کردم اما کسی جواب نداد.
    ممنون میشم کار ما رو همینجا را بندازید ما بریم سر مشکل بعدی
    =====ضمنا=====
    الان که فید سایت رو بررسی کردم لینک سایتم درست شده اما صفحه اصلی سایتم 404 هست.

  • بهروز ازند

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵۱۹
    تشکر شده: ۷۹۹ بار
    # نوشته شده: ۸ سال پیش
    ۹ اردیبهشت ۱۳۹۰ - ۱۲:۴۲

    blacknet جان
    مطمئنی با تغییر پیند یکتا صفحه اصلی نشون داده نمیشه چون معمولا با تغییر پیوند یکتا صفحات پستها ، آرشیو ، برگه ها و تگها دچار ارور نمایش میشن و صفحه نخست که پیوندش تغییر نمیکنه که مشکل داشته باشته
    برای پیوند یکتا شما با چند پیش‌شرط روبرو هستید و اون اینه که سرور شما این اجازه رو به شما بده ویا نوع سرور (لینوکس یا ویندوز) که محدودیتهایی رو بوجود میارن و همچنین تنظیمات سابق در فایل htaccess
    که میتونن مشکلساز بشن و حتی مانع این تغییر بحث بعدی بعد از مشکل شما این نکته هم قابلیت پیوند یکتا رو که خیلی ها برای بهبود سئو ازش استفاده میکنن در استفاده از اون بی‌دقتی میکنن که باعث افت سئو میشه
    شما این موارد رو بیان کنید تا دوستای گلم بهتر از مسئله شما آگاه بشن
    آدرس سایت
    نوع سرور
    محتویات فایل htaccess
    اقداماتی که گفتید انجام داده اید
    البته ساده ترین راه اینه که با پشتیبان سرورت تماس بگیری

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Saeed Fard - blacknet
  • python

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸۶
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۹ اردیبهشت ۱۳۹۰ - ۱۳:۲۵

    افزونه رو نصب کردم،تنظیماتی چیزی نداره؟چون هیچی تغییر نکرد!

    این افزونه به طور اتوماتیک این کار یعنی عمل ریدایرکت رو انجام میده و نیازی به تنظیمش نیست
    شاید مشکل شما از یه جای دیگه باشه
    چون تغییر پیوند یکتا اونطور که دوستمون گفتن ربطی به صفحه اصلی نداره

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Saeed Fard - blacknet
  • blacknet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۲ بار
    # نوشته شده: ۸ سال پیش
    ۱۱ اردیبهشت ۱۳۹۰ - ۰۰:۳۰

    سلام
    آقا شرمنده نوشته ي من به صورت كلي منظور رو اشتباه ميرسونه!
    منظور من از اين كه صفحه اصلي سايتم 404 ميشه اين بود كه صفحه بالا مياد(قالب بار گذاري ميشه،برگه ها هستن و همه چي خوبه) اما بجاي پست ها پيغام نوشته يافت نشد - 404 نشون داده ميشه.
    پشتيبان من هم اعلام ميكنه كه مشكلات سي ام اسي به ما مربوط نيست و توي انجمن هاي خودشون مشكل رو مطرح كنيد

  • enik

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۷۷
    تشکر شده: ۱۱ بار
    # نوشته شده: ۸ سال پیش
    ۱۱ اردیبهشت ۱۳۹۰ - ۱۳:۵۸

    اگر از اول بالا آمدن سایت ها با وردپرس سعی کنید در آدرس از آی دی استفاده کنید. به هنگام تغییر پیوند یکتا به پیوندی دیگر که باز هم همان آی دی داشته باشد. وردپرس اتوماتیک آدرسی قبلی را بر آدرس جدید ریدایرکت می کند
    %post-id%

  • blacknet

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۵
    تشکر شده: ۲ بار
    # نوشته شده: ۸ سال پیش
    ۱۱ اردیبهشت ۱۳۹۰ - ۱۷:۲۳

    من كه نفهميدم الان بايد چيكار كنم!؟
    شما ميگي پيوند يكتا رو post-id بذارم؟ اونوقت آدرس عددي ميشه كه هيچ تأثيري توي سئو نداره!
    من اول رفتم پيوند يكتا رو پيشفرض كردم بعد دسترسي فايل h.... رو به 777 تغيير دادم بعد محتوياتش رو طبق گفته دوستان در ساير تاپيك ها تغيير دادم بعد پيوند يكتا رو دلخواه كردم و دسترسي اون فايل كذايي رو 644 كردم و همچنان 404!

  • python

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۸۶
    تشکر شده: ۴۸ بار
    # نوشته شده: ۸ سال پیش
    ۱۲ اردیبهشت ۱۳۹۰ - ۱۰:۵۲

    شما یه بار قالبتون رو عوض کنید روی پیش فرض بذارید
    احتمالا مشکل از قالبتون باشه
    حداقل آدرس سایتتون رو بذارید ببینیم شاید فهمیدیم چشه؟

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    blacknet
  • h1h2h3

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۳
    تشکر شده: ۶ بار
    # نوشته شده: ۸ سال پیش
    ۵ تیر ۱۳۹۰ - ۱۵:۱۱

    اگر از كد زير در پيوند يكتا استفاده كنيد مشكلتون حل ميشه :

    /index.php/%category%/%postname%.html

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    blacknet
  • تصفیه آب خانگی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۶۱
    تشکر شده: ۴ بار
    # نوشته شده: ۶ سال پیش
    ۱۹ دی ۱۳۹۱ - ۱۴:۲۱

    h1h2h3 گفت:
    اگر از كد زير در پيوند يكتا استفاده كنيد مشكلتون حل ميشه :

    /index.php/%category%/%postname%.html

    استفاده كردم ولي مشكل حل نشد... ضمناً مي خواهم index.php از آدرس حذف شود. آدرس ها به اين صورت باشد: my.ir/sample.html

  • downdl

    آفلاین
    عضو
    تعداد نوشته‌ها: ۵
    # نوشته شده: ۵ سال پیش
    ۵ مهر ۱۳۹۲ - ۱۱:۴۱

    اقا منم همین مشکلو دارم و مشکل اینجاست دیگه حتی به صفحه مدیریت نمیره !
    تورو خدا کمک کنید

  • Seo one

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۵۰
    تشکر شده: ۸۹ بار
    # نوشته شده: ۵ سال پیش
    ۷ مهر ۱۳۹۲ - ۱۴:۲۲

    فایل htaccess ببینید تو روت سایت شملا هست یا نه ازش یه کپی بگیرید و بعد حذف کنیدش بیبنید مشلکلتون حل میشه یا نه

درباره‌ی این موضوع



برچسب‌ها