انجمن


باگ پلاگين YOAST Seo و ايجاد مشكل در Open Graph سايت  (۲ نوشته)

  • DariushGreat

    آفلاین
    عضو
    تعداد نوشته‌ها: ۴۸
    تشکر شده: ۱۹ بار
    # نوشته شده: ۴ سال پیش
    ۱۸ بهمن ۱۳۹۳ - ۱۱:۴۸

    با عرض سلام و خسته نباشيد
    يك بار امكان سوشيال پلاگين Yoast رو فعال كردم. بعد به دليل اين كه خروجي مناسب متاتگ هاي اپن گراف رو نداشت غير فعالش كردم تا با روشي ديگه امتاها رو اعمال كنم. مساله اينجاست كه اين پلاگين ديگه متا تگ هاشو غير فعال نميكنه. با نصب پلاگين هاي ديگه مربوط به اپن گراف، در عملكردشون تداخل ايجاد مي كنه (مثلا دو تا og:image ميده بيرون يا دو تا og:describtion) و خود وردپرس هم مدام هشدار اين مساله رو ميده. از طرفي هم اگر به شكل دستي كد رو اضافه كنم باز به دليل اولويت اپن گراف اين پلاگين در راس پردازش قرار ميگيره و كدها رو بعد ايجاد ميكنه و باز هم تداخل رخ ميده. اين باگ خود پلاگينه كه در ورژن جديدش گريبان خيليا رو گرفته.
    چطور مي تونم از طريق function.php يا دستكاري خود افزونه YOAST امكان سوشيالش رو براي هميشه خاموش كنم؟

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    آموزش وردپرس - ahang90
  • آموزش وردپرس

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۸۳۹
    تشکر شده: ۱۷۶۵ بار
    # نوشته شده: ۴ سال پیش
    ۱۹ بهمن ۱۳۹۳ - ۰۲:۵۹

    DariushGreat گفت:
    با عرض سلام و خسته نباشيد
    يك بار امكان سوشيال پلاگين Yoast رو فعال كردم. بعد به دليل اين كه خروجي مناسب متاتگ هاي اپن گراف رو نداشت غير فعالش كردم تا با روشي ديگه امتاها رو اعمال كنم. مساله اينجاست كه اين پلاگين ديگه متا تگ هاشو غير فعال نميكنه. با نصب پلاگين هاي ديگه مربوط به اپن گراف، در عملكردشون تداخل ايجاد مي كنه (مثلا دو تا og:image ميده بيرون يا دو تا og:describtion) و خود وردپرس هم مدام هشدار اين مساله رو ميده. از طرفي هم اگر به شكل دستي كد رو اضافه كنم باز به دليل اولويت اپن گراف اين پلاگين در راس پردازش قرار ميگيره و كدها رو بعد ايجاد ميكنه و باز هم تداخل رخ ميده. اين باگ خود پلاگينه كه در ورژن جديدش گريبان خيليا رو گرفته.
    چطور مي تونم از طريق function.php يا دستكاري خود افزونه YOAST امكان سوشيالش رو براي هميشه خاموش كنم؟

    به نام خدا
    عرض سلامو خسته نباشید به نظرم نمیرسه از طریق فانکشن بشه کاری کرد ! من به شخصه خودم بررسی کردم یه مرتبه دیدم عبارت fa-IR رو می نویسه fa_IR که این صحیح نیست ! بعد رفتم افزونه رو ویرایش کردم دیدی ای بالا تا ویرایش می کنم خود به خود میشه en_US بعدش بی خیال شدمو بر گردوندم روی همون fa_IR گفتم به همینم قانع هستیم دوباره بعد از چند ماه سه یا چهار روز پیش این مورد رو انجام دادم همین مشکل پیش اومد و با کمی دقت دیدم ای دل قافل تو خط بالایی که من ویرایش کردم نوشته en_US که اونم گذاشتم fa-IR درست شد در مورد مشکل شما هم باید با دقت بیشتری از داخل همون فایلی که متا تگ ها قرار دادن که الان اسمشو یادم نیست این تگ ها رو غیر فعال کنید ! تا بعدا به قابلیت های افزونه اضافه بشه با تشکر
    ارادتمند : مسلم فلاح نیت

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    DariushGreat - techno

درباره‌ی این موضوع