انجمن


مشکل با قسمت پیوند یکتا در پوسته  (۷ نوشته)

  • dorsashop.ir

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    تشکر شده: ۱ بار
    # نوشته شده: ۷ سال پیش
    ۱۰ اردیبهشت ۱۳۹۱ - ۱۴:۲۹

    سلام من از پوسته IT Blogs 4.4 استفاده میکنم.
    در قسمت پیوند یکتا فقط حالت پیشفرض ( http://127.0.0.1/?p=123 ) درست عمل میکنه و بقیه قسمت ها درست نیست.من میخوام حالت نام نوشته (http://127.0.0.1/نوشته-نمونه/ ) رو انتخاب کنم . زمان انتخاب توی سایت ارور میده . چه کار باید بکنم تا مشکل حلشه ؟ البته تمام حالت ها به جز پیش فرض مشکل دارن و ارور میدن !
    با تشکر .

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    forklift
  • بهروز ازند

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۲
    تشکر شده: ۷۶ بار
    # نوشته شده: ۷ سال پیش
    ۱۳ اردیبهشت ۱۳۹۱ - ۱۳:۵۲

    این مورد به فعال بودن mod_rewrite در هاست شما مربوط میشه و تنظیمات فایل .htaccess
    برای اولی فقط میتونی با پشتیبانی سرور تماس بگیری تا مطمئن بشی این مورد فعال هست یا نه
    در مورد دومی اگه اولی اکی بود
    کد زیر رو داخل نرم افزار نوتپد بنویس

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    و با دقیقا با نام زیر سیو کن و تو فولدر اصلی سایتت آپلود کن
    .htaccess

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    dorsashop.ir
  • dorsashop.ir

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    تشکر شده: ۱ بار
    # نوشته شده: ۷ سال پیش
    ۱۳ اردیبهشت ۱۳۹۱ - ۱۵:۳۶

    kalarena گفت:
    این مورد به فعال بودن mod_rewrite در هاست شما مربوط میشه و تنظیمات فایل .htaccess
    برای اولی فقط میتونی با پشتیبانی سرور تماس بگیری تا مطمئن بشی این مورد فعال هست یا نه
    در مورد دومی اگه اولی اکی بود
    کد زیر رو داخل نرم افزار نوتپد بنویس

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    و با دقیقا با نام زیر سیو کن و تو فولدر اصلی سایتت آپلود کن
    .htaccess

    با تشکر از راهنمایی . اما من هنوز روی لوکال هاست دارم سایتم رو راه اندازی میکنم! شما میگید به هاست من مربوط میشه . اما در حال حاظر هاست من لوکال هست.
    نمیتونید خودتون بگید کدوم قسمت هست تا تغییرش بدم ؟
    مورد دوم هم توی htaccess قرار دادم اما نمیشد ! چون مشکل اول حل نشده هنوز دیگه !
    اگه کمک کنید بازم ممنون میشم

  • بهروز ازند

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱۲
    تشکر شده: ۷۶ بار
    # نوشته شده: ۷ سال پیش
    ۱۳ اردیبهشت ۱۳۹۱ - ۲۱:۱۴

    اگه از ومپ سرور استفاده میکنید برای سرور لوکال
    روی آیکونش در تسک بار کلیک کنید از زبانه apache روی apache madules کلیک کنید و تیک
    rewrite_madule
    رو بزنید حالا میتونید از پیوند یکتا استفاده کنید

  • علی سجادی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۴ بار
    # نوشته شده: ۷ سال پیش
    ۱۳ اردیبهشت ۱۳۹۱ - ۲۱:۲۲

    توصیه میکنم از اسم پست توی پیوند یکتا استفاده نکنین. چون باعث افزایش کارکرد سی پی یوی سرورتون میشه و ممکنه هاست بهتون اخطار بده.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    dorsashop.ir
  • dorsashop.ir

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    تشکر شده: ۱ بار
    # نوشته شده: ۷ سال پیش
    ۱۴ اردیبهشت ۱۳۹۱ - ۱۵:۲۴

    kalarena گفت:
    توصیه میکنم از اسم پست توی پیوند یکتا استفاده نکنین. چون باعث افزایش کارکرد سی پی یوی سرورتون میشه و ممکنه هاست بهتون اخطار بده.

    من میخوام پلاگین yoast wp seo نصب کنم. که در ابتدا بهم پیشنهاد داده که پیوند یکتا به صورت " نوشته نمونه " باشه. عنوان مطلب باشه ؛ فکر کنم واسه سئو بهتر باشه اما به سرور فشار میاره اگر حجم داده ها بالا باشه.

    kalarena گفت:
    اگه از ومپ سرور استفاده میکنید برای سرور لوکال
    روی آیکونش در تسک بار کلیک کنید از زبانه apache روی apache madules کلیک کنید و تیک
    rewrite_madule
    رو بزنید حالا میتونید از پیوند یکتا استفاده کنید

    اما من از easy php استفاده میکنم و توی گوگل هم یه سرچی در مورد همین apache modules کردم و یه اطلاعاتی هم کسب شد اما کافی نبود.
    نمیدونم دقیقا باید چه کاری رو کرد. اگه بازم راهنمایی کنید ممنون میشم.

  • dorsashop.ir

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    تشکر شده: ۱ بار
    # نوشته شده: ۷ سال پیش
    ۱۴ اردیبهشت ۱۳۹۱ - ۱۶:۳۱

    مشکل حل شد.
    باید از پوشه EasyPHP 3.0\conf_files فایل httpd.conf رو باز کرده و قسمت
    LoadModule rewrite_module modules/mod_rewrite.so # رو به
    LoadModule rewrite_module modules/mod_rewrite.so تغییر داد و سپس
    <Directory "${path}/www"> رو پیدا کرده که و AllowOverride None رو باید به AllowOverride All تغییر بدید و مشکل حل میشه. با تشکر از کمک دوستان (-;

درباره‌ی این موضوع



برچسب‌ها