انجمن


تصویر شاخص کمک  (۵ نوشته)

  • danial

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۵
    تشکر شده: ۱۲ بار
    # نوشته شده: ۷ سال پیش
    ۲۴ خرداد ۱۳۹۱ - ۱۳:۴۱

    سلام دوستان بنده از این کد برای تصویر شاخص استفاده میکن

    <?php the_post_thumbnail('thumbnail'); ?>

    کد به خوبی کار میکنه فقط یه مشکل دارم اینه میخوام وقتی پستی تصویر شاخص نداره یه عکس به جای اون نمایش داده بشه اینو گذاشتم ولی دوتا رو با هم نشون میده وقتی پست تصویر شاخص داره

    <?php the_post_thumbnail('thumbnail');  if(isset($image) && !empty($image)) {echo '<img src="'.get_post_meta($post->ID, 'image',true).'" class="post-pic"/>' ;} else {echo '<img src="'.get_bloginfo("template_url").'/images/none-pic.jpg" class="post-pic"/>' ;}?>
  • امید

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۱
    تشکر شده: ۱۸ بار
    # نوشته شده: ۷ سال پیش
    ۲۴ خرداد ۱۳۹۱ - ۱۸:۳۴

    if( has_post_thumbnail()){
     the_post_thumbnail();
    }else{
    echo '<img src="'.get_bloginfo("template_url").'/images/none-pic.jpg" class="post-pic"/>';
    }
  • LORD_PARSI

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۲
    تشکر شده: ۱ بار
    # نوشته شده: ۷ سال پیش
    ۲۴ خرداد ۱۳۹۱ - ۱۸:۴۲

    rap_bazi گفت:
    سلام دوستان بنده از این کد برای تصویر شاخص استفاده میکن

    <?php the_post_thumbnail('thumbnail'); ?>

    کد به خوبی کار میکنه فقط یه مشکل دارم اینه میخوام وقتی پستی تصویر شاخص نداره یه عکس به جای اون نمایش داده بشه اینو گذاشتم ولی دوتا رو با هم نشون میده وقتی پست تصویر شاخص داره

    <?php the_post_thumbnail('thumbnail');  if(isset($image) && !empty($image)) {echo '<img src="'.get_post_meta($post->ID, 'image',true).'" class="post-pic"/>' ;} else {echo '<img src="'.get_bloginfo("template_url").'/images/none-pic.jpg" class="post-pic"/>' ;}?>
      خوب دوست عزیز شما می تونی از کد زیر به جای کدی که دادی استفاده کنی و دو تا تصویر نشون نده:
      <?php the_post_thumbnail('thumbnail');  if(isset($image) && !empty($image)) {echo '<img src="'.get_post_meta($post->ID, 'image',true).'" class="post-pic"/>' ;}?>
  • danial

    آفلاین
    عضو
    تعداد نوشته‌ها: ۹۵
    تشکر شده: ۱۲ بار
    # نوشته شده: ۷ سال پیش
    ۲۴ خرداد ۱۳۹۱ - ۱۹:۲۳

    ممنون ولی
    کد اول رو توی فانکشن گذاشتم ارور داد و قالب بالا نیومد
    کد دومم همون کد خودم بود قسمت ادرس عکس پاک کرده بود دوستمون
    کسی نمیدونه چی کار کنم

  • امید

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۱
    تشکر شده: ۱۸ بار
    # نوشته شده: ۷ سال پیش
    ۲۵ خرداد ۱۳۹۱ - ۰۹:۰۸

    کد من مشکی نداره(سینتاکس)
    توی Function نباید بذارید که! توی قسمتی باید بذارید که تصویر شاخص نمایش داده میشه(جایگزین کنید با قبلیه)
    توی تم باید بذارید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    danial

درباره‌ی این موضوع



برچسب‌ها

هیچ برچسبی نیست.