انجمن


پلاگین Google friend connect مخصوص وردپرس  (۸ نوشته)

  • میثم الله‌داد

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۵
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۱ اسفند ۱۳۸۸ - ۰۳:۴۱

    در Google friend connect قسمت Plug-ins & APIs افزونه‌ای برای وردپرس هست به همراه دو پلاگین دیگه:
    Drupal Login Plugin
    و
    phpBB Login Plugin
    این افزونه‌ها به شما این اجازه رو می‌دن که کسی که می‌خواد کامنت بذاره برای پست‌هاتون بتونه از یه آی دی خودش (یاهو، گوگل، توئیتر، فیسبوک و...) وارد بشه و با اون کامنت بذاره. یعنی یه چیزی شبیه این شکل.
    ولی متأسفانه وقتی روی این افزونه کلیک می‌کنم یه پیغام خطای Forbidden می‌گیرم. افزونه اینجا هست.
    یا من راه رو اشتباه رفتم، یا این امکان وجود نداره برای همه‌ی کاربران.
    اگر کسی بلده کمکم کنه. ضمن این‌که این آقا رفته و به نتیجه هم رسیده و توضیح انگلیسی به همراه شکلش رو در قسمت سوم این مطلب داده.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    Arsam_Arsam - sadeghjam - hamid2day
  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۹ سال پیش
    ۱۱ اسفند ۱۳۸۸ - ۰۹:۵۵

    شاید این افزونه کارتون رو راه بندازه: http://wordpress.org/extend/plugins/google-friend-connect-integration/

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    hamid2day
  • میثم الله‌داد

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۵
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۱ اسفند ۱۳۸۸ - ۱۳:۱۸

    Gonahkar گفت:
    شاید این افزونه کارتون رو راه بندازه: http://wordpress.org/extend/plugins/google-friend-connect-integration/

    این افزونه رو امتحان کردم و اونی که می‌خواستم از توش در نیومد. ولی این‌قدر گشتم تا این متن رو پیدا کردم. آخر متنش توی قسمت گوگل کد و این‌ها به نحوه نصب پلاگین لینک داده که اینجاست. گفته که می‌تونید پلاگینش رو از اینجا بگیرید و نحوه‌ی نصبش رو نشون داده. همچنین دو تا سایت نمونه هم نشون داده که توی قسمت کامنت‌هاش می‌شه این ابزار رو استفاده کرد که می‌تونیم یکی‌اش رو که من هم می‌خوام مثل این در بیارم (به قول خودش Native Comment داشته باشه) رو اینجا ببینیمش. اون یکی رو که Native Comment نداره رو اینجا می‌شه دید.
    من هم طبق دستورش رفتم جلو و نصبش کردم. اتفاقاً نشست سر جایی که باید بشینه. ولی یه مشکل بزرگی دارم باهاش و اون‌هم اینه که کامنت‌های قبلی‌ام ناپدید شدند و نحوه‌ی قبلی کامنت‌گذاری رو هم از بین برده. یعنی فقط باید Sign-in کنی یا ناشناس کامنت بذاری. به قولی، فرم کامنت رو حذف کرده! مثلاً این پست من 39 کامنت داشت ولی الآن شده صفر و فرم کامنت گذاری هم ناپدید شده. شده شبیه همون بدون Native Comment. اگر درست بشه به نظر من فوق‌العاده است و حتی ارزش فارسی‌سازی هم داره.
    من دارم بین این همه کد گم می‌شم!

  • میثم الله‌داد

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۵
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۱ اسفند ۱۳۸۸ - ۱۳:۳۲

    ایول! آقا درست شد. یه تیک کوچیک توی ستینگش داشت که توی خط اول اینجا توضیحش داده. خیلی جالبه. خیلی جالبه.
    پیشنهاد می‌کنم این افزونه رو معرفی کنید و حتی اگر می‌شه دوستان فارسی‌سازی‌اش کنن. اینجا همه‌ی نسخه‌هاش هست:
    http://code.google.com/p/wp-gfc/downloads/list
    نمونه‌ی تکمیل شده‌اش رو هم می‌تونید توی وبلاگ خودم ببینید. اینجا توی کامنت‌ها:
    http://maysam.allahdad.com/?p=635#

    موفق و پیروز باشید.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    sadeghjam
  • sadeghjam

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۱
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۱ اسفند ۱۳۸۸ - ۱۷:۲۹

    ممنون بابت معرفی این افزونه :) منم نصبیدمش و بدون مشکل ازش استفاده می‌کنم

  • میثم الله‌داد

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۵
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۷ اسفند ۱۳۸۸ - ۱۵:۵۶

    راستش من حین کار با یه مشکلی مواجه شدم. کامنت که برای خودم می‌ذارم، یا پست می‌ذارم موقع ارسال یه ارور بهم می‌ده، هر چند پست می‌شه. فکر می‌کنم توی تشخیص بین این که من بالاخره ادمین سایت هستم یا ادمین گوگل فرند کانکت گیر می‌کنه. آخر سر هم موقع کامنت گذاشتن عکسم رو نشون نمی‌ده. این متن ایرادیه که می‌گیره:

    PHP Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in C:\host adress\wp-content\plugins\googlefriendconnect\osapi\osapi.php on line 53

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۹ سال پیش
    ۱۹ اسفند ۱۳۸۸ - ۱۴:۲۰

    این افزونه به PHP5 احتیاج داره. شما از کدوم نگارش PHP استفاده می‌کنین؟

  • میثم الله‌داد

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۵
    تشکر شده: ۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۹ اسفند ۱۳۸۸ - ۱۷:۴۲

    ورژنش قدیمی‌تر هست متأسفانه:
    PHP Version 4.4.6
    من سعی می‌کنم ارتقاء‌اش بدم و بعد مجدد مزاحم بشم.
    ممنونم واقعاً.

درباره‌ی این موضوع