انجمن


مشکل نصب buddypress در وردپرس نسخه 3  (۱۴ نوشته)

  • مصطفی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۲۳ بار
    # نوشته شده: ۹ سال پیش
    ۹ مرداد ۱۳۸۹ - ۱۹:۰۴

    سلام، از اونجا که از نسخه 3 وردپرس ویژگی چندکاربره بهش اضافه شده فکر نمی کنم این پست خلاف قوانین باشه. درضمن خیلی به چندکاربره بودنش هم ربط نداره.
    من می خوام تو وردپرس نسخه 3 (multisite) پلاگین buddypress نگارش 1.2.5.2 رو نصب کنم. متاسفانه موقع فعال کردنش این پیغام رو می ده:

    به‌دلیل داشتن مشکلی جدیافزونه فعال نشد.
    Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 19456 bytes) in /home/vol3/gigfa.com/gigfa_5996567/htdocs/wp-content/plugins/buddypress/bp-groups.php on line 90

    البته خیلی جاها دنبالش گشتم،اما همه می گن مربوط به php_value memory_limit هست و باید زیادش کرد. دو تا راه حل هم دادن
    1. یه همچین خطی(php_value memory_limit 64M) رو به فایل .htaccess اضافه کنم
    2. یا یه خط define('WP_MEMORY_LIMIT', '64M'); رو به فایل wp-config.php اضافه کنم

    ولی هیچ کدو از اینها جواب نمی ده. من از هاست رایگان gigfa.com استفاده می کنم و اونا مقدار حافظه رو برای php اضافه نمی کنن. آیا راه حل دیگه ای نداره؟

    مثلا اگه bbpress رو که الان همراه این buddypress اضافه شده از توش بردارم نمی شه که درست بشه؟ (چجوری باید اینکار رو انجام داد؟)

  • babakrz

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۲
    تشکر شده: ۳۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۰ مرداد ۱۳۸۹ - ۰۸:۴۷

    این کد رو توی یه فایل با پسوند php کپی کن و اجرا کن ببین که memory_limit رو چقدر نعیین کردن.
    <?php
    phpinfo();
    ?>

    معمولا کد php_value memory_limit 64M که توی .htaccess قرار بدین مشکل حل میشه و اون فایل رو در root سایتتون قرار بدین، مگر اینکه دسترسی شما رو محدود کرده باشن و اجرای کدهای داخل .htaccess هم غیر فعال شده باشه. در این صورت هیچ کاری نمیتونین بکنین.

    pooras گفت:
    البته خیلی جاها دنبالش گشتم،اما همه می گن مربوط به php_value memory_limit هست و باید زیادش کرد. دو تا راه حل هم دادن
    1. یه همچین خطی(php_value memory_limit 64M) رو به فایل .htaccess اضافه کنم
    2. یا یه خط define('WP_MEMORY_LIMIT', '64M'); رو به فایل wp-config.php اضافه کنم

    ولی هیچ کدو از اینها جواب نمی ده. من از هاست رایگان gigfa.com استفاده می کنم و اونا مقدار حافظه رو برای php اضافه نمی کنن. آیا راه حل دیگه ای نداره؟

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    مصطفی
  • مصطفی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۲۳ بار
    # نوشته شده: ۹ سال پیش
    ۱۰ مرداد ۱۳۸۹ - ۱۳:۱۸

    کدی که گفتین رو اجرا کردم. مقدار رو ۲۴M می زنه.

    من دسترسی به htaccess دارم و اون کد رو همونطوری که قبلا هم گفتم بهش اضافه کردم ولی تاثیری نداشت. یه جا خونده بودم چند ساعت طول می کشه تا اثر کنه! درسته؟ به هر حال بعدشم دوباره رفتم اون مقدار 24m تغییری نکرده بود.

    راستی من برای تست، وردپرس (روی سایت اصلیم) رو به حالت تک کاربره برگردوندم، بعدش با غیرفعال کردن یه پلاگین (wassup) تونستم buddypress رو فعال کنم!! انگار این چندکاربره بودن، خیلی حافظه می بره.

    البته یه حالت دیگه رو هم تست کردم. تو یه ساب دومین دیگه که جدید ساختم، همین وردپرس 3 رو نصب کردم، چند کاربره بودنش رو هم فعال کردم، اتفاقا بعدش هم روش buddypress رو تونستم فعال کنم!!!!
    واسم عجیبه که چرا تو یه نصب تازه از وردپرس این کار شدنیه، ولی تو سایت اصلیم نه... یه سوال دیگه : حجم اطلاعاتی که از قبل روی سایتم بوده هم تاثیر داره؟ مثلا من تو سایتم حدود 100 تا پست و 200 تا نظر دارم...می تونه ربطی داشته باشه؟

  • babakrz

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳۲
    تشکر شده: ۳۶ بار
    # نوشته شده: ۹ سال پیش
    ۱۰ مرداد ۱۳۸۹ - ۱۵:۳۰

    آره میتونه به همه چی ربط داشته باشه.
    چون وقتی یک صفحه وردپرس لود میشه همه توابع رو لود میکنه و هزارتا چیز رو چه استفاده بشه و چه نشه همراهش میاره تو حافظه. من قبلا این مشکل رو تو لود صفحه اصلی مدیریت سایتم داشتم که با همین کد که توی .htaccess قرار دادم درست شد. برای من که طول نمیکشه و فورا مقداری که براش میذارم رو فورا در لود صفحات اعمال میکنه. فعلا 64 گذاشتم و همه چی خوبه در صورتی که از طرف میزبانم این مقدار 32 هست که عملا دسترسی به مدیریت وردپرسم با 32 وجود نداشت.
    من فکر میکنم اجازه اجرای .htaccess شما رو محدود کردن.این دستور رو (AllowOverride All) ابتدای .htaccess بنویس ببین میشه کلک زد؟! فکر نکنم بشه و شاید شد. احتمالا اونها AllowOverride None تعریف کردن ): که معمولا فقط برای CGI-BIN تعریف میشه.
    بد نیست این رو هم امتحان کنی:
    ini_set('memory_limit', '64M');
    رو توی wp-comfig.php بزار و توی wp-settings.php همون اولش که مربوط به حافظه میشه رو عیر فعال کن و ببین چی میشه.

    دیگه چیزی به فکرم نمیرسه.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    مصطفی
  • مصطفی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۲۳ بار
    # نوشته شده: ۹ سال پیش
    ۱۰ مرداد ۱۳۸۹ - ۲۲:۳۸

    اون htaccess و wp-config رو انجام دادم تغییری نکرد، اونی که درمورد wp-setting گفته بودی رو هم دقیقا پیدا نکردم. در کل فکر نمی کنم جواب بده، چون یه بارم از هاست پرسیدم گفتن برای اکانت های free نمی شه اضافه بشه!
    امکانش هست بگی هاستی که ازش استفاده می کنی چیه یا هاستی رو می شناسی که اکانت های free با memory-limit بالا داشته باشن؟

  • پدرام

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۳۰
    تشکر شده: ۱۵۶ بار
    # نوشته شده: ۸ سال پیش
    ۲ آبان ۱۳۸۹ - ۱۵:۰۳

    اقا منم این مشکل رو دارم و دقیقا همین پیغام رو میده پ

    حجم اطلاعاتی که از قبل روی سایتم بوده هم تاثیر داره؟ مثلا من تو سایتم حدود 100 تا پست و 200 تا نظر دارم...می تونه ربطی داشته باشه؟

    فکر نمیکنم چون سایت من تقریبا هیچ پستی نداره . ...

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    milad200
  • پدرام

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۳۰
    تشکر شده: ۱۵۶ بار
    # نوشته شده: ۸ سال پیش
    ۲ آبان ۱۳۸۹ - ۲۲:۵۸

    مشکل من هم بالا مطرح شده .. اما یه بار دیگه در کل مینویسم

    هنگام فعال کردن بعضی از افزونه ها با این پیغام مواجه میشم :

    به‌دلیل داشتن مشکلی جدیافزونه فعال نشد.
    Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 19456 bytes) in /home/vol3/gigfa.com/gigfa_5996567/htdocs/wp-content/plugins/buddypress/bp-groups.php on line 90

    من تو فعال کردن افزونه buddypress و GD Star Rating با این مشکل برخوردم

    اطلاعات :
    نسخه وردپرس : 3.0.1
    نوع هاست : رایگان گیگفا
    نسخه افزونه ها : اخرین ورژن
    تعداد افزونه های فعال : 13
    تعداد پست ها : 6
    تعداد نظرات : 4
    تعداد کاربران : 2 با خودم
    ... دیگه همه چی رونوشتم ... تو پاسخ دادن خواهشا کم نزارید .... چون ما دو هزاریمون کجه

  • مصطفی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۲۳ بار
    # نوشته شده: ۸ سال پیش
    ۲ آبان ۱۳۸۹ - ۲۳:۲۸

    دوست عزیز، همونطوری که قبلا گفته شد، این خطا مربوط به محدودیت حافظه برای اجرای اسکریپت های php تو هاست هست. معمولا هم این خطاها توی هاست های رایگان اتفاق میافته. خصوصا اکانت های رایگان مثل گیگفا که 24 مگابایت حافظه به پارامتر memory_limit توی فایل php.ini سرور برای اکانت های رایگان تعریف می کنن.

    هرچی تعداد افزونه هایی که استفاده می کنی بیشتر بشه، این مقدار حافظه هم بیشتر مصرف می شه و دیگه از یه حدی به بعد، هر افزونه ای که بخوای فعال کنی(فرقی نمی کنه چی باشه) چون حافظه کافی برای اجرای کدهاش وجود نداره با این خطا روبرو می شه و فعال نمی شه.

    علت مشکل با buddypress و اروری که معمولا برای فعال کردن اون میاد اینه که کلا حافظه مورد نیاز این افزونه به دلیل حجیم بودنش و سنگین بودنش زیاده(حتما می دونید که buddypress چقدر امکانات داره و تازه روی اون هم باز افزونه نصب می شه!). بنابراین تو هاست های رایگان اکثرا با این خطا مواجه می شید.
    البته حجم مصرفی memory_limit شما فقط به تعداد افزونه ها وابسته نیست. هرچی سایتتون قدیمی تر باشه و پست ها و دیدگاه هاش بیشتر، مصزف شما هم بالاتر.

    اما چند تا راه حل:

    1- هاست رایگان رو بی خیال بشید و یه هاست بخرید. نتیجتا شما حجم memory_limit بیشتری رو خواهید داشت.
    2- تو همون گیگفا اگه می خواید حداقل یه بار اجرای همزمان وردپرس 3.0.1 و buddypress رو ببینید می تونید یه ساب دومین(البته بازم باید یه پولی از قبل واسه دومین داده باشید!) درست کنید. بعدش یه وردپرس تازه نصب کنید و بعدش قبل از هر کاری buddypress رو نصب کنید و بعد از اون به کارتون ادامه بدید.(اینو خودم تست کردم، جواب می ده)
    3- اما اگه می خواید کلا مفت تموم بشه! این کار احتمالا جواب می ده(خودم تست نکردم، مسئولیتش با خودتونه ولی چیزی هم نمی شه) البته طبیعتا زحمت زیادی هم داره:
    اول از همه نوشته ها و دیدگاه ها پشتیبان تهیه کنید. بعد بیاید کلا وردپرستون+ فایل هاش+ دیتابیس رو کاملا پاک کنید!! و روز از نو روزی از نو.....(البته نیازی به پاک کردن همه فایل ها نیست ولی اینجوری مطمئن تره)
    بعد دوباره دیتابیس درست کنید، فایل های وردپرس رو آپ کنید، نصبش کنید و......اول از همه buddypress رو نصب کنید. بعد مطالب خودتون رو وارد کنید و بعدش دونه دونه افزونه ها رو آپ و فعال کنید. تا به اون خطا برسید.
    مطمئنا افزونه های کمتری رو می تونید نصب کنید.

    نکته مهم: این روش آخر چون حجم مصرف حافظه php سرور رو بخاطر buddypress بالا می بره، پایداری سایتتون رو هم کم می کنه. یعنی ممکنه یهو بعد از یه مدت استفاده و افزایش حجم دیتابیس، سایتتون بالا نیاد! یا صفحه سفید نشون بده. اگه اینطوری شد، افزونه هایی که واستون مهم نیست رو از ftp تغییر نام بدید تا غیرفعال بشن و حافظه خالی بشه. اگه بازم بالا نیومد نهایتا خود buddypress رو تغییر نام بدید تا دیگه 100% بالا بیاد.

    اینم صفحه مربوط به اطلاعات php.ini اکانت رایگان گیگفا. توش دنبال memory_limit بگردید، جلوش نوشته 24M

    پدرام جان، خوب بود؟ کم نگذاشتم که؟!

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    پدرام - milad200 - Mostafa
  • پدرام

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۳۰
    تشکر شده: ۱۵۶ بار
    # نوشته شده: ۸ سال پیش
    ۲ آبان ۱۳۸۹ - ۲۳:۴۰

    اقا دمت گرم ممنون
    به قولی ترکوندی
    فقط یه چیزی اینجا درست در نمیاد
    چون تو خود وگیگفا تو قسمتی که میخوای هاست رایگان درست کنی نوشته :

    اختصاص 50 عدد ديتابيس MySQL ( فضای هر دیتابیس : 50 مگابایت )

    حالا ای ن ارور میگه فضا 24 مگابایت هست ... !

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۸ سال پیش
    ۳ آبان ۱۳۸۹ - ۱۳:۰۷

    اونطوری که مصطفی مطرح کنید بنظرم باید بیخیال هاست رایگان بشین!
    چون در آینده مشکل ساز می شه. چون بادی پرس خودش هم افزونه جداگانه داره ;)

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    پدرام
  • پدرام

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۳۰
    تشکر شده: ۱۵۶ بار
    # نوشته شده: ۸ سال پیش
    ۳ آبان ۱۳۸۹ - ۱۳:۱۳

    ممنون .. ما که فهمیدیم مشکل چیه و حل شد

  • مصطفی

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۶
    تشکر شده: ۲۳ بار
    # نوشته شده: ۸ سال پیش
    ۳ آبان ۱۳۸۹ - ۱۸:۲۶

    pedramass گفت:
    اقا دمت گرم ممنون
    به قولی ترکوندی
    فقط یه چیزی اینجا درست در نمیاد
    چون تو خود وگیگفا تو قسمتی که میخوای هاست رایگان درست کنی نوشته :

    اختصاص 50 عدد ديتابيس MySQL ( فضای هر دیتابیس : 50 مگابایت )

    حالا ای ن ارور میگه فضا 24 مگابایت هست ... !

    دوست عزیز این مقدار حافظه ی ۵۰ مگابایت مربوط به دیتابیس mysql شماست. عملا مدت زیادی هم طول می کشه تا حجم دیتابیستون بخواد به ۵۰ برسه. اما این ۵۰ مگابایت با اون ۲۴ مگابایتی که گفتم کلا فرق می کنه. اون ۲۴ مگابایت حافظه اجرایی برای اجرای اسکریپت های php هست.
    این مقدار رو هم خود گیگفا گفته دیگه! لینکشو که دادم.

    اما اگه بخوام خلاصه کنم...اون ۵۰ مگابایت یجورایی(نه دقیقا) مقل هارد شماست و اون ۲۴ مگابایت هم رم شما.
    برای همین هم شما نمی تونی بیش از حد افزونه رو همزمان فعال کنی چون اون ۲۴مگابایت(یا رم شما) جای کافی برای اجرای همزمان همشون نداره.

    راستی مشکلت رو چجوری حل کردی؟ کلا هاست رو عوض کردی؟

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    پدرام
  • پدرام

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۳۰
    تشکر شده: ۱۵۶ بار
    # نوشته شده: ۸ سال پیش
    ۳ آبان ۱۳۸۹ - ۲۲:۳۱

    نه بابا منظورم از حل شدن این بود که فهمیدم چرا این خطا رو میده
    من اگه پول داشتم هاست بخرم ... از گیگفا استفاده نمیکردم

  • kits

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۲۵
    تشکر شده: ۷۰ بار
    # نوشته شده: ۸ سال پیش
    ۲۲ دی ۱۳۸۹ - ۰۳:۰۱

    آقا مصطفي ميشه فايل ترجمه بادي پرس كه خودت به طور كامل ترجمه كردي را برا دانلود بذاري

    ممنون

درباره‌ی این موضوع