انجمن


مشکل در نمایش تاریخ  (۴ نوشته)

  • malim

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱
    # نوشته شده: ۱۱ سال پیش
    ۲۵ تیر ۱۳۹۰ - ۱۳:۱۶

    سلام
    من مشکلی برای نمایش تاریخ در وردپرس دارم. در واقع سایت من دوزبانه هست. وقتیکه وردپرس جلالی رو نصب کردم، برای بخش فارسی به درستی تاریخ رو نمایش میده. ولی برای بخش انگلیسی هم تاریخ هجری شمسی رو نشون میده!

    برای نمایش تاریخ در بخش فارسی: <?php echo mps_the_jdate(100, 'j / F / Y') ?>
    برای نمایش تاریخ در بخش انگلیسی: <?php the_date();?>

    ولی با اینحال هم در بخش فارسی و هم در بخش انگلیسی، تاریخ به هجری شمسی نشون داده میشه
    ممنون میشم راهنمایی کنید که برای حل این مشکل چه کار باید انجام دهم.
    با تشکر

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۱۱ سال پیش
    ۲۵ تیر ۱۳۹۰ - ۱۴:۱۱

    سلام، ورودتون رو به انجمن تبریک می‌گم. اینو بررسی کنید:
    <?php echo date(get_option('date_format')); ?>
    اگر تابعی برای تشخصی زبان باشه، میشه باید شرط مشکل رو حل کرد!

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    malim
  • kamrani68

    آفلاین
    عضو
    تعداد نوشته‌ها: ۳
    # نوشته شده: ۱۰ سال پیش
    ۱۵ مهر ۱۳۹۰ - ۰۰:۰۹

    من هم مشکل در نمایش تاریخ دارم.
    وقتی کدهای پوسته توی بخش index رو خوندم دیدم کدی برای تاریخ تعریف نشده!!
    الان چیکار باید بکنم؟

    در ضمن یه مشکل دیگه ای هم توی پوسته من هست،این که وقتی مطلبی با عکس می ذارم خود به خود عکس وارد ادامه مطلب میشه.
    با این مشکل چیکار کنم؟!!
    در ضمن ویرایش کد ها رو هم بلد نیستم!!
    ممنون.

  • Mostafa

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۵۲۷۶
    تشکر شده: ۵۷۷۷ بار
    # نوشته شده: ۱۰ سال پیش
    ۱۸ مهر ۱۳۹۰ - ۱۹:۵۹

    من هم مشکل در نمایش تاریخ دارم.
    وقتی کدهای پوسته توی بخش index رو خوندم دیدم کدی برای تاریخ تعریف نشده!!
    الان چیکار باید بکنم؟

    سلام، ورودتون رو به انجمن تبریک می‌گم.
    نیازی به تعریف تابع نیست! تابع زمان رو فراخوانی کنید، مشکلی پیش نمیاد.
    ولی تابع the_date و the_time رو باید درون حلقه loop قرار بدین تا تاریخ نوشته رو مشخص کند.

    در ضمن یه مشکل دیگه ای هم توی پوسته من هست،این که وقتی مطلبی با عکس می ذارم خود به خود عکس وارد ادامه مطلب میشه.
    با این مشکل چیکار کنم؟!!
    در ضمن ویرایش کد ها رو هم بلد نیستم!!
    ممنون.

    در single.php به جای تابع the_content از تابع the_excerpt استفاده کنید.

درباره‌ی این موضوع