انجمن


مشکل با صفحه ی بعدی /صفحه قبلی  (۲۱ نوشته)

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۱۹ خرداد ۱۳۸۷ - ۱۸:۲۶

    سلام دوستان، من از قالب Daleri استفاده می کنم. البته قالبی که از وردپرس داونلود کردم کمی مشکل داشت که با کمی دستکاری الان کار می کند. تنها مشکل این است که صفحه های قبلی/بعدی کار نمی کند و اگر روی این لینک ها کلیک کنم ارور 404 می گیرم. نمی دونم چکار کنم که این مشکل حل شود...
    ممنون می شم اگه کسی کمک کنه... این آدرس وبلاگ من: http://freelantern.com/p است و این هم کد index.php:

    <?php get_header(); ?>
    
    <div id="content">
    <?php if (have_posts()) : ?><?php while (have_posts()) : the_post(); ?>
    
    <div class="post">
    
    <h2><a href="<?php the_permalink() ?>" title="<?php the_title(); ?>"><?php the_title(); ?></a></h2>
    <p class="timestamp"><?php the_time('j, n, Y') ?> | <?php the_category(', '); ?> | نوشته : <?php the_author(); ?> | <?php comments_popup_link( 'بدون کامنت', 'یک کامنت', '% کامنت', '', ''); ?><?php edit_post_link('[e]',' | ',''); ?></p>
    
    <div class="contenttext">
    <?php the_content('<p><strong> ادامه این مطلب &raquo;</strong></p>'); ?>
    </div>
    </div>
    
    <?php endwhile; ?>
    
    <div class="postpagesnav">
    <div class="older"><?php next_posts_link('&laquo; نوشته‌های پیشین') ?></div>
    <div class="newer"><?php previous_posts_link('نوشته‌های پسین &raquo;') ?></div>
    <br class="clear" />
    </div>
    
    <?php else : ?>
    <h2>پیدا نشد - خطای 404</h2>
    <p>نوشته‌ی مورد نظر پیدا نشد، ممکن است آدرس مورد نظر را اشتباه وارد کرده باشید.</p>
    <?php endif; ?>
    
    </div>
    
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>
  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۹ خرداد ۱۳۸۷ - ۱۸:۳۸

    عجیبه . به نظر همه چیز درست میاد ! روی تم پیش فرض هم مشکل دارید ؟

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۱۹ خرداد ۱۳۸۷ - ۱۹:۳۴

    ممنون از جواب سریعت... الان تست کردم بله همون اشکال 404 رو میده تنها فرقش اینه که به فارسی اشتباه رو می نویسه چون در قالب من قالب 404 ترجمه نشده!

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۰ خرداد ۱۳۸۷ - ۱۷:۱۸

    می شه فرمت و ساختار پیوند های ثابتتون رو اینجا قرار بدید ...

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۲۰ خرداد ۱۳۸۷ - ۱۹:۰۰

    به روی چشم:
    من از custom structure استفاده می کنم و این فرمتش هست:

    /index.php/archive/%postname%/

    خودم هم فکر کردم که اشکال شاید از این باشه ولی در وبلاگ انگلیسی ام از همین ساختار استفاده می کنم و اونجا چنین مشکلی وجود نداره.

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۱ خرداد ۱۳۸۷ - ۰۸:۰۶

    عجیبه. اون /archive رو پاک کنید ببینید درست می شه یا نه :-?

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۲۱ خرداد ۱۳۸۷ - ۱۴:۰۶

    ممنون از پیگیریت نوید جان.
    اون رو پاک کردم باز هم همون مشکل هست... البته برگردوندم به حالت اول بخاطر لینک هایی که به وبلاگ داده شده... ممکنه اشکال از htaccess باشه؟
    دارم حسابی کلافه می شم نمی تونم سر دربیارم مشکل کجاست.

  • navid

    آفلاین
    ناظم
    تعداد نوشته‌ها: ۲۷۱۸
    تشکر شده: ۲۹۸ بار
    # نوشته شده: ۱۲ سال پیش
    ۲۲ خرداد ۱۳۸۷ - ۱۷:۵۳

    مشکل عجیبه . البته این هاست های netfirms کلا به درد وردپرس نمی خوره ... من چند وقت پیش یکی گرفتم همونطوری ولش کردم تا تموم شد !

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۲۲ خرداد ۱۳۸۷ - ۲۰:۱۴

    خود نت فرمز البته امکان نصب وردپرس رو می ده ولی آخه مشکل اینجاست که من در وبلاگ انگلیسیم که از همین قالب (فقط انگلیسیش) استفاده می کنه چنین مشکلی نداره... انگار هیچ کس دیگری هم این دور و برا نیست که نظری داشته باشه... کلافه شدم واقعا!

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۲ تیر ۱۳۸۷ - ۰۲:۲۲

    ساختار پیوند پایدارتون رو به حالت پیش‌فرض و اولیه وردپرس برگردونین ببینین باز هم مشکل هست یا نه؟

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۶ تیر ۱۳۸۷ - ۱۸:۵۵

    ممنون از جوابت گناهکار جان... مشکل وقتی به پیش فرض برمی گردم حل می شه... راهی هست که بتونم ساختار لینک رو قشنگ نگه دارم و در عین حال این مشکل رو نداشته باشم؟ از طرف دیگه اگه به پیش فرض برگردم همه لینک های ورودی به وبلاگم خراب می شه نه؟

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۷ تیر ۱۳۸۷ - ۱۲:۵۱

    آره٬ اگه با ساختار قبلی لینک داده باشن خراب می‌شه٬ به‌نظرم فایل htaccess رو خودت دستی بساز٬ ببین جواب می‌ده یا نه.

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۹ تیر ۱۳۸۷ - ۱۴:۲۱

    آقا این محتویات الان htaccess من است، چی رو به نظرت تغییر بدم؟

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /p/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /p/index.php [L]
    </IfModule>
    
    # END WordPress

    ترجیح می دم که ساختار لینک ها رو تغییر ندم اگه بشه به یک شکل دیگری اصلاح کرد این مشکل رو... جالب اینه که من همین قالب رو در وبلاگ انگلیسیم استفاده می کنم و چنین مشکلی نداره...

  • گناهکار

    آفلاین
    کلیددار
    تعداد نوشته‌ها: ۳۵۳۵
    تشکر شده: ۲۵۴۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۹ تیر ۱۳۸۷ - ۱۷:۱۵

    والا مشکلی نداره در ظاهر این فایل، من فکر کردم ممکنه فایل اصلن ساخته نشده باشه یا اینکه خالی باشه.

    فولدر وبلاگت رو امتحانی عوض کن ببین مشکل همچنان ‍ابرجاست یا نه.

    کاربران زیر به‌خاطر این نوشته تشکر کرده‌اند:
    sadegh3333
  • babak220

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۶
    تشکر شده: ۴ بار
    # نوشته شده: ۱۲ سال پیش
    ۱۰ تیر ۱۳۸۷ - ۰۱:۵۹

    نام پست ها را در وبلاگ فارسی ، فارسی می‌نویسید؟
    شاید مشکل از اون باشه.
    یک پست تست بزنید و نامش را انگلیسی بگذارید ببینید درست می‌شود؟

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۱۰ تیر ۱۳۸۷ - ۱۱:۳۰

    babak220 گفت:
    نام پست ها را در وبلاگ فارسی ، فارسی می‌نویسید؟
    شاید مشکل از اون باشه.
    یک پست تست بزنید و نامش را انگلیسی بگذارید ببینید درست می‌شود؟

    نه همه اسم پست ها رو انگلیسی می نویسم.

  • Alius

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۷
    # نوشته شده: ۱۲ سال پیش
    ۱۰ تیر ۱۳۸۷ - ۱۲:۱۰

    فولدر وبلاگت رو امتحانی عوض کن ببین مشکل همچنان ‍ابرجاست یا نه.

    گناهکار جان منظورت اینه که کل وبلاگ رو در یک آدرس دیگه پابلیش کنم؟ امروز بعد از کار امتحان می کنم ببینم مشکل حل می شه یا نه... ممنونم از پی گیریت

  • thenext

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲
    # نوشته شده: ۹ سال پیش
    ۲۱ اردیبهشت ۱۳۹۰ - ۱۹:۰۱

    حل مشکل لینک های صفحات دسته بندی وردپرس : صفحه بعدی > 1 2 3 4 < صفحه قبلی
    این مشکل هنگامی رخ می دهد که شما پس از استفاده از افزونه هایی که شماره صفحه ایجاد میکنند و از دست برقضا شما حتما می خواهید که آدرس پیوندهای یکتا را بصورت ساختاری دلخواه ( هر ساختاری که فکرشو بکنی!) ایجاد کنید بوجود می آید. مشکل دقیقا در آدرس های صفحات 2 به بعد دسته بندی بوجود می آید و تمامی / (اسلش ها) تبدیل به
    %2F
    می شود. به عنوان مثال اگر ساختار دلخواه این باشه
    /detail=%post_id%
    بعد از اعمال تغییرات تمامی لینکهای مربوط به دسته بندی از صفحه 2 به بعد تبدیل به این می شود
    http://www.example.com%2Fdetail%2Fnews%2Fpage%2F2
    در اینجا باید بگم که
    %2F
    همون یونیکد / (اسلش) است اما مرورگر تقصیری ندارد و آن را به / (اسلش) ترجمه نکرده و در نتیجه صفحات شما در 2 3 4 ... بدین شکل در می آید که با خطا مواجه خواهد شد. (فقط صفحه اولی کار میکنه)
    چه باید کرد؟
    خیلی آسونه : )
    شما از ساختار دل خواه یعنی پیوند یکتا استفاده کردید اما پیوند یکتای دسته ها رو بیخیال شدید
    !!!
    فقط کافیه در قسمت مبنای دسته یک مقدار مثلا کلمه
    categoooory
    را استفاده کنید و ذخیره تغییرات رو بزنید. یادتون باشه فقط مبنای دسته رو اعمال کنید
    خب دیگه حله : )
    سالها بود سایتهای خارجی روشهای عجیب و غریبی می دادن که اگه یک کمی براتون بگم که کدوم کدهای بی زبون وردپرس رو دستکاری میکردن! کله شما سوت خواهد کشید O:
    یا دستکاری فایل
    htaccess.
    بدبخت!
    مت (سازنده وردپرس) کجایی که ببینی.... که با وردپرست چه کردند
    موفق باشید

  • MooCHooL

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۰
    # نوشته شده: ۸ سال پیش
    ۱۰ آذر ۱۳۹۰ - ۱۵:۱۱

    منم همین مشکلو دارم...

    http://hashemi-co.com/topics/%D8%AA%D8%B1%D8%A7%D8%B4/%D9%86%D9%88
    توی بعضی از موضوعات ،صفحه ی دوم نمیره!

  • MooCHooL

    آفلاین
    عضو
    تعداد نوشته‌ها: ۲۰
    # نوشته شده: ۸ سال پیش
    ۱۰ آذر ۱۳۹۰ - ۱۵:۲۵

    حل مشکل صفحات قبل و بعد وبلاگ

    http://forum.wp-persian.com/topic/17407?replies=1

  • gentelman

    آفلاین
    عضو
    تعداد نوشته‌ها: ۱۱
    # نوشته شده: ۶ سال پیش
    ۳ آذر ۱۳۹۲ - ۲۳:۱۶

    فقط کافیه در قسمت مبنای دسته یک مقدار مثلا کلمه
    categoooory
    را استفاده کنید و ذخیره تغییرات رو بزنید. یادتون باشه فقط مبنای دسته رو اعمال کنید
    خب دیگه حله : )

    من اصلا متوجه نشد منظورتونو..باید دقیقا کجا رفت و چیکار کرد ؟؟؟

درباره‌ی این موضوع



برچسب‌ها